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Redes Coloridas

1. Explorar as simetrias com o objetivo de reduzir o tamanho da rede.

Falha: o grafo é reduzido mas a informacao para para as inscricoes a
complexidade da representacao nao se altera significativamente

2. Ter uma representacao abstrata para a rede classica.
Falha: verdade em principio, mas ter que reduzir a representacao para
rede classica cada vez que deseja fazer analise de propriedades

pode nao ser exatamente uma vantagem.

3. Aumentar o poder de expressao da representacao baseada em
redes.

Falha: simplesmente nao é verdade.

- Prof. José Reinaldo
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Histérico das redes CPN

As redes coloridas surgiram nos anos 80 conjugando a representacao grafica
das redes de Petri com o Standard ML, que representa tipos e cores.

No final dos anos 80 e principio dos anos 90 surgiu o ambiente Dsign CPN
proposto pelo mesmo grupo de Ahus, Dinamarca (Kurt Jensen).

A idéia é simplesmente ter um formalismo mais abstrato
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Definicao informal das CPNs

Kurt Jensen

Coloured Petri Nets (CP-nets or CPNs) is a graphical
language for constructing models of concurrent systems
and analyzing their properties. CP-nets is a discrete-event
modeling language combining Petri Nets and the
functional programming language CPN ML which is based
on Standard ML.
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Aplicacoes

AplicacOes Tipicas

Protocolo de Comunicacao
Redes de Dados

Algoritmos Distribuidos

Sistemas Embarcados

Novas Aplicagcoes

Sistemas de workflow
Sitemas de manufatura
Sistemas multi-agente
Processos de negdcio

Analise de Requisitos

Prof. José Reinaldo Silva
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Uso pratico das redes CPN

Como no caso das redes classicas o uso pratico das redes CPN esta
associado a Simulacao do modelo, e portanto ao estudo de cenarios
especificos e ao processo de evolucao das marcas.

Temos portanto o mesmo problema de desenvolver métodos
alternativos de analise baseados nas propriedades da rede e fugir do
problema da atingibilidade.

Novos métodos :> Verificacao e Model checking
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Caracteristicas das redes CPN

e As marcas sao divididas em conjuntos e separadas por tipo

e A area de declaracao do sistema contém a identidade de
cada variavel assim como em declaragoes em ML

e Os arcos possuem inscrigcoes e filtros que selecionam o tipo
de marca que pode fluir por este arco.

e O comportamento dinamico € dado pelo conjunto : grafo,
inscricoes e declaracao.
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Contexto formal

Redes de Petri in i
Convencionais Inguag a

Definicao de Tipos
Manipulacao
Sintaxe

Sincronizacao de
processos
concorrentes

Kurt Jensen, An Introduction to the Practical Use of Coloured Petri
Nets, Lect. Notes in Comp. Science 1492, 1998.
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O problema do acoplamento
com recursos

O sistema S2PR pode ainda
ser acoplado de modo que
OS processos sequenciais
interferem um no outro
podendo causar atrasos e ate
deadlocks devido a falta de
recursos no momento
devido.

Fig. 1(a) S’PR &3™-order system :

Li, Z.W. and Zhou, M.C., “Deadlock resolution in
a=b=c=1.

automated manufacturing systems: A novel Petri net
approach,” Springer, London, 2009
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Introducao informal: O problema da alocacao de
recursos

Na indUstria automotiva moderna é
comum se ter varios processos ou linhas
de montagem e nestes um ou mais tipos
de automoével sendo montados em
pipeline. Isso traz um problema, que é
ter o tipo certo de insumo ou recurso no
tempo correto, para a matriz correta.

Um problema similar e igualmente
importante é ter processos homogéneos

mas compartilhando o mesmo centro de
recursos.
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Estruturacao do
problema

Three g-processes

p-processes
take Two p-processes
two s

take
onet

take
onet

Return
all
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Modelagem classica

Seja o seguinte sistema de alocacao de recursos, caracterizado
por dois processos concorrentes,

P/T

P process

—~ [0l Z

\g process

Prof. José Reinaldo Silva
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P process

Prof. José Réihal'_c:lo' Silva
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Para sintetizar uma rede uma rede colorida devemos
explorar a simetria entre os processos, isto €,
produzir um unico processo que representa tanto o
processo p como o processo g. Neste caso as
marcas passam a ser distinguiveis para representar os
dois processos.
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color U=with p | q;
color I = int;

color P = product U*I;
color E=with e;

varx : U;
vari: I;
E E 2 2'e
case x of
p=2'¢
e qg=1e
=p then 1'¢ 2.
else empty
e
3'(q.0) 2 (p.0)
g . @
(x,i) (x,i) (x,1) (X,1) (X,1) (x i) (X,1) (X,1) (x,i)
3 30 Q@)
[x=q]
If x=q
then 1°(q, 1+1)
else empty

Escola Politécnica da USP
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case x of (X,1)
p =» 2‘9
lg=>1%e
(X,1)
E P
3'e

Prof. José Réihevl._l__c"lo'_ Silva
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Disparo na rede

Binding: (2)2'(p.0) New Markin
<X=p,hib> f’(E) ‘ °
case X of case X of
p=>2e p=>2e
lg=>1e la=>Te

':2/1 2'e E
£ (3 i Dre

Prof. José Réihevl._l__c"lo'_ Silva
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Strong type

Binding:
<X=(, |I=2>

case X of
p=> 2 e
lg=>1¢e

Prof. José Réihal'_c:lo' Silva
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Outro exemplo

case X of
p=> 2 e
' q =1e

Prof. José Réihevl._l__c"lo'_ Silva
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Uma vez respeitado o tipo qualquer possibilidade pode ocorrer.

Binding: (3) 1" (p.2)+1°(p,4)+1°(q,3) Binding: (3) 1" (p.2)+1°(p,4)+1(
<X=p, i=2> P@ <X=(q, i=3> P
A1 N 1.3
case x of oy P2 case X of CON R
) =2e
lp—>2‘e Ig=>1‘e £h
q=> 1e 1 . L __/,.'1 ‘(q 3)
/ x| VP2 /ﬂ/1 : (x.i)
272 )
N/ p E CSJ P

E (S
@3‘e
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MECATRONICA
Concorréncia
Binding:
<X=p, i=2>
Binding: (3) 1'(p,2)+1"(p,4)+1°(q.,3)
<x=q,hﬂk> fj‘g'
e .
V11 (p.2)+1(q.3)
case X of
P => 2 e
lqg=>1¢e )

Prof. José Réihevl._l__c"lo'_ Silva
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case X of
p=> 2 e
lg=>1e

(2)1'(p.2)+1°(q.3)

Prof. José Ré‘ina_ll_cilo' Silva
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Gerenciando conflito

A situacao de conflito é similar, s6 que agora levando em conta os tipos

Binding: G (3)1'(p.2)+1 (p4+1°@.3)  Binding: (3 (3) 1" (p.2)+1 (p.4)+1°(q.3)
<X=p, I=2> : 9 <X=p, i=4> -
o 1°(p.2 1'(p.4
case x of iy P2 case x of (p.4)
p=>2e p=>2%e
lg=>1%e I . lg=>1e i
// (x,1) 1 (p’2) / (X,i) 1 (P,4)
2)2% 2o
E(s) p £ 2e .
(®)3e (3)3e

Prof. José Reinaldo Silva
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CPN Elements

Declarations:

o Types, functions, operations and variables.

Each place has the following inscriptions:

e Name (for 1dentification).

o Colour set (specifying the type of tokens which
may reside on the place).

o Initial marking (multi-set of token colours).

Prof. José Reinaldo Silva
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Each transition has the following inscriptions:
 Name (for 1dentification).

* Guard (boolean expression containing some of
the variables).

Each arc has the following inscriptions:

» Arc expression (containing some of the variables).

When the arc expression 1s evaluated 1t yields a
multi-set of token colours.

 Prof. José Reinaldo Silva
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Enabling Condition

A binding assigns a colour (1.e., a value) to each
variable of a transition.

A binding element 1s a pair (t,b) where t1s a
transition while b 1s a binding for the variables
of t. Example: (T2,<x=p, 1=2>).

Prof. José Reinaldo Silva

PMR5237

29



A binding element 1s enabled if and only if:

e There are enough tokens (of the correct colours on
each mput-place).

e The guard evaluates to true.

When a binding element 1s enabled 1t may occur:
* A multi-set of tokens 1s removed from each
mput-place.

e A multi-set of tokens 1s added to each
output-place.

A binding element may occur concurrently to other
binding elements — iff there are so many tokens
that each binding element can get its "own share".

Prqf; jo‘séi Relnaldo VASi‘Iv'a" ’
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CPN Tools
(cpntools.org)
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CPN Tools Homepage

CPN Tools Homepage

L+
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< _>[ @ http://cpntools.org/start

v C“ (*g~ Google

Q) |f

Most Visited » P Getting Started

Latest Headlines v | | Apple

D Yahoo! -" Google Maps

[] YouTube \X/ Wikipedia

» [EJ Bookmarks ~

GAME & APPS

v I cpn tools download

VAN 0 @ B - Ben W

>»
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CPN Tools

* Documentation

* FAQ

* Getting Started

* Licensing
Contact
Download
Publications
Support

Search | *

Home Download Getting Started

Tools

CPN Tools is a tool for editing, simulating, and
analyzing Colored Petri nets.

The tool features incremental syntax checking
and code generation, which take place while a
net is being constructed. A fast simulator
efficiently handles untimed and timed nets. Full
and partial state spaces can be generated and
analyzed, and a standard state space report
contains information, such as boundedness
properties and liveness properties.

New Features in Version 3.0

e Support for 64-bit Windows

e Support for running under virtualization
software such as VMWare and Parallels (use
safe mode if you get errors under Parallels)

e New simulator which is up to twice as fast
for both automatic simulation and state
space generation

e Support for prioritized transitions

e Support for real time

The latest version is version 3.0.4 from April

Documentation

Support

Contact

¥Tool box -~
» Auxliary
» Create
» Hiararchy
» Monstoring
» Net
» Smulation
» State space
» Style
»\iew
» Halp
» Options
¥ HierarchicalProtocol con
Step: 0
Time: O
» Optons
» History
¥ Dedarations
» colsat INT
» colset DATA
» colset INTXDATA
» colset INTXINT
svarnknln2
»varpstr
» val stop
» colset Tend
» colset Tenl
ryars
svarrrln2
»fun Ok
» fun imin
» Morstors

Binder O
Top Sender Network Recsiver(1) Recsiver(2)

Nore

Chiaxtsend i) 171

k| |imin(n1n2)

Racwve
Adnow
1'(n2,2)

«mpo M| p ppm

N
¥Tep
Sander

v e A e
I

Send J8) 1°(6,7rad Patr)++
107, Natswa™)es
1(8 saparane”)

INTXDATA

INTXINT

1(n1 )44

Michael's Blog on CPN Tools

e In All Fairness... (2011/04/20 16:58)
e Graphical User Interface (2011/03/24

14:31)

e The Access/CPN Source Released
(2011/02/08 10:51)

>
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Download << CPN Tools Homepage

J @ Download << CPN Tools Home... “Tﬂ Curso: Modelagem e Design de ... Jl + L =
4 Z| @ http://cpntools.org/download 7 v | (2§~ Google Q) [m
(&) Most Visited ~ ’ Getting Started Latest Headlines v [] Apple D Yahoo! -.' Google Maps D YouTube \Y/ Wikipedia » n Bookmarks v

GAME&APPS v | cpn tools download v| vo@ @ = = [E Login @ @1 » 9y +

CPN Tools ~
* Documentation
* FAQ Home Download Getting Started Documentation Support Contact
* Getting Started

* Licensing

Contact

S Download
Publications

Support

CPN Tools is free software; see here for licensing information.

tom | Search | X

It should be straight-forward to install CPN Tools; otherwise, read the help pages.

—Windows

Download: [3.04 3

Mailing list:
¥ Announce (highly recommended, very low traffic)

0 Support (recommended, support questions go here, medium traffic and digest
option available)

E-mail address:

—Linux/Mac 0OS X

We recommend you to download the latest Windows version of CPN Tools and run it
using a virtual machine. Linux users can also download an older version of CPN Tools,
but these versions are not maintained any longer.

Download Linux Version 2.3.5

Download Linux Version 2.2.0

Escola Politécnica da USP
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary :
Create ifx=q
Hierarchy 2?5: elm ‘(3?:;,” 1)
Monitoring
Net
Simulation
State space
Style
View
» Help
¥ Options
Commands between autosave : 50
» Simulation Report . [ then 1° (p,i+1)
» Simulator Process “e(R er _ else empty
¥ ResourceAllocation.cpn
Step: O
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
» colset P
»colset E
»var x
= vari
» Monitors
Top

Resource Allocation Example

Escola Politécnica da USP ». '_:‘ Tt St i PMR5237




¥Tool box
Auxiliary :
Create ifx=q
Hierarchy tTen 1" (a,i+1)
Monitoring BB
Net
Simulation
State space
Style
View
»Help -
¥ Options ‘ 72 (p,0)++
Commands between autosave : 50 llf(xq:L_\
» Simulation Report thenpl‘ (p,i+1)
» Simulator Process : er ) else empty
¥ ResourceAllocation.cpn :
Step: 1
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
» colset P
»colset E
»var x
wvari
» Monitors case X 0

Top p=>2¢e
- lg=>1"¢e

Resource Allocation Example
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¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 2
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
» colset E
= var X
= vari
» Monitors
Top

Escola Politécnica da USP

if x=q
then 17 (q,i+1)
else empty

then 17 (p,i+1)
else empty

case x o
p=>2'e
lg=>1"¢e

Resource Allocation Example

PMR5237




¥Tool box
Auxiliary :
Create ifx=q
Hierarchy ET:: elmg%;/lﬂ)
Monitoring
Net
Simulation
State space
Style
View
> Help
¥ Options
Commands between autosave : 50
» Simulation Report 4 i then 1° (p,i+1)
» Simulator Process “e(R i _ else empty
¥ ResourceAllocation.cpn
Step: 3
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
» colset P
»colset E
= var x
e vari
» Monitors
Top

Resource Allocation Example
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Auxiliary
Create
Hierarchy
Monitoring

“* CPN Tools (Version 3.0.4, April 2011)
¥ Tool box

if x=q
then 17 (q,i+1)
else empty

Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 4
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
»colset E
= var x
= vari
» Monitors
Top

then 17 (p,i+1)
else empty

Resource Allocation Example
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®* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary
Create
Hierarchy
Maonitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: S
Time: 0
» Options
» History
¥ Declarations
»colset U
» colset I
» colset P
»colset E
B varx
> yari
» Monitors
Top

e

Escola Politécnica da USP

if x=q
then 17 (q,i+1)
else empty

::3"‘ 2" (p,0)++

1°(q,0) —
if %=p
then 17 (p,i+1)
else empty

Resource Allocation Example
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary

Create if x=q ;
then 17 (q,i+1)

else empty

Hierarchy
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options .
Commands between autosave : 50 ™
» Simulation Report ) then 1° (p,i+1)
» Simulator Process ’ . _ else empty
¥ ResourceAllocation.cpn
Step: S
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
»colset E
»var x
»yari
» Monitors case X o

Top p=>2e
o lg=>1"e

Resource Allocation Example
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¥Tool box
Auxiliary :
Create ifx=q
Hierarchy gr:: e1m|(3?:§1|+1)
Monitoring
Net = !
Simulation ¢ i Eg'(l);*'J'
State space -
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report then 1" (p,i+1)
» Simulataor Process : er . else empty
¥ ResourceAllocation.cpn
Step: 6
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
»colset P
»colset E
= var X
= vari
» Monitors
Top

Resource Allocation Example
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Modelagem classica para o
problema dos filésofos

O exemplo dos filésofos
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space PH.all()

1 ph(2)++
»Help 1 ph(3)++
¥ Options 1" ph(4)++
Commands between autosave : 50 1" ph(S)
» Simulation Report
» Simulatar Process Take hopstick
¥ DiningPhilosophers.cpn Chopsticks Chopsticks(p)
Step: 4
Time: 0
» Options
»History . Unused ),
¥ Declarations Chopsticks =
»valn
» colset PH
» colset CS p
»varp ¥
»fun Chopsticks
» Monitors

Page

Put Down Chopsticks(p)
Chopsticks

)

Prof. José Reinaldo Silva
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Modelagem com CPNs

* Diferente abordagem, mais abstracao

* Classificar elementos do projeto segundo tipos bem definidos
* A observancia dos bindings (strong type) é fundamental

* Explorando as simetrias (pode nao aparecer desta forma)

* Maior facilidade para reutilizacao

Escola Politécnica da USP 2 P Y PMR5237




Alguns problemas...

 Diferente abordagem, mais abstracao
Depende do background do designer, mas a questao base é escolher entre fazer a

5 modelagem ja direto em rede colorida ou comegarJelq rede classica
* Classificar elementos do projeto segundo tipos bem definidos

Consequencia do item anterior e novamente € uma questao de diciplina.

* A observancia dos bindings (strong type) é fundamental :
Comum nos processos estruturados, choca-se com a excessiva carga funcional que oS

engenheiros costumar dar aos projetos.
* Explorando as simetrias (pode nao aparecer desta forma)

De fato deve ser feito também no caso classico, o tipo de simetria a ser explorada € que e

* Maior facilidade para reutilizacdo et
Sera amplicado no tanto no caso classico com no das redes de alto nivel com a introducao da
hierarquia, mas continua mais forte no caso das redes de alto nivel, embora a escolha da
componente reutilizavel seja mais complexa.
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Sobre o formalismo

Portanto, a Unica maneira de minorar os problema é voltar ao
formalismo para explorar melhor a analise de propriedades,
especialmente os invariantes.

O formalismo também abre a possibilidade de se ter outras interfaces
mais amigaveis e adaptadas aos ambientes de trabalho, tendo o CPN
Tools (por exemplo) por tras. Nesse caso a aderéncia ao formalismo
das CPNs é importante e fundamental para a credibilidade da
ferramenta.

Escola Politécnica da USP
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CPN : definicao formal

Definition: A Coloured Petr1 Net 1s a tuple CPN = (2, P, T, A, N,
C, G, E,]I) satisfying the following requirements:
(1) X 1s a finite set of non-empty types, called colour sets.
(1) P 1s a finite set of places.
(1) T 1s a finite set of transitions.
(1v) A 1s a finite set of ares such that:
* PAnT=PnA=TnA=0.
(v) N 1s a node function. It 1s defined from A mto PxT u T xP.

(vi) C 1s a colour function. It 1s defined from P 1nto X.

 Prof. José Reinaldo Silva
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(vit) G 1s a guard function. It 1s defined from T into expressions
such that:

o VteT: [Type(G(t)) =Bool A Type(Var(G(t))) c X].

(vim) E 1s an arc expression function. It 1s defined from A into
expressions such that:

* VaeA: [Type(E(a)) = C(p(a))ms » Type(Var(E(a))) c 2]
where p(a) 1s the place of N(a).

(1x) I 1s an initialization function. It 1s defined from P into
closed expressions such that:

* VpeP: [Type(I(p)) = C(p)wms].

Prof. José Remaldo Silva
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