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A. OBJETIVOS 

 
Esta sessão de lab tem como objetivo familiarizar o estudante com o uso do 

ambiente de gerenciamento de projeto IC Station, da Mentor Graphics 
Corporation, particularmente na questão de criação e dimensionamento de 
camadas/máscaras e no uso de regras de projeto. O ambiente consiste de uma série 
de ferramentas como, por exemplo: 

 IC Graph- editor de polígonos coloridos, em que cada conjunto <cor - textura - 
espessura de borda> representa uma máscara da tecnologia CMOS 
considerada; 

 Calibre- programa de extração do esquema de um circuito a partir do seu 
leiaute, 

 DRC- iniciais de design rule checker, programa de verificação das regras de 
projeto impostas pela empresa onde o circuito será fabricado (em uma Silicon 
Foudry).  

Para a familiarização com a ferramente IC Graph, serão realizadas as seguintes 
tarefas neste laboratório:  

1. Desenhar o leiaute de um transistor MOS usando o programa ICGraph; 

2. Verificar se a regras de projeto (também denominadas de regras de leiaute) 
da biblioteca de células ADK estão sendo respeitadas. Para tanto, utilizando-se 
da ferramenta DRC; 

3. Gerar arquivos contendo a descrição de leiaute no formato (arquivo) GDSII, 
que representa a geometria dos polígonos correspondentes às máscaras do 
processo CMOS e que serve como interface entre a fase de projeto e a de 
fabricação de um CI. 

 

B. PARTE PRÁTICA 

ATENÇÃO: Observe que, ao longo desta apostila, existem várias informações e 
discussões que deverão aparecer na sua folha de respostas. Recomenda-se, no 
entanto, que o aluno grave todas as informações relevantes, seja para, depois, 
poder anexá-los e/ou para eventual estudo posterior. 

 

1) ASPECTOS DA TECNOLOGIA USADA 

 1.1. MANUAIS DE TECNOLOGIA E REGRAS DE PROJETO 

 As aulas práticas no laboratório adotarão uma tecnologia de 0,35 m tanto da 
TSMC, como da AMI. Esta é uma tecnologia com a qual é possível fabricar circuitos 
que podem funcionar em frequências na faixa de gigaHertz (podendo chegar a 3 ou 
4 GHz). Aspectos da especificação desta tecnologia encontra-se nos arquivos 
disponibilizados no Moodle. Baixem-nos para a sua pasta home. 

As regras de projeto estão no manual: 

ENG-183_rev6.pdf (revisão 6)  
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enquanto os parâmetros elétricos no manual:  

ENG-182_rev5.pdf (revisão 5) 

 Como forma de se familiarizar com o manual, o aluno deverá fazer algumas 
anotações e comentá-las. 

Obs. Use as referências para transistores com denominações NMOS e PMOS. Não 
use os dados de NMOSM[xx] e PMOSM[xx] que são transistores para tensões altas. 

 Completar informações no formulário de respostas (item 1.1) 

 
 1.2. EXEMPLO COM REGRAS DE PROJETO 

 O programa IC Station usado em nossas aulas adota “regras de projeto 
escalável”, ou seja, baseado em regras λ. São as regras MOSIS-SUBM (algumas no 
Apêndice 1 da apostila de teoria). A conversão para regras em microns é feita 
usando-se critérios de pior caso. O valor de λ no nosso caso é de 0,2 μm para a 
tecnologia de 0,35 m (observar que a metade da menor dimensão seria 0,175 μm, 
mas, esta conversão não permitiria o atendimento de todas as regras em microns de 
ENG-183_rev6.pdf, portanto não é adotada e arredonda-se para cima).  

ATENÇÃO: Seguindo a recomendação no MOSIS (Tabela 3 da apostila de teoria), 
utilize sempre λ= 0,2 μm. 

 Como forma de verificar a questão da margem de segurança nas dimensões, 
o aluno deverá comparar os dois casos de conversão, de λ: 0,175 e 0,2 μm.  

 Completar informações no formulário (item 1.2) 

 

 1.3. MANUAIS DA IC STATION E OUTRAS FERRAMENTAS 

 A Mentor Graphics disponibiliza os manuais de seus softwares, incluído a IC 
Station, através de documentos *.html ou *.pdf.  Estes manuais se encontram nas 
pastas: 

 /tools/mgc_tree/ic_station_2014_v9/v9.0h_linux_x86_64/icstation_ 
home/docs/pdfdocs/icstn_user.pdf 

 /tools/mgc_tree/ic_station_2014_v9/v9.0h_linux_x86_64/icstation_ 
home/docs/htmldocs/icstn_user/wwhelp/wwhimpl/js/html/wwhelp.h
tm 

 
OBSERVAÇÃO: Você pode acessar os manuais depois de disparar a ferramenta 
IC Station (ver próxima seção).  

 

2) EXEMPLO GUIADO COM IC STATION 

 
 2.1. DISPARANDO O PROGRAMA IC Station 

Crie uma Janela de Terminal (ou Janela de comandos)- konsole.  

 Todas as tarefas deste lab 1 (descritas a seguir) deverão ser realizadas a 
partir da pasta ~/lab1/celulas.  (já preparada segundo a seção 3.2 do Guia para a 
Preparação da Infraestrutura dos Softwares, fornecido na aula 2). Caso você não 
conheça o sistema Linux e não tenha feito o procedimento da aula 2, recomenda-se 
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seguir toda a seção 3 daquele guia antes. 

 Esta pasta corresponderá ao working directory (ou pasta de trabalho) de seu 
projeto e será frequentemente designada pelas iniciais WD. 

Primeiro você precisa posicionar o seu terminal na sua pasta de trabalho, 
working directory. Para isto, ative um terminal na sua tela (ou usar algum terminal 
que já esteja aberto). Na janela tecle o comando : 

  cd  ~    (para se certificar que esteja ou retorne para o seu home 
directory) 

  cd  lab1/celulas   (para mudar para sua pasta de trabalho working 
directory)  

 source   ~/perfil_mgc_2020-64  (script para ajustar as variáveis de 
ambiente que foi copiado do Moodle na aula 2) 

ATENÇÃO: lembre-se de que, sempre que abrir uma nova janela de terminal, o 
comando do script (source ...)  deve ser executado antes do disparo das 
ferramentas da Siemens. 

 Dispare o IC Station, teclando: 

 adk_ic   &    (símbolo & do LINUX para manter o controle do terminal) 

  e aguarde alguns instantes até a janela do IC Station aparecer. 

OBSERVAÇÃO: O comando adk_ic é na verdade um script que serve para 
configurar mais variáveis de ambiente, os caminhos (paths) e a licença de uso do 
programa IC Station adaptado para a biblioteca de tecnologia ADK1. 

Primeiramente, defina o diretório de trabalho no IC Station. Clique na barra 
superior 

 MGC -> Location Map → Set Working Directory 

e selecione ~/lab1/celulas se este não for o WD  já selecionado. 

Observe que aparece à direita da tela do IC Station uma palheta de trabalho e 
uma de camadas (Session e Layer Pallete). Caso elas não estejam na tela, clique na 
barra superior, para elas aparecerem: 

 Setup -> Windows -> Palette Area 

 Setup -> Windows -> Layer Palette  

OBSERVAÇÃO: A palheta pode ser eliminada da tela para ampliar a área de 
trabalho clicando na parte superior da própria palheta sobre o símbolo de um pino (à 
esquerda do X). Para reativar a palheta basta posicionar o mouse sobre a palavra 
Session ou Layer Pallete (que aparecem no canto direito da janela) e em seguida 
clicar novamente sobre o pino. 

 Você pode acessar os manuais, clicando em:  

 Help → Open Users manual  

e para acessar o Manual de Usuário do IC Station no Acrobat Reader escolha: 

 IC Station-> Getting Started with IC Station.  
                                                 
1 O aluno poderá olhar o conteúdo do script abrindo o arquivo  /tools/mgc_tree/adk3_1/bin/adk_ic com algum 

editor de texto 
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 Usando o gerenciador de arquivos, acesse a pasta onde se encontra o 
manual no formato .pdf. Observe que nas pastas indicadas existem diversos outros 
manuais de outros programas que compõem o pacote da Siemens/Mentor Graphics. 

 Para familiarizar-se com estes manuais, acesse alguns deles. 
 

 2.2.CRIANDO UMA NOVA CÉLULA 

Na palheta de trabalho (IC Palletes), clique: 

 New (aparecerá a caixa de diálogo New Layout) 

 Cell name:  cel_1  

 Process: navegue até o arquivo de biblioteca navegue até a pasta 
/tools/mgc_tree/adk3_1/technology/ic/process e selecione a tecnologia 
CMOS 0,35um (indicado com a letra P) ( tsmc035).  Clicar OK. 

 Rules: navegue até a mesma pasta, selecione o arquivo de regras de 
leiaute (“tsmc035.rules”). Cuidado para não selecionar outras regras também 
iniciadas com "tsmc.."). Clicar OK. 

 Confirme as seleções clicando OK. 

Uma janela de projeto (vazia) aparecerá, cuja parte superior conterá o nome da 
célula (cel_1). Nela aparece uma grade composta de pontos, alguns menos e outros 
mais brilhantes. Na parte inferior há uma aba denominada Message Area, onde  
você pode acompanhar todos os seus comandos correspondentes às suas ações.  

ATENÇÃO: A mensagem que deve aparecer é "$MGC_WD/cel_1 reserved for 
edit”. O $MGC_WD indica que você está, de fato, trabalhando na sua pasta de 
trabalho,  cel_1 é o nome dado para a sua célula e reserved for edit significa que a 
célula pode ser editada.  
 

 2.3. GRAVANDO O SEU PROJETO 

Para gravar o seu projeto  

 Clique em File→Save→Layout 

 

 
 2.4. EDITANDO UMA CÉLULA 

Uma janela do editor de leiaute do IC Station pode apresentar uma célula COM ou 
SEM permissão para ser editada. A opção COM permissão (reserved for edit) é a 
normal. A opção SEM permissão é usada quando, por precaução, não se deseja 
permitir mudanças (nem mesmo acidentais) num leiaute satisfatório. Você pode 
mudar de uma situação para outra clicando em: 

 Context -> Layout -> Set Edit Mode On/Off 

ATENÇÃO!!: por segurança, grave os resultados sempre que você obtiver um 
resultado parcial satisfatório- cuidado para não perder dados. 

OBSERVAÇÃO: após você gravar o resultado de um leiaute, ao reiniciar o projeto 
(usando a opção OPEN cell na palheta de trabalho) a célula será sempre reaberta 
no modo SEM permissão. Logo, não esqueça de tornar a célula editável caso queira 
prosseguir realizando alterações no projeto. 
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 2.5 ENTENDENDO O SISTEMA DE COORDENADAS 

 No canto superior direito da janela do IC Station aparece um indicador 
Cursor, com dois números. Estes números correspondem à atual posição do cursor 
do projeto em coordenadas . O ponto (0,0) (origem) está indicado na figura através 

de um +. Ao mover o mouse sobre a grade, o cursor indica as suas coordenadas, ou 
seja a distância dada em . Os valores indicados são relativos à origem que é fixa.  

 Posicione o cursor no centro da janela e observe que aparecem as 
coordenadas (0,0). 

 Mova o mouse e observe que os valores (em em mudam. 

 
 2.6. CONTROLANDO A GRADE 

A grade serve para duas finalidades: 

1-  Definir as dimensões dos retângulos (ou outros tipos de polígonos) que 
irão constituir o leiaute;  

2-  Definir a posição de cada retângulo (polígono) no leiaute.  

No menu superior: 

 Selecione ViewZoomTo Grid. 

e observe o que ocorre.  

 Observe também usando o indicador Cursor  qual é o espaçamento entre os 
pontos menores e maiores. Observe que o ponteiro do mouse pode, pelo menos, 
neste primeiro momento, parar fora das posições da grade. Pelo menu: 

 Selecione a opção Setup Preferences 

 Na janela que surge, selecione  Display->Rulers/Grid 

 Na caixa de diálogo, observe que a opção Use Snap Grid esteja ativada. 
Observe os valores de Snap grid coordinates X e Y, Snap grid offsets X 
e Y e Grid points at Major e Minor.  

OBSERVAÇÃO: Você pode usar a opção ViewZoomIN ou OUT para 
ampliar/reduzir o seu desenho. 

 Completar informações no formulário (item 2.6) 

 Mova o cursor na vertical e horizontal, e veja a relação entre os pontos de 
parada e os valores de Snap grid coordinates X e Y 

 Veja qual a relação entre o valor de Grid points at Minor e os valores de 
Snap grid coordinates X e Y  

 Veja qual a relação entre o valor de Grid points at Minor e o valor de Grid 
points at Major 

  

 2.7. MODIFICANDO OS VALORES DA GRADE 

Modifique a grade para que você tenha certeza que entendeu o significado dos 
parâmetros dados. Repita as operações:  

 Selecione a opção Setup Preferences 
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 Na janela que surge, selecione  Display->Rulers/Grid 

 Modifique o valor dos parâmetros: 

 Grid points at Major = 4 

  Grid points at Minor = 2 

  Snap grid coordinates X = 2 

  Snap grid coordinates Y = 1 

 Clique em Apply → OK 

 Selecione View → Zoom → To Grid 

e movendo o cursor sobre a nova grade observe o que ocorre pela marcação da 
posição do cursor no canto superior direito de sua tela.  

 Mova o cursor na vertical e horizontal, e veja a relação entre os pontos de 
parada e os valores de Snap grid coordinates X e Y 

 Veja qual a relação entre o valor de Grid points at Minor e os valores de 
Snap grid coordinates X e Y  

 Veja qual a relação entre o valor de Grid points at Minor e o valor de Grid 
points at Major  

 Completar informações no formulário (item 2.7) 

 Faça mais mudanças e experimentos por sua conta. 

 

 2.8. DESENHANDO UM RETÂNGULO (POLY) 

Para o desenho do leiaute que se segue, retorne aos valores da grade inicial, 
ou seja:  

 -  Grid points at Major = 5; Grid points at Minor = 2;  Snap grid coordinates X = 
0.5 e Snap grid coordinates Y = 0.5 

Os desenhos serão personalizados com o número USP da seguinte forma: 

 W (em ) é o penúltimo algarismo do seu número USP. Se for < 5, some 
o valor 5 a ele. 

 L (em ) é formado com o último algarismo do seu número USP. 
Considere o algarismo como n, então a dimensão é (n mod 4). Caso for 
< 2, some o valor 2  a ele. 

 Exemplo 1: #USP 3164124  leva a W =7 (ou seja, 2+5 )  e  L=2  (pois n=0). 

 Exemplo 2: #USP 3164167  leva a W =6 e  L=3. 

 Completar informações no formulário (item 2.8) 

Para desenhar polígonos (retângulos) coloridos, cada cor representando uma 
camada do processo CMOS, clique sobre a palheta de trabalho em: 

 Easy Edit -> Shape 

Antes de desenhar o polígono é preciso escolher a que camada do processo 
CMOS corresponde (cor do polígono). Caso a palheta de camadas (ATENÇÃO: não 
confundir com a palheta de trabalho) não estiver presente na tela, faça-a aparecer 
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clicando em: 

 Setup/Windows/Layer Pallete  

OBSERVAÇÃO: caso apareça uma caixa de diálogo Object Editor, você pode 
minimizar o seu tamanho, pois ela não será usada nesta experiência. 

OBSERVAÇÃO: A palheta Layer contém TODAS AS CAMADAS DO PROCESSO 
TSMC_035. Nós somente usaremos algumas destas camadas. Localize a camada 
N-WELL. As camadas que serão usadas nas aulas de laboratório são as que estão 
listadas logo após a NWELL. 

Prosseguindo, 

 Na palheta Layer, clique sobre o botão  (nome) POLY. 

 Clique sobre a palheta de trabalho em: Easy Edit -> Shape 

 O seu retângulo deverá ter tamanho (altura A_poly= L ; largura W_poly= 
W+4) 

 Posicione o mouse sobre a grade no ponto onde você irá desenhar um dos 
vértices do retângulo, arraste o mouse (sem soltar o botão do mouse) até a 
posição onde se encontra o vértice na outra diagonal do retângulo e 
finalmente solte o botão. O retângulo na camada Poly (cor vermelha) 
aparece na área de trabalho, como abaixo. 

 

 

 

 

OBSERVAÇÃO: Caso você faça uma edição errada, a forma mais rápida de corrigir 
e´"desfazer a edição". Para isto, ou 'tecle u' ou clique no botão de desfazer em 
vermelho na lista da barra lateral esquera, ou selceione o menu superior em Edit -> 
Undo. 

Se na sua figura, apenas a borda esteja em vermelho, coloque o cursor dentro do 
retângulo e tecle F2 (o polígono fica de-selecionado, como visto abaixo).  

 

 2.9. MEDINDO O TAMANHO DO RETÂNGULO 

 Existem diferentes formas de se medir o tamanho de um objeto. 

 a) PELA GRADE 

 Calcule o tamanho do retângulo em função do tamanho de sua grade. Veja no 
no começo da seção de que forma você definiu a distância entre os pontos da grade. 

 

 b) PELA RÉGUA (RULER) NA PALHETA DE TRABALHO 

 Clique em Ruler (a opção line na janela que se abre deve estar ativada) 

 Clique com o mouse posicionado sobre uma das extremidades do 
retângulo e clique novamente na outra extremidade. 

 

A_poly 

W_poly 
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 c)  PELA MEDIDA DE DISTÂNCIA (VIEW MEASURE DIST) 

 Clique em View → Measure Dist  

 Clique com o mouse posicionado sobre uma das extremidades do 
retângulo e clique novamente na outra extremidade. 

Naturalmente as 3 formas devem conduzir aos mesmos valores. 

 

 2.10. FECHANDO E REABRINDO A IC STATION E REATIVANDO A SUA 
CÉLULA 

 Saia do programa clicando: 

 MGC -> Exit  (caso não tenha gravado o arquivo ainda, será alertado a 
fazê-lo) 

 Na janela de terminal, reative o programa (adk_ic &) e reabra a sua célula: 

 Na palheta de trabalho clique em Open 

 Na janela clique sobre o nome da sua célula e confirme com OK. 

ATENÇÃO: lembre-se que a sua célula foi reaberta SEM PERMISSÃO PARA 
EDIÇÃO. Para mudar tecle: 

 Context -> Layout -> Set Edit Mode On  (sempre lembrar de fazer isto 
para tornar o projeto editável). 

 

 2.11. DESENHANDO UM SEGUNDO RETÂNGULO (ACTIVE) 

Clique sobre a palheta de trabalho em: 

 Easy Edit -> Shape 

 Na palheta de camadas escolha a camada ACTIVE (região ativa/ óxido 
fino).  

Lembre-se que caso a palheta de camadas não esteja presente na tela, faça-a 
aparecer com clicando em: 

 Setup/Windows/Layer Pallete  

 

 O segundo retângulo deve ficar como indicado na figura abaixo (tente 
centralizar os dois polígonos). Ele deverá ter as dimensões (altura A_ra= 
L+11 largura W_ra= W). 
 
 

 

 

 

 

 

A_ra 

W_ra 
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 Posicione o mouse sobre a grade no ponto onde você irá desenhar um dos 
vértices do retângulo, arraste o mouse (sem soltar o botão do mouse) até a 
posição onde se encontra o vértice na outra diagonal do retângulo e 
finalmente solte o botão.. 

Caso apenas a borda esteja verde, coloque o cursor dentro do retângulo e tecle F2 
(de-selecionnado-o). 

OBSERVAÇÃO: Note que, apesar de neste momento existirem apenas 2 
retângulos, das camadas vermelho (Poly) e verde (Região Ativa), na tela aparece 
uma terceira cor, na região onde os 2 retângulos se cruzam. Esta cor NÃO 
representa nenhuma camada útil do processo CMOS. Trata-se apenas de um 
feedback da ferramenta para indicar a sobreposição de duas ou mais camadas, 
gerando uma região de canal do transistor. 

 

 2.12. IMPRIMINDO E GRAVANDO LEIAUTES 

 Para gravar o desenho do leiaute (a ser incluído no seu relatório), acione 
FilePrint, e na janela que aparece, escolha 'Use formatter' e 'Export to file'. 
Tecle no retângulo 'Formatter Options' e lá escolha o 'Output format' como TIFF 
(poderia ser outro formato), escolha um nome 'Output file' por exemplo "cel_1.tiff". 
Selecione 'Omit page numbers', acione o 'color output' (ou sairá em preto e 
branco), finalmente tecle OK nesta janela. Tecle OK na primeira janela aberta. No 
seu diretório de trabalho deve aparecer um arquivo 'cel_1.tiff'.    

 Para visualizar um arquivo *.tiff, clique com o botão da direita do mouse sobre 
o seu ícone no dolphin e utilizeuma das duas opções: 

 - okular (programa que serve para ler arquivos pdf também)- permite gravar 
em *.pdf. 

 - gimp (gnu image manipulation program, explicado brevemente no apêndice 
da apostila de teoria) - serve para editar imagens e camadas e permite gravação e 
vários formatos alternativos (jpg, png, gif, etc..)  

 Completar informações no formulário (item 2.12) 

 

 2.13. REGISTRO DAS MÁSCARAS 

Um formato bem comum para guardar as informações geométricas das máscaras 
de um leiaute é o GDSII. Este é o formato usado para transmitir o projeto do ASIC a 
ser fabricado pela Foundry. Trata-se de um formato de arquivo binário, compacto, 
adequado para transferências eletrônicas. Outro formato equivalente é o XML. Para 
gerar estas descrições, acione FileExportGDSII (e, também, XML). Na janela 
que aparece, use as opções default, selecione a célula topo de seu leiaute e escolha 
um nome para o ‘Output GDS File’, por exemplo: cel_1.gds2 (e, também, para o 
‘Output XML File’, com NMOS.xml). Clique em OK.  

Abra os dois arquivos com o aplicativo Kate e veja os seus conteúdos. Em, 
particular, para o arquivo XML, use adicionalmente a opção do IC Station, 
ReportDesign Layers, com o mapeamento das máscaras, para auxiliar no 
entendimento do arquivo. 

 Completar informações no formulário (item 2.13) 
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 2.14. SELECIONANDO E DE-SELECIONANDO POLÍGONOS 

Para efetuar modificações e correções em um desenho em andamento, é 
necessário selecionar e/ou de-selecionar polígonos já desenhados que precisam ser 
modificados ou corrigidos. 

Existem diversas formas para fazer a seleção/de-seleção de figuras.  

a) USANDO O MENU DO BOTÃO DIREITO 

 Clicar COM O BOTÃO DIREITO DO MOUSE POSICIONADO SOBRE A 
JANELA DE TRABALHO. Aparecerá um cardápio de opções onde, entre 
outros comandos, encontram-se Select e Unselect. Cada um deles 
apresenta diversas opções.  

Para selecionar: 

 Clicar em Select -> Área 

 Arrastando o mouse, desenhe um retângulo qualquer que cubra TODA a 
área do retângulo desenhado. Desta forma ele estará selecionado.  

Para de-selecionar: 

 Clicar em Unselect  -> Área  

 Arrastando o mouse, desenhe um retângulo qualquer que cubra a área do 
retângulo desenhado. Desta forma ele estará de-selecionado. 

OBSERVAÇÃO: Você também pode selecionar e de-selecionar usando outras 
alternativas indicadas no menu. 

OBSERVAÇÃO: Quando o retângulo está de-selecionado, toda sua superfície está 
em vermelho (cor que representa silício poli). Mas, quando está selecionado aparece 
apenas a sua periferia, indicando que modificações de tamanho ou qualquer outra 
podem ser feitas. 

b) USANDO AS TECLAS F1 E F2 

A tecla F1 corresponde a selecionar e a F2 de-selecionar. Para testar os seus 
funcionamentos execute as seguintes operações:  

 Com o cursor sobre a área de trabalho (onde existe grade), mas 
posicionado fora dos 2 retângulos, tecle uma vez em  <F2>  e depois tecle 
<F1> duas vezes seguidas.  

 Repita, mas agora mantenha o cursor sobre um dos retângulos. 

 Repita, mas agora mantenha o cursor sobre o outro retângulo. 

 Repita mais uma vez mas posicione o cursor sobre a palheta de camadas. 

OBSERVAÇÃO: Use o  item do menu View->Zoom-> In (ou Out) para uma melhor 
visualização.  

OBSERVAÇÃO: Uma forma rápida de centralizar a visualização é teclar <Shift F8> 
no teclado (veja as informações sobre as teclas de funções na barra abaixo da tela 
de projeto). Este atalho é equivalente a clicar na barra superior com View->All. 
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 2.15. FAZENDO CÓPIA DE UM OBJETO 

Selecione um polígono (F1) e depois, para fazer uma cópia, clique com o botão 
direito do mouse sobre a área de trabalho. No menu do botão direito clique: 

 Edit->Copy->Selected (ou, equivalentemente, na palheta de trabalho 
selecionar Copy) 

Observe que grudado ao cursor aparece a geometria que está sendo copiada 

 Posicione o novo polígono na posição desejada. 

 Clique com o botão esquerdo do mouse para fixar a cópia nesta posição. 

 Clique em <Escape> para finalizar e liberar a função. 

 Clique em Undo pelo botão da esquerda até voltar à situação original.  

 

 2.16. MOVENDO O POLÍGONO USANDO A OPÇÃO REL MOVE 

Escolha um polígono e selecione-o: 

 No menu do botão direito clique: Edit -> Move -> Relative (ou, 
equivalentemente, na palheta de trabalho, clique: Rel Move - mover 
relativamente). Na caixa de diálogo informe: X Offset = 2; Y Offset = 0. 

 Clique em OK (o retângulo se deslocará de 2 positivamente pois o offset 
de Y é indiferente neste caso).  

 Clique em <Escape> para finalizar e liberar a função. 

 Clique em Undo pelo botão da esquerda até voltar à situação original.  

 

 2.17. MODIFICANDO AS DIMENSÕES USANDO A OPÇÃO STRETCH  

Com o polígono de-selecionado: 

 No menu do botão direito, clique Select-> Area e selecione o retângulo 
cuja dimensão será modificada. 

 Clique sobre a opção Stretch na palheta de trabalho.  

 Note que a opção Polygon está ativada na janela que se abre. 

 Clicando com o botão esquerdo do mouse (sem soltar) desenhe uma janela 
retangular envolvendo os dois vértices do lado do retângulo que será 
deslocado (a fim de mudar a dimensão). Mas, somente estes 2 vértices 
devem ser cobertos pela janela. 

Observe que, feito isto a opção Line será automaticamente ativada na janela 
inferior 

 Desenhe sobre a grade, em qualquer posição da área de trabalho (não 
precisa clicar exatamente sobre o lado do retângulo) uma linha com o 
tamanho do deslocamento (a direção do deslocamento, para a esquerda ou 
para a direita, para cima ou para baixo é importante). Você observará o 
deslocamento do lado selecionado no valor definido. 

 Clique em OK e cancele a janela inferior.  

 Clique em Undo pelo botão da esquerda até voltar à situação original.  
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 2.18. APAGANDO UM DOS POLÍGONOS 

 a) USANDO O TECLADO 

 Selecione somente um dos retângulos e em seguida tecle delete (no 
teclado).  

 Clique em Undo pelo botão da esquerda até voltar à situação original.  

b) USANDO O MENU GRÁFICO DO CANTO ESQUERDO 

 Como cometado, na lateral esquerda da área de trabalho existe outro menu 
com símbolos gráficos. Teste cada um deles para saber os seus significados. 

 Clicar sobre o X (vermelho)  

 Clique em Undo pelo botão da esquerda até voltar à situação original.  
 

 2.19. VISUALIZANDO UMA MÁSCARA DE CADA VEZ 

Ao desenhar um leiaute, o desenho apresenta diversos polígonos em diversas 
cores. Muitas vezes é útil visualizar uma, ou um conjunto de camadas de cada vez 
(as outras são eliminadas da tela, sem serem apagadas). Na palheta de camadas, 
observe que existem 5 colunas que contêm: os nomes das camadas, as cores e três 
com as letras. São elas: S (select), V (visibility) e F (fill). Normalmente todas estão 
ativadas (símbolo  ). Ao clicar sobre o símbolo repetidamente, você pode 
desativar/ativar cada coluna independentemente. A fim de observar somente o 
retângulo na camada Active, na palheta de camadas:   

 Desative as 3 colunas. 

 Duplo clique sobre o ícone azul (logo ao lado dos símbolos S V F) que 
corresponde  ao comando save layer settings. 

 Clique sobre os campos V e F da camada Active. 

 Duplo clique sobre o ícone azul. 

Na tela ficará somente o retângulo na camada Active. Você pode editá-lo 
modificando sua forma, tamanho, posição, etc, sem alterar o resto do seu desenho. 

Para visualizar todo o seu desenho novamente basta voltar a selecionar todas as 
colunas novamente e dar o duplo clique sobre o ícone azul. 
 
 2.20. ATIVANDO O VERIFICADOR DE ERROS DE PROJETO (DRC) 

A fim de se testar o programa DRC, reduza a dimensão do polígono da região 
ativa original (use a operação Stretch, por exemplo) de forma que as bordas da 
direita dos retângulos coincidam, como indicado na figura abaixo.  
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Rode o programa de verificação DRC para entender o seu funcionamento. Na 
palheta Easy Edit: 

 Clique em Back (no topo da palheta de trabalho).  

Na palheta IC Palettes: 

 Clique em ICrules.  

Na palheta ICrules que deve aparecer: 

 Clique em Check.   

 Clique OK na caixinha de diálogo.  

Em seguida clique em: 

 First.  

O(s) erro(s) cometido(s) aparecerá(ão) através de uma realimentação gráfica 
sobre o seu leiaute. Na área de mensagens (na parte inferior da janela) aparecerá a 
explicação sobre o(s) erro(s).  

Em seguida clique sucessivamente em: 

 Next  

A cada novo clique aparecerão mais erros cometidos, tanto na tela como na área 
de mensagens. 

 Completar informações no formulário (item 2.20) 

 2.21. LOCALIZANDO OS ERROS NO ARQUIVO DE TECHNOLOGIA 

Vá para o desktop 2. Usando o programa File Browser vá até a sua pasta home 
e abra o  abra o documento contendo as regras de leiaute: 

 

ENG-183_rev6.pdf (revisão 6)  

 

Localize as regras que foram violadas e observe os valores mínimos neste 
documento. 


