
1 
 

 

Pórtico Bidimensional 
Tutorial da Interface dos Programas GiD e xFram  

 
Prof. Dr. Edgard S Almeida Neto,  27/09/2018 

Escola Politécnica da USP 

Índice 

1 Instalação dos Programas ............................................................................................................. 1 

2 Modelo Físico ................................................................................................................................ 2 

3 Construção do Modelo Sólido no programa GiD .......................................................................... 3 

3.1 Criação de pontos ..................................................................................................................... 3 

3.2 Traçado das linhas retas ............................................................................................................ 4 

3.3 Traçado do arco circular............................................................................................................ 5 

4 Geração de Dados para o Programa xFram .................................................................................. 5 

4.1 Deslocamentos impostos aos pontos ou às linhas do modelo ................................................. 8 

4.2 Forças e momentos concentrados aplicados nos pontos ......................................................... 8 

4.3 Forças uniformemente distribuídas aplicadas a linhas do modelo .......................................... 9 

4.4 Forças linearmente distribuídas aplicadas a linhas do modelo ................................................ 9 

4.5 Propriedades do material e da seção transversal ................................................................... 10 

4.6 Título, tipo de análise, unidades e eixo de referência para as forças distribuídas ................. 11 

4.7 Tamanho da malha de elementos finitos ............................................................................... 11 

4.8 Gravação do arquivo de dados ............................................................................................... 12 

5 Pós-Processamento ..................................................................................................................... 13 

 

1 Instalação dos Programas 

 
Este tutorial requer a instalação dos seguintes programas e arquivos: 

 Microsoft Visual C++ 2017 redistributable package (os arquivos 'vc_redist.x86.exe' ou 
'vc_redist.x64.exe' podem ser encontrados no site do STOA ou no endereço 
https://www.visualstudio.com/downloads/ ); 

https://www.visualstudio.com/downloads/
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 GiD  versão 14.0.1 (programa de pré- e pós-processamento disponível no endereço http:// 
www.gidhome.com/download/official-versions); 

 xFram-Fram2D_v64.gid (pasta que deve ser adicionada à pasta problemtypes do programa GiD 
localizada em C:\Program Files\GiD\GiD 14.0.1 e contém os arquivos da interface GiD- xFram e o 
programa xFram de elementos finitos compilado para Windows 64 bits). 

 
O programa xFram foi escrito em C++ e compilado no Visual Studio 2017.  A sua execução no 

sistema Windows requer a instalação do pacote de redistribuição do Visual C++ 2017 da Microsoft em 
micros sem o Visual Studio 2017 instalado.  

Os arquivos da interface devem estar na pasta problemtypes criada pelo programa GiD para que 
este reconheça os arquivos e disponibilize a interface no menu Data > Problem type > xFram-
Fram_2D_v64.  

Em micros de 64 bits, o programa xFram pode ser executado de dentro do programa GiD. Em micros 
de 32 bits ou para visualizar as mensagens de erro emitidas pelo programa, o xFram deve ser executado 
de fora do GiD bastando copiar o executável para a mesma pasta contendo o arquivo de dados do 
modelo com extensão .dat que foi gerado pelo GiD. 

A interface com o GiD foi elaborada a partir da interface do programa MAT-fem, de autoria de 
Zárate e Onãte, disponibilizada no site do GiD.  

2 Modelo Físico 

 
A título de exemplo, analisaremos o pórtico plano da Fig. 1 submetido a um carregamento formado 

por forças concentradas e distribuídas. Como a interface não dispõe de forças distribuídas na projeção 
da barra, substituiremos esse tipo de força pelas forças mostradas na Fig. 2. 

 
 

 
Fig. 1 Pórtico plano ( 6 21030 kN/mE  ). 

http://gid.cimne.upc.es/download/
http://www.gidhome.com/download/official-versions
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Fig. 2 Adaptação do carregamento. 

 
Na próxima seção, construiremos um modelo reticulado a partir dos pontos e segmentos de barra 

indicados na Fig. 2, o qual será usado na descrição da geometria e das condições de contorno. 
 

3 Construção do Modelo Sólido no programa GiD 

 
O usuário deve iniciar o programa GiD e escolher um nome para o modelo ao salvá-lo (Files > Save)1; 

no tutorial foi adotado o nome ‘Frame’ .  A extensão '.gid' é acrescentada automaticamente quando é 
criada a pasta em que são armazenados todos os arquivos do modelo.  O mesmo nome é usado nos 
arquivos de entrada de dados, Frame.dat, e de pós-processamento dos resultados da análise, 
Frame.post.res. 

3.1 Criação de pontos 

A geração de pontos a partir das coordenadas garante a precisão do modelo reticulado além de 
facilitar o traçado das barras e a aplicação das cargas nodais.  Para entrar com as coordenadas da Tab. 1, 
use o comando Geometry > Create > Point a partir do menu, conforme mostrado na Fig. 3. Para cada nó, 
digite as coordenadas separadas por um espaço ou uma vírgula na linha de comando localizada na parte 
inferior da janela. Use a tecla ESC para interromper a entrada das coordenadas. Use o comando View > 

Zoom > Frame ou o botão  para ajustar automaticamente a escala do desenho. 
 
 
 
 
 
 
 

 
 

                                                           
1 Não esqueça de salvar o modelo periodicamente. 
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Ponto X Y 

1 3 0 

2 14 0 

3 0 8 

4 3 4 

5 6 8 

6 10 8 

7 14 8 

8 0 16 

9 6 16 

10 11.6569 13.6569 

 
Tab. 1 Tabela das coordenadas dos pontos. 

 

 
Fig. 3 Criação de pontos. 

 

3.2 Traçado das linhas retas 

As linhas são traçadas unindo-se os pontos criados. O acesso ao comando pode ser feito pelo menu,  

Geometry > Create > Straight line, conforme a Fig. 4, ou diretamente pelo atalho   na barra vertical 
de ferramentas.  O comando Ctrl-A alterna os modos de criação e seleção de pontos,  facilitando a 
seleção de pontos existentes e evitando a duplicação destes. Use a tecla ESC para interromper o traçado 
das linhas. 
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Fig. 4 Criação de segmentos de reta. 
 

3.3 Traçado do arco circular 

O comando Geometry > Create > Arc > By 3 points solicita três pontos quaisquer do arco em 
sequência. Use a tecla ESC para interromper a definição do arco. 

 

 
 

Fig. 5 Criação de segmentos de arco. 

4 Geração de Dados para o Programa xFram 

 
Quando a interface do programa xFram é ativada através do menu Data > Problem type > xFram-

Fram2D_v64, o programa GiD mostra a janela de identificação da interface e disponibiliza os botões de 
atalho mostrados na Fig. 6. Os arquivos de interface devem permanecer na pasta problemtypes/xFram-
Fram2D_v64.gid do GiD para que a opção xFram-Fram2D_v64 apareça no menu.  

A ordem em que são percorridas as cinco primeiras janelas da Fig. 6 não tem importância, mas todas 
as janelas devem ser preenchidas antes da geração da malha de elementos finitos e da criação do 
arquivo de dados. 
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Todas as grandezas físicas devem ter unidades consistentes com as unidades fornecidas na janela 
Problem types; em nosso exemplo: força em KN, comprimento em m, tempo em s e temperatura em °C.  
Assim, a unidade de força distribuída no contorno para o estado plano de tensão é kN/m e a densidade 
de massa, ton/m3.  
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Fig. 6 Botões de atalho e as respectivas janelas. 
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4.1 Deslocamentos impostos aos pontos ou às linhas do modelo 

 
Deslocamentos e rotações podem ser bloqueados ou ter valores impostos nos pontos do modelo. O 

engaste no ponto 1 requer a restrição dos deslocamentos e da rotação, enquanto o apoio fixo no ponto 
2 requer a restrição das duas componentes de deslocamento. Para especificar as condições nos dois 
apoios,  

 abra a janela Fixed Displacements clicando o botão  — repare que o botão contendo um ponto, 
posicionado no canto superior esquerdo da janela, já está selecionado e não existe outra opção; 

 selecione a opção Restraint  logo abaixo;  

 clique com o mouse as caixas associadas às componentes que devem ser bloqueados; 

 aplique, por meio do botão ‘Assign,’ as vinculações ao ponto 1 da Fig. 2; libere a rotação e aplique as 
vinculações ao ponto 2; 

 clique o botão 'Draw' para visualizar as condições impostas e o 'Unassign' para desfazer aplicações 
incorretas; 

 encerre pressionando o botão ‘Finish.’ 
 
Também existe a opção Prescribed displacement, junto à opção Restraint, que permite fornecer 

deslocamentos e rotações não nulos.  
 

 

 
Fig. 7 Representação da vinculação (Draw). 

4.2 Forças e momentos concentrados aplicados nos pontos 

O botão  abre a janela para a entrada de forças concentradas em pontos do modelo. O botão 
contendo um ponto está selecionado e não existe outra opção.  

 forneça a componente X2 da força concentrada, um valor negativo indica que a força é para baixo; 

 aplique, por meio do botão ‘Assign,’ uma força de -40 na direção de 2X ao ponto 5 da Fig. 1; altere 

o valor para -20 e aplique ao ponto 6; 

 clique o botão 'Draw' para visualizar os esforços aplicados e o 'Unassign' para desfazer aplicações 
incorretas; 

 encerre pressionando o botão ‘Close.’ 
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Fig. 8 Representação dos esforços concentrados (Draw). 
 

4.3 Forças uniformemente distribuídas aplicadas a linhas do modelo 

O botão  abre a janela para a entrada de forças distribuídas aplicadas a linhas do modelo. Com 
a janela aberta, selecione BAR uniform load, o sistema global G de coordenadas, o tipo UNIF, a direção 2 

correspondendo ao eixo global 2X , e entre com o valor -5.0; aplique, por meio do botão ‘Assign,’a força 

distribuída às linhas 5-6 e 6-7 da Fig. 1. 
 

 
Fig. 9 Linhas carregadas (Draw). 

 
Aplique as demais forças distribuídas uniformes na direção horizontal. Ou seja, os valores 1.6 à linha 

3-4 e 2.0 à linha 1-3 da Fig. 1. 

4.4 Forças linearmente distribuídas aplicadas a linhas do modelo 

O botão  abre a janela para a entrada de forças linearmente distribuídas aplicadas a linhas do 

modelo. As forças são descritas pela magnitude 0p que atua na coordenada de referência 0w mais a 

variação da força /p w    por unidade de comprimento medida no eixo w de referência.  O eixo de 

referência é um dos parâmetros da análise e coincide com um dos eixos globais 1X  ou 2X (ver item 

4.6). O valor da força distribuída em qualquer ponto da linha é calculado por 
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 0 0 )) ((p pw w w   , 

em que w é a coordenada do ponto no eixo de referência especificado. 
 
Na janela aberta, selecione BAR Level load, o sistema global G de coordenadas, a direção 1 associada 

ao eixo horizontal global 1X , e entre com os valores 0 2p  , 0 8w  (correspondendo à ordenada do 

ponto 4) e (3 2) / 8 0,125    .  Aplique, por meio do botão ‘Assign,’a força distribuída à linha 4-8 da 

Fig. 1.  
 

4.5 Propriedades do material e da seção transversal 

Acesse a janela de materiais e seções transversais através do botão  .  Primeiro escolha a seção 

retangular CS Rect; depois clique no botão com a folha em branco, , para criar novas seções e 
escolha nomes convenientes como ‘Sec-A’ e ‘Sec-B’.  Para cada seção, preencha os campos das 
propriedades do material — CS Material, e das dimensões da seção — CS Dimensions, e aplique-as às 
linhas do modelo.  

 

 
 

Fig. 10 Preenchimento da janela de seção transversal. 
 

Adote 6 230 10 kN/mE   para o módulo de elasticidade. Considere a seção A com 8m0,1b   e 

0m0,3h   ( 2

1 0,054mA  e 3 4

3 0,405 m10I  ) para as barras superiores; e a seção B com 8m0,1b   

e 0m0,5h   ( 2

1 0,090mA  e 3 4

3 1,875 m10I  ) para as barras inferiores. Verifique se as aplicações 

estão corretas selecionando o botão 'Draw' e a opção ‘all materials’. 
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Fig. 11 Definição das seções transversais (Draw). 
 

4.6 Título, tipo de análise, unidades e eixo de referência para as forças distribuídas 

Acesse a janela dos parâmetros da análise através do botão  e forneça todas as informações 
pedidas. Adote unidades consistentes com as básicas em todo o arquivo de dados, pois o programa não 
faz conversão de unidade. Selecione a caixa `Nodal Reactions’ para que o programa calcule as reações 
de apoio. 

 

 
 

Fig. 12 Parâmetros da análise. 
 
 

4.7 Tamanho da malha de elementos finitos 

A malha não-estruturada com elementos retos de dois nós é a malha Default no programa GiD.   

A geração da malha pode ser acessada por meio do botão . Forneça o tamanho máximo dos 
elementos e deixe o programa gerar a malha. Varie o tamanho do elemento e gere outras malhas até 
ficar satisfeito com o resultado. No menu 'Mesh' existem vários recursos para controlar a geração da 
malha e verificar sua qualidade.  É possível melhorar a discretização escolhendo uma subdivisão menor 
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para uma determinada linha. Para tal, acione o comando Mesh > Structured > Line > Assign Number of 
Cells e escolha o número adequado de subdivisões da linha. 

Os números dos nós e elementos da malha podem ser visualizados com o comando View > Label > 
All quando a malha é apresentada no GiD. A versão de avaliação do GiD permite gerar malhas com até 
1000 nós. 

 
 

 
 

Fig. 13 Malhas de elementos finitos. 
 

4.8 Gravação do arquivo de dados  

Com a malha gerada, pressione o botão  para gravar o arquivo de entrada de dados.  A 
interface GiD-xFram se encarrega de gerar o arquivo no formato correto. Mantenha o nome ‘Frame’ 
com a extensão ‘.dat’ para que o programa xFram gere um arquivo de saída `Frame.post.res’ 
identificável pelo programa GiD. 

Examine o arquivo de entrada usando um editor de texto para verificar se os dados estão de acordo 
com o modelo. Em particular, verifique as propriedades dos materiais no bloco  `:MATE', as forças 
concentradas no sub-bloco `::NATR' do bloco `:NODE', e as forças distribuídas no sub-bloco `::DSTR' de 
`:BARR'.   

É possível executar o programa xFram na versão 64 bits de dentro do GiD por meio do comando 
Calculate > Calculate. O programa GiD alerta quando termina a execução e pergunta se o usuário quer 
passar para a fase de pós-processamento. Se não houver resposta do GiD, o programa xFram deve ser 
executado fora do GiD para que o usuário tenha acesso às mensagens de erro emitidas pelo programa. 

Para executar a análise externamente ao GiD usando a versão 64 bits do programa xFram, transfira 
o arquivo Frame.dat para a pasta com o programa xFramVSC2017_v64_Win64.exe, execute o programa, 
forneça o nome do arquivo de dados sem a extensão dat, e depois da execução copie o arquivo 
Frame.post.res  de volta para a pasta Frame.gid. Outra opção seria rodar o programa na própria pasta 
do modelo. 
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5 Pós-Processamento 

 

Os botões  e  no canto superior direito alternam entre os modos de pré- e pós-
processamento.  Repare que as colunas de comando à esquerda da janela mudam completamente.  

Faixas de isovalores podem ser visualizadas tanto na geometria indeformada como na deformada, 
assim como vetores de deslocamento e outras grandezas, conforme indicam as sequências de comandos 
nas Figs. 14 a 17. 

Um número maior de elementos é necessário para mostrar a deflexão das barras do pórtico em 
decorrência do programa GiD ignorar as rotações na representação da deformada. Compare as 
deformadas mostradas nas Figs. 14 e 18, para as quais foram usadas 15 e 39 barras, respectivamente. 
Repare que mesmo a malha mais refinada não representa satisfatoriamente a deformação do nó 
superior esquerdo do pórtico, que deveria permanecer reto, como mostra a deformada na Fig. 19. 

Resultados para a malha com 11 barras são apresentados na Fig. 19 para que o usuário possa 
comparar os valores armazenados no arquivo de saída ‘Frame.out’ gerado pelo programa. 

 

 
 

Fig. 14 Amplitudes de deslocamento. 
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Fig. 15 Vetores de deslocamento mostrados na malha indeformada. 

 

 
 

Fig. 16 Faixas de momentos fletores. 
 

 
 

Fig. 17 Diagrama de momentos fletores. 
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Fig. 18 Diagramas para a malha com 38 nós 

 
Fig. 19 Resultados para a malha de 10 nós e 11 barras com deformação transversal cúbica. 


