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1 Instalação dos Programas 

 
Este tutorial requer a instalação dos seguintes programas e arquivos: 

 Microsoft Visual C++ 2017 redistributable package (os arquivos 'vc_redist.x86.exe' ou 
'vc_redist.x64.exe' podem ser encontrados no site do STOA ou no endereço 
https://www.visualstudio.com/downloads/); 

https://www.visualstudio.com/downloads/
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 GiD (versão 14.0.1 do programa de pré- e pós-processamento disponível no endereço http:// 
www.gidhome.com/download/official-versions); 

 xFram-FEM_2D_v64.gid (pasta que deve ser adicionada à pasta problemtypes do programa GiD 
localizada em C:\Program Files\GiD\GiD 14.0.1) contém os arquivos da interface GiD-xFram; 

 xFramVSC2017_v64_Win64.exe (arquivo que também deve ser colocado na pasta problemtypes 
para que possa ser executado de dentro do GiD) versão 6.4 do programa de elementos finitos 
compilada para Windows 64 bits. 

 
O programa xFram foi escrito em C++ e compilado no Microsoft Visual Studio 2017. A sua execução 

no sistema Windows requer a instalação do pacote de redistribuição do Visual C++ 2017 da Microsoft 
em micros sem o Visual Studio 2017 instalado.  

Os arquivos da interface devem estar na pasta problemtypes criada pelo programa GiD para que 
este reconheça os arquivos e disponibilize a interface no menu Data > Problem type > xFram-
FEM_2D_v64.  

O programa xFram pode ser executado de dentro do programa GiD. Contudo, para visualizar as 
mensagens de erro emitidas pelo programa, ele pode ser executado de fora do GiD bastando copiar o 
executável para a mesma pasta contendo o arquivo de dados do modelo com extensão .dat que foi 
gerado pelo GiD. 

A interface para o GiD foi elaborada a partir da interface do programa MAT-fem, de autoria de 
Zárate e Onãte, disponibilizada no site do GiD.  

2 Modelo Físico 

 
A título de exemplo, analisaremos a chapa da Fig. 1 submetida a uma força uniformemente 

distribuída  𝑞 = −20kN/m aplicada na metade da aresta superior, e a uma força de volume 𝒃 = −9,8 ×
7,96 = −78kN/m3, ambas na direção vertical.  A chapa tem 5m de comprimento, 2m de altura e 0,01m 
de espessura. Evitaremos cargas concentradas, inclusive vínculos pontuais, visando minimizar 
concentrações fictícias de tensão que atrapalhariam a convergência dos resultados. 

 

 
 

Fig. 1 Chapa retangular furada: geometria, vinculação e carregamento. 
 

Na próxima seção, construiremos o modelo sólido a partir dos pontos e segmentos indicados na Fig. 
2, os quais serão usados para descrever a geometria e as condições de contorno. 

http://gid.cimne.upc.es/download/
http://www.gidhome.com/download/official-versions
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Fig. 2 Pontos usados na definição da geometria. 

 

3 Construção do Modelo Sólido no programa GiD 

 
O usuário deve iniciar o programa GiD e escolher um nome para o modelo e salvá-lo (Files > Save)1; 

no turorial foi adotado o nome ‘Wall’. A extensão '.gid' é acrescentada automaticamente quando o 
programa cria a pasta em que são armazenados os arquivos do modelo.  O mesmo nome é usado nos 
arquivos de entrada de dados, Wall.dat, e de pós-processamento dos resultados da análise, 
Wall.post.res. 

3.1 Criação de pontos 

A geração dos pontos a partir das coordenadas é uma forma de garantir a precisão do modelo sólido 
e facilitar o traçado das linhas de contorno e a aplicação posterior das cargas. Para entrar com as 
coordenadas da Tab. 1, use o comando Geometry > Create > Point a partir do menu, conforme mostrado 
na Fig. 3. Para cada nó, digite apenas as coordenadas separadas por um espaço ou uma vírgula na linha 
de comando localizada na parte inferior da janela. Use a tecla ESC para interromper a entrada das 
coordenadas.  Caso a tecla ESC esteja desativada, use o botão direito do mouse para acessá-la no menu 
contextual.  

Use o comando View > Zoom > Frame ou o botão para ajustar automaticamente a escala do 
desenho. 

 
 

 
 
 
 
 
 
 
 
 

                                                           
1 Não esqueça de salvar o modelo periodicamente. 
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Ponto X Y 

1 0.0 0.0 

2 0.2 0.0 

3 5.0 0.0 

4 5.0 2.0 

5 2.5 2.0 

6 0.0 2.0 

7 1.0 0.2 

8 1.3 0.5 

9 1.0 0.8 

10 0.7 0.5 

 
Tab. 1 Tabela das coordenadas dos pontos. 

 

 
 

Fig. 3 Criação de pontos. 
 

3.2 Traçado das linhas do contorno externo 

As linhas retas são traçadas unindo-se os pontos criados. O acesso ao comando pode ser feito pelo 

menu,  Geometry > Create > Straight line, conforme a Fig. 4, ou diretamente pelo atalho  na barra 
vertical de ferramentas.  O comando Ctrl-A alterna os modos de criação e seleção de pontos — com o 
mouse indicado por uma cruz ou uma caixa, respectivamente; ele facilita a seleção dos pontos 
existentes e evita a duplicação destes. Use a tecla ESC para interromper o traçado das linhas. 

 

 
 

Fig. 4 Criação de segmentos de reta. 
 

3.3 Traçado dos arcos formando o buraco circular 

Dois arcos foram usados para definir o buraco na parede.  O comando Geometry > Create > Arc > By 
3 points solicita três pontos quaisquer do arco em sequência. Use a tecla ESC para interromper a 
definição dos arcos. 
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Fig. 5 Criação de segmentos de arco. 

3.4 Definição da superfície NURBS 

Como a geometria do modelo é bem simples, o comando Geometry > Create > NURBS surface > 
Automatic, cujo atalho está indicado à direita na Fig. 6, é capaz de simultaneamente gerar a superfície e 
extrair o furo.  

Com o mouse, delimite um retângulo que inclua todas as linhas do modelo e use a tecla ESC para 
interromper a seleção.  As superfícies são indicadas por linhas rosa em escala reduzida para evitar 
superposição com as linhas originais.  Na definição de geometrias mais complexas, é possível somar e 
subtrair superfícies durante a construção do modelo. Use a tecla ESC novamente para interromper a 
definição das superfícies e não esqueça de salvar o modelo. 

 

 
 

Fig. 6 Criação das superfícies. 
 

Nota: Também é possível acrescentar um furo a uma superfície de geometria mais complexa.  Defina 
antes a superfície e a linha de contorno do furo; depois empregue o comando Geometry > Edit > Hole 
NURBS surface para extrair o furo da superfície. 

4 Geração de Dados para o Programa xFram 

 
A interface do GiD com o programa xFram é ativada através do menu: Data > Problem type > xFram-

FEM_2D_v64. Em resposta, GiD mostra a janela de identificação da interface e disponibiliza os botões de 
atalho resumidos na Fig. 7. Os arquivos de interface devem permanecer na pasta problemtypes\xFram-
FEM_2D_v64.gid, localizada na pasta principal do GiD, para que a opção xFram-FEM_2D_v64 apareça no 
menu.  
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A ordem em que as cinco primeiras janelas da Fig. 7 são percorridas não tem importância, mas todas 
elas devem ser preenchidas antes da geração da malha de elementos finitos e da criação do arquivo de 
dados. 

Todas as grandezas físicas devem ter unidades consistentes com as unidades fornecidas na janela 
Problem types (associada ao botão Prob. Type): força em KN, comprimento em m, tempo em s e 
temperatura em °C.  Assim, a unidade de força distribuída no contorno para o estado plano de tensão é 
kN/m e a densidade de massa, ton/m3.  

 

 
 

Fig. 7 Botões de atalho e as respectivas janelas. 
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4.1 Deslocamentos impostos aos pontos ou às linhas do modelo 

 
Deslocamentos podem ser bloqueados ou ter valores impostos a pontos ou linhas do modelo.  

Vamos restringir os deslocamentos das linhas 1-2 e 3-4 da Fig. 2 nas duas direções; isto implica em 
bloquear todos os nós da malha gerados sobre essas linhas:  

 abra a janela Fixed Displacements clicando o botão ; 

 selecione a opção Restraint  na parte superior e depois clique no botão com um segmento, 
localizado no canto superior esquerdo da janela;  

 marque  as caixas associadas aos deslocamentos que devem ser bloqueados; 

 aplique, por meio do botão ‘Assign’ na parte inferior, as vinculações às linhas 1-2 e 3-4 da Fig. 2; 

 clique o botão 'Draw' para visualizar as condições impostas e o 'Unassign' para desfazer aplicações 
incorretas; 

 e, para encerrar, pressione o botão ‘Finish’ e depois ‘Close.’ 
 
Existe também a opção Prescribed displacement, junto à opção default Restraint, que permite 

fornecer deslocamentos não nulos.  
 

 
Fig. 8 Linhas vinculadas. 

 

 
Fig. 9 Representação da vinculação (Draw). 

4.2 Forças concentradas aplicadas nos pontos 

O botão  abre a janela para a entrada de forças concentradas em pontos do modelo. Repare 
que o botão contendo um ponto, localizado no canto superior esquerdo da janela, já está selecionado e 
não existe outra opção.  

Se existissem forças concentradas na chapa, bastaria fornecer as componentes nas duas direções e 
aplicá-las aos pontos correspondentes no modelo. Verifique sempre a aplicação das forças concentradas 
no modelo e na malha gerada, pois nem sempre o programa GiD gera nós nos pontos criados pelo 
usuário, principalmente se eles forem pontos intermediários.  
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4.3 Forças uniformemente distribuídas aplicadas nas linhas do modelo 

O botão  abre a janela para a entrada de forças distribuídas aplicadas a linhas do modelo. Na 
janela, o botão contendo um segmento já está pré-selecionado.  Para estado plano de tensão, o 
programa xFram considera a aplicação de uma força distribuída por unidade de comprimento, eq t  , e 

não do vetor tensão t aplicado.  Para estado plano de deformação, ele considera uma carga distribuída 
por unidade de superfície, ou seja, o próprio vetor tensão t  aplicado.   

Na janela aberta, selecione EDGE distributed force, o sistema global G de coordenadas, o tipo UNIF, 
a direção 2 correspondendo ao eixo global Y, e entre o valor -20.0 para a magnitude de q .  A janela 3. da 

Fig. 7 mostra a janela preenchida. Aplique, por meio do botão ‘Assign,’a força distribuída à linha 6-5 da 
Fig. 2. 

 

 
Fig. 10 Linha carregada. 

 

4.4 Propriedades do material e espessura no caso de estado plano de tensão 

Acesse a janela de materiais através do botão . O botão superior com a folha de papel, , 
permite criar um novo material isótropo elástico-linear; escolha um nome e preencha os campos das 

propriedades do material e da espessura. Adote as seguintes propriedades: 8

2

kN
2.1 10

m
E   ; 0.2  ; 

3

ton
7.96

m
  e uma espessura de 0.01mt  ; caso queira comparar os resultados com os do tutorial. 

Aplique o material criado à superfície NURBS do modelo pressionando o botão ‘Assign’, escolhendo 
‘Surfaces’ e depois selecionando a linha rosa. Verifique se a aplicação está correta pressionando o botão 
'Draw' e o nome do material antes de fechar a janela. 

4.5 Título, tipo de análise, flag para peso-próprio e unidades 

Acesse a janela dos parâmetros da análise através do botão  e forneça todas as informações 
pedidas. Forneça unidades consistentes com básicas em todo o arquivo de dados, pois o programa não 
faz conversão de unidade. 
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Fig. 11 Parâmetros da análise. 

 

4.6 Tamanho da malha de elementos finitos 

A malha não-estruturada com elementos triangulares de três nós é a malha Default no programa 
GiD.  Para selecionar elementos triangulares quadráticos de 6 nós configure as seguintes opções no 
menu 'Mesh': 

 Mesh > Unstructured > Assign Entities > Surfaces  (selecionar superfície); 

 Mesh > Element type > Triangle (selecionar superfície); 

 Mesh > Quadratic type > Quadratic 

A geração da malha pode ser acessada por meio do botão . Forneça o tamanho máximo dos 
elementos e deixe o programa gerar a malha.  Varie o tamanho do elemento e gere outras malhas até 
ficar satisfeito com o resultado. No menu 'Mesh' existem vários recursos para controlar a geração da 
malha e verificar sua qualidade. 

A versão de avaliação do GiD permite gerar malhas com até 1000 nós. 
 

 

 
Fig. 12 Malha de elementos finitos (pouco refinada no furo). 

 

4.7 Gravação do arquivo de dados  

Com a malha gerada, pressione o botão  para gravar o arquivo de entrada de dados.  A 
interface GiD-xFram se encarrega de gerar o arquivo no formato correto. Grave na pasta Wall.gid e 
mantenha o nome ‘Wall’ com a extensão ‘.dat’ para que o programa xFram gere um arquivo de saída 
`Wall.post.res’ reconhecível pelo programa GiD. 

Examine o arquivo de entrada usando um editor de texto para verificar se os dados estão de acordo 
com o modelo. Em particular, verifique as propriedades dos materiais no bloco `:MATE', as forças 
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concentradas no bloco `::NATR' de `:NODE', e as forças distribuídas no bloco `:DSTR’. Os números dos 
nós e elementos da malha podem ser visualizados com o comando View > Label > All quando a malha é 
apresentada no GiD. 

É possível executar o programa xFram na versão 64 bits de dentro do GiD por meio do comando 
Calculate > Calculate. O programa GiD alerta quando termina a execução e pergunta se o usuário quer 
passar para a fase de pós-processamento. 

Para executar a análise externamente ao GiD usando a versão 32 bits do programa xFram, transfira 
o arquivo Wall.dat para a pasta com o programa xFramVC2015_v60d_Win32.exe, execute o programa, 
forneça o nome do arquivo de dados sem a extensão dat , e depois copie o arquivo Wall.post.res  criado 
de volta para a pasta Wall.gid. 

5 Pós-Processamento 

 

Clique em um dos botões  para alternar entre os modos de pré- e pós-processamento; a 
disponibilidade dos botões logo abaixo do menu à direita depende do modo.  Repare que as colunas de 
comando à esquerda da janela mudam completamente.  

Curvas e faixas de isovalores podem ser visualizadas tanto na geometria indeformada como na 
deformada, assim como vetores de deslocamento e outras grandezas, conforme indicam as sequências 
de comandos nas Figs. 13 a 15. 

 

 
Fig. 13 Amplitudes de deslocamento. 
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Fig. 14 Vetores de deslocamento mostrados na malha indeformada. 

 

 
 

Fig. 15 Tensões tangenciais mostradas na malha deformada. 
 


