


� Overview of Ansoft Designer GUI
� Using interface

� Circuit Design
� Building schematic
� Analysis circuit
� Tuning
� Optimization 
� Statistical analysis
� Layout basic
� Building Hierarchy

� LNA Design
� Input/output Matching – Smith tool
� Nonlinear analysis

� RF 1 tone
� DC analysis
� RF 2 tones
� modulation

� Load-Pull analysis
� Oscillator Analysis

� Transient Analysis
� Harmonic balance and Phase noise

� Field Solver Design basic
� Create stack-up
� Drawing geometry
� Parameterized geometry
� Analysis

� Co-simulation
� Use field solver simulation in 

circuit design
� Tuning Field solver design

� Planar EM Antenna Design





Ansoft Designer Overview

� Multi Window Desktop
� Design Capture
� Layout
� Multiple Simulation Types
� Circuit Simulation 
� System Simulation 
� EM Simulation
� Co-Simulation 
� Design Automation
� Synthesis
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� Synthesis

Analysis Types:
� Linear Network Analysis
� Harmonic Balance
� 3D EM Analysis
� Harmonic Balance Oscillator
� Modulation Envelope
� Transient
� Convolution
� DC Analysis
� Stability
� LoadPull

Analysis Types:
� Linear Network Analysis
� Harmonic Balance
� 3D EM Analysis
� Harmonic Balance Oscillator
� Modulation Envelope
� Transient
� Convolution
� DC Analysis
� Stability
� LoadPull
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Double click on the design icon
to open the schematic editor

Click on the +/- to expand 
or collapse the tree

Double click on the substrate 
or analysis icon to open the 
Definition dialog for those 
objects

Double click on the graph 
icon to display results Tabs for project, 

Components, 
and Search



Right Clicking on Icons in the 
project window brings up 

various menus

Right Clicking on Icons in the 
project window brings up 

various menus



Place components by either:
1. Double clicking and placing
2. Right-clicking and placing
3. Click-and-drag to window

Place components by either:
1. Double clicking and placing
2. Right-clicking and placing
3. Click-and-drag to window



Search by name, type, 
or partial names
Search by name, type, 
or partial names



The property window is dockable, or 
can be brought up by double-
clicking on a component

The property window is dockable, or 
can be brought up by double-
clicking on a component

Property windows contains tabs 
which address different types of 
properties, such as General, 
Symbol, Variables, etc.

Property windows contains tabs 
which address different types of 
properties, such as General, 
Symbol, Variables, etc.



To wire a component:
1. Move mouse to hover over a node
2. The cursor changes to an “X”
3. Click to make connection
4. Move cursor to another node (or a wire)
5. When the cursor is over another connection point, 

it will revert back to an “X”
6. Click to make connection

To wire a component:
1. Move mouse to hover over a node
2. The cursor changes to an “X”
3. Click to make connection
4. Move cursor to another node (or a wire)
5. When the cursor is over another connection point, 

it will revert back to an “X”
6. Click to make connection



To Realign the layout choose Edit-> align MW ports 
(Hotkey Ctrl-m).
• If two or more components are selected, only 

those components will be aligned
• If nothing is selected, the complete layout will be 

realigned 

To Realign the layout choose Edit-> align MW ports 
(Hotkey Ctrl-m).
• If two or more components are selected, only 

those components will be aligned
• If nothing is selected, the complete layout will be 

realigned 



The 3D view can be zoomed, rotated, and operated on.  
• Right clicking brings up the menu choices.  
• There are also many hotkeys.

The 3D view can be zoomed, rotated, and operated on.  
• Right clicking brings up the menu choices.  
• There are also many hotkeys.



The progress window is also a detachable 
window.   This window tells you the status 
of a simulation.  It comes up automatically 
when a simulation is performed

The progress window is also a detachable 
window.   This window tells you the status 
of a simulation.  It comes up automatically 
when a simulation is performed



The Message window shows error 
and informational messages 
about various processes in 
Designer.  

The Message window shows error 
and informational messages 
about various processes in 
Designer.  



Simulation results can be plotted 
in many 2D and 3D many formats, 
such as tables, cartesian, polar, 
smith, and others.

Simulation results can be plotted 
in many 2D and 3D many formats, 
such as tables, cartesian, polar, 
smith, and others.



Menus change dynamically depending on which Design 
window is highlighted (Circuit, Planar EM or System)
Menus change dynamically depending on which Design 
window is highlighted (Circuit, Planar EM or System)



� One to One Component Correspondence 
� User can work directly in Layout
� Components placed in schematic automatically 

appear in Layout and vice-versa
� Property edits in Layout are reflected in Schematic

� One to One Component Correspondence 
� User can work directly in Layout
� Components placed in schematic automatically 

appear in Layout and vice-versa
� Property edits in Layout are reflected in Schematic



� Common Desktop/GUI: Circuit, Planar EM, System all 
work from a common GUI. 

� Co-Simulation: Circuit/System/Planar EM 
� Solver on demand: EM Kernel components
� Common project, component, library management. 

� Common Desktop/GUI: Circuit, Planar EM, System all 
work from a common GUI. 

� Co-Simulation: Circuit/System/Planar EM 
� Solver on demand: EM Kernel components
� Common project, component, library management. 



Design Automation 
Component Libraries

� Components, Materials, Symbols 
etc. are organized into libraries.

� Libraries are stored in
Ansoft\Designer\syslib
Ansoft\Designer\userlib
Ansoft\Designer\PersonalLib

� Specific Libraries are “configured” 
for each project making the 
Components, Materials etc. 
available for use in that project. 



� Important File Extensions for 
Ansoft Designer:
� .adsn   Project File
� .aclb Component Lib
� aflb Footprint Lib
� .asty Technology File
� .aslb Symbol Lib
� .asol Solution Data File
� .amat Material Lib

� Important File Extensions for 
Ansoft Designer:
� .adsn   Project File
� .aclb Component Lib
� aflb Footprint Lib
� .asty Technology File
� .aslb Symbol Lib
� .asol Solution Data File
� .amat Material Lib

Every Project created is saved on disk as an .adsn file (AnsoftDesign file)

Ansoft Designer automatically creates a File Folder named 
“ProjectName.results”    to hold the results files, netlist etc. for the project.



Building a Low Pass Filter



� Open Designer
� Insert Circuit Design

� Select Technology file
� View data loaded by technology file
� Save technology file

� Insert components
� Move copy and paste
� 6 Microstrip transmission lines
� 2 smc capacitors Philips library
� 2 grounds
� 2 Microstrip Tees
� 1 smc inductor toko library
� Add ports

� Set substrate parameters
� Rename circuit

� Define variables From component or project tree
� Wline = 0.8mm
� Lline = 1mm
� Cvalue = 10 (pf)

� Add analysis setup
� Select Linear
� Start 0.1Ghz Stop 3Ghz Step 0.01Ghz and click Add
� Run

� Create Report
� Add traces
� Edit graph

� Create parametric Sweep
� Step Cvalue from 2 to 12 step 2 

� Create Report
� Plot S21 (Cartesian)
� Plot s21 (3D)

� Tune
� Set Cvalue for tuning
� Set l parameter for tuning (inductor)
� Tune (real time)

� Optimization
� Set L and CValue for optimization
� Set parameters to optimize
� db(s21) at 1GHz  = -3 Weight 10
� Db(s11) from .5Ghz to 1ghz <= -30 Weight=1

� Statistical Analysis
� Define Parameters
� Set both C and L for uniform distribution 

� View results
� View Data and Histogram
� Layout



• Double-Click on the Ansoft Designer icon 
• located on the desktop or 

• Use Start > Programs > Ansoft Designer (folder) > Ansoft Designer 

• Double-Click on the Ansoft Designer icon 
• located on the desktop or 

• Use Start > Programs > Ansoft Designer (folder) > Ansoft Designer 



Insert Circuit Design
(Select Technology File)

• Right - Click on project folder
• Select Insert -> Circuit Design

• Right - Click on project folder
• Select Insert -> Circuit Design

• The “Choose Layout Technology” appears
• Select FR4 .060in
• Click “Open”

• The “Choose Layout Technology” appears
• Select FR4 .060in
• Click “Open”

From a general way of working when you don’t know what to do on a specific folder, 
just click right on it and the list of command available for this folder will be prompted.
From a general way of working when you don’t know what to do on a specific folder, 
just click right on it and the list of command available for this folder will be prompted.

Note that if you don’t want the set of definitions that come
with a technology file, you can choose the None button. 
This is useful for basic concept designs without any 
manufacturing or substrate information.

Note that if you don’t want the set of definitions that come
with a technology file, you can choose the None button. 
This is useful for basic concept designs without any 
manufacturing or substrate information.



� A Technology File initializes a design with a set of data to avoid repeated entry of commonly used data.  
� This data can consist of layers and stackup information for layout, configured libraries of components, and substrate definition(s) for circuit analysis.  
� Users and foundries can customize Technology Files for their ownmanufacturing process and simulation models.
� A “technology” file contains stackup, substrate information and list of libraries to load. 
� These information can be created, saved, copied and changed to suit the user.  Designer has many standard technology files to choose from.  They range from simple substrates such as single layered alumina, to complex multi-layered stackups.   The user can also create their own simple or complex technology files and stackups, or modify existing ones. 



View Data Loaded by Technology file 

Double click on the substrate icon to 
open the substrate definition dialog 

Single click on the stackup icon in the 
toolbar to open the stackup dialog 

Note that the dielectric information is disabled.  This 
indicates it is referencing a layer in the stackup.

The metallization is also referencing the 
Trace layer.

Either of these can be 
edited by clicking on the 
Edit buttons, but this will 
break the connection to 
the physical stackup.



• Choose Tools -> Configure Libraries…• Choose Tools -> Configure Libraries…



• Click left on circuit1 to highlight it (Save As Technology File is 
only available when a Planar EM, Circuit or System design is 
selected)

• Choose File -> Save As Technology File
• Save the Technology File either in userlib or Personallib

• Click left on circuit1 to highlight it (Save As Technology File is 
only available when a Planar EM, Circuit or System design is 
selected)

• Choose File -> Save As Technology File
• Save the Technology File either in userlib or Personallib



Insert Component 
(Vendor Library Capacitors)

• Click on Components Tab in Project Window
• Scroll to Vendor Elements
• Expand “Capacitors” Folder
• Expand “Philips” Folder
• Click “Philips_smc_0603” and drag to schematic window
• Hit the “R” key to rotate Capacitor to vertical Position Shown
• Click on Schematic window to place component
• Move cursor  to another area click again

• This places a second capacitor

• Click on Components Tab in Project Window
• Scroll to Vendor Elements
• Expand “Capacitors” Folder
• Expand “Philips” Folder
• Click “Philips_smc_0603” and drag to schematic window
• Hit the “R” key to rotate Capacitor to vertical Position Shown
• Click on Schematic window to place component
• Move cursor  to another area click again

• This places a second capacitor



Insert Remaining Components
(Vendor Library Inductor, Transmission Lines)

• Click on Components Tab in Project Window
• Scroll to Vendor Elements
• Expand “Inductors” Folder
• Expand “Toko” folder
• Click “Tokoll1608f” and drag to schematic window
• Click on Schematic window to place component
• Repeat to place MS Transmission Line, Physical Length

• Place a total of 2
• 1 Vertical, 1 Horizontal
• Located in Circuit Elements > Microstrip > Transmission Lines

• Repeat to place MS TEE – Ref Planes at edge
• Located in Circuit Elements > Microstrip > _General Components

• Click on Components Tab in Project Window
• Scroll to Vendor Elements
• Expand “Inductors” Folder
• Expand “Toko” folder
• Click “Tokoll1608f” and drag to schematic window
• Click on Schematic window to place component
• Repeat to place MS Transmission Line, Physical Length

• Place a total of 2
• 1 Vertical, 1 Horizontal
• Located in Circuit Elements > Microstrip > Transmission Lines

• Repeat to place MS TEE – Ref Planes at edge
• Located in Circuit Elements > Microstrip > _General Components



Viewing Window
Copy, Paste & Move

• Right-Click on schematic to view the zoom options
• There are menus and quick key equivalents for all

• Right click on a component to see the component menu choices
• Note the menu choices for copy, paste, etc.
• Each has a quick-key equivalent next to it

• Click on a component and drag to move it
• Create 6 more transmission lines with cut and paste

• Right click or quick-key
• Create another “tee” with copy and paste

• Right click or quick-key
• Rotate & move the transmission lines to match schematic shown

• Right click or quick-key

• Right-Click on schematic to view the zoom options
• There are menus and quick key equivalents for all

• Right click on a component to see the component menu choices
• Note the menu choices for copy, paste, etc.
• Each has a quick-key equivalent next to it

• Click on a component and drag to move it
• Create 6 more transmission lines with cut and paste

• Right click or quick-key
• Create another “tee” with copy and paste

• Right click or quick-key
• Rotate & move the transmission lines to match schematic shown

• Right click or quick-key



• Place cursor over a component pin
• Cursor becomes an “x” for the wiring tool

• Click on pin
• Move cursor to pin you want to connect

• You will see a “blue” wire
• Click on that pin
• Move a component so that its pin lies directly over another pin

• This also connects the two component pins

• Place cursor over a component pin
• Cursor becomes an “x” for the wiring tool

• Click on pin
• Move cursor to pin you want to connect

• You will see a “blue” wire
• Click on that pin
• Move a component so that its pin lies directly over another pin

• This also connects the two component pins

Place two grounds by 
clicking on the ground Icon

Cursor turns into an “X” 
when you move the 
mouse over a pin

Connect components 
as shown on next slide
Connect components 
as shown on next slide



Place two ports by clicking 
on the Port Icon

Double clicking on 
the port brings up 
the port dialog box

• At  this point, rename the circuit and save the project
• Click right on circuit1 
• select rename 
• enter LPF and hit return

• Save the project
• Right click on project folder and select save.
• Enter LPFProject in field File Name
• click Save

• At  this point, rename the circuit and save the project
• Click right on circuit1 
• select rename 
• enter LPF and hit return

• Save the project
• Right click on project folder and select save.
• Enter LPFProject in field File Name
• click Save

Ports also appear in project 
tree.  Double-click to open 
properties box



Clicking on a single component 
outlines the component in Red
and shows that component’s 
properties in the dockable
properties window

Multiple tabs are available 
which show different sets 
of properties

Double-Clicking on a component 
outlines brings up the Properties 
Dialog Box, which is just an 
“expanded” version of the 
dockable properties window



Clicking on a multiple component (either 
by click-dragging or control-click) will 
show the “common” properties of the 
selected components  in the dockable
properties window.  Note that the 
“Primary” selection (or the first 
component selected) will be in a brighter 
Red, while the other selected components 
will be in a darker red.

In this schematic, the selected 
components are 3 MS transmission 
lines and 1 MS TEE. Substrate is a 
common parameter.  This allows the 
user to quickly change the “common” 
values of many components at once. 

The user can also edit on the 
schematic, modifying parameters
value directly by typing on the 
schematic

The user can also edit on the 
schematic, modifying parameters
value directly by typing on the 
schematic



Double click on this inductor 
to bring up this properties 
dialog box

Double click on this inductor 
to bring up this properties 
dialog box

The inductor and Capacitors are elements form the vendor 
library.  These components have predefined properties, such 
as footprints (discussed later) and parameters.

The inductor and Capacitors are elements form the vendor 
library.  These components have predefined properties, such 
as footprints (discussed later) and parameters.

Clicking on this value brings up the 
possible vendor models shown on the 
right.  Select 10nh for the inductor and 
10pf for the capacitance



Defining Variables
Component Selection Methods

Click on the value field of the inductor.  
The cursor will change to an insertion 
cursor, allowing the user to type in a 
new value.  Type in 10nh 

Multiple select ALL the MS transmission lines.  In the 
dockable properties window, type wline for the value 
of width, w.  Since wline has not been previously 
defined, the dialog box to the right will appear, 
prompting the user to enter a value for wline.  Enter 
0.8mm and click the radio button for Local Variable.  
Click ok. Type lline for p, Enter 1mm and click the 
radio button for Local Variable. 



Defining Variables
Circuit Selection method

Right click on the LPF icon in the project window. This 
brings up the shown menu.  Choose Design Properties…

We want to add a new parameter, click add…

The Add Property dialog appears.  Type Cvalue
for the name and 10pf for the value.  Click OK



� Three different types of Variables:
�� Local VariablesLocal Variables

� Entered directly  in parameter field
� RM Click on Design and select Design Properties

�� Definition ParametersDefinition Parameters
� Passed parameters for a Design
� Entered in same manner as Local Variables

�� Project VariablesProject Variables
� Global parameters selected from Project menu
� $ added to designate project variable List of predifined variablesList of predifined variables



Defining Variables
Final Variable Assignment

Assign the value wline for the properties w1, w2 and w3 in 
the MS tee by using any of the aforementioned methods.  
Notice that Designer will not prompt for variable names 
since the value of wline has already been defined.

Assign the variable cvalue to 
the c parameter of the two capacitors.



The schematic is completed we have to define the Analysis 
setup.
Click right on Analysis, select Add Analysis Setup

The schematic is completed we have to define the Analysis 
setup.
Click right on Analysis, select Add Analysis Setup



You can select from a 
list of different Analysis 
Setup :
Linear Network Analysis
Harmonic Balance
Harmonic Balance 
Oscillator
Modulation Envelope
Transient Analysis
DC Analysis
DC Nyquist Analysis
Load Pull Analysis

You can select from a 
list of different Analysis 
Setup :
Linear Network Analysis
Harmonic Balance
Harmonic Balance 
Oscillator
Modulation Envelope
Transient Analysis
DC Analysis
DC Nyquist Analysis
Load Pull Analysis

Select Linear Network Analysis 
and click next
Select Linear Network Analysis 
and click next

Click Add to add SetupClick Add to add Setup

Select Linear Step 
Enter Start 0.1Ghz Stop 3Ghz Step 
0.05Ghz and click Add and OK.

Select Linear Step 
Enter Start 0.1Ghz Stop 3Ghz Step 
0.05Ghz and click Add and OK.

The Add/Edit Sweep 
dialog enables the 
Setup of Single 
Values and multiple 
Sweep types. 

The Add/Edit Sweep 
dialog enables the 
Setup of Single 
Values and multiple 
Sweep types. 

Click finishClick finish

Hit CTRL+S to save the projectHit CTRL+S to save the project

1 2
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Analysis setup name NWA1 is added under the Analysis Folder.
Click right on NWA1 icon and select Analysis NWA1.
The progress bar shows the status of the analysis

Analysis setup name NWA1 is added under the Analysis Folder.
Click right on NWA1 icon and select Analysis NWA1.
The progress bar shows the status of the analysis



Simulation Successfully Completed

Once the simulation is finished you can check in the Message Window that 
the simulation is correctly completed.
Any problem encountered during simulation will be related in this window.

Once the simulation is finished you can check in the Message Window that 
the simulation is correctly completed.
Any problem encountered during simulation will be related in this window.



To initiate plotting results:
Right click on Results in the Project Manager Window

Then:
Select Create Report

The Create Report Dialog allows the generation of 
Rectangular, Polar, Table, Smith Charts, and 3D Plots. 

For this analysis we’ll create a Rectangular Plot
Select OK and the Report Editor Appears



To create a Plot from the Report Editor:
Click on S-parameters
Click on S11 and S21
Click on dB
Select Add Trace
Select Done

Y-Axis – select the Y-axis which to plot the 
trace against (maximum of 4 available)

Design – if the project has multiple top-level 
designs, select the desired design

Solution – if the design has multiple analysis 
setups, select the desired analysis

Domain – different domains are available 
depending on the solution, including 
frequency domain, time domain, and sweep 
domain
Sweeps Tab – allows you to determine the 
sweep variables and their order to be used



Click Right and Select Data Marker, you’ll see a 
small marker on the first trace.  
Select the S21 trace in the legend to put the data 
marker on that trace.  As you move the cursor, the 
data marker follow it.  
You can also use the keyboard arrow keys to 
move the marker left and right and between 
traces.
Position the marker at 1Ghz point and click the 
mouse button (or hit the “t” key).  A tag will 
appear.  Move the marker over to the second 
second curve and click again; a second tag will 
appear.



Note that you can 2X click on any 
item in the plot window (traces, 
axes, legends, title, background 
etc.) in order to change its 
attributes (color, line style, scale, 
font etc.)

Note that you can Right click 
anywhere in the Plot window to 
bring up this dialog which enables
Markers, Zooming, etc.



There are also a number of operations available from the right 
mouse popup menu from within the graph:

Modify Report – show the Reporter dialog for this graph
Zoom In/Out/Autoscale – view a magnified or original graph
Trace Type – Enabled when a trace is selected. Modify the 

method of viewing the trace.
Data Marker – Put a tag on the trace to mark a specific point
Mark All Traces – Show data points for all traces at once
Arrows – Display arrows on the trace to show increasing 

calculation index
Add Label – Put text on the trace
Delete – Enabled when a trace is selected to delete the trace
Delete All Tags – Delete the marker tags
Accumulate – Keep prior traces on the graph up to the 

Accumulate Depth (settable in Tools>Options>Report 2D 
Options)

Print – Send to printer
Copy to Clipboard – Put a copy of the graph on the clipboard to 

paste into other applications



In Ansoft Designer you can use any variable to 
define a sweep. We will sweep Cval. 
Click right on Analysis, select Add Analysis Setup, 
select Linear Network Analysis, click next.

In Ansoft Designer you can use any variable to 
define a sweep. We will sweep Cval. 
Click right on Analysis, select Add Analysis Setup, 
select Linear Network Analysis, click next.

You can notice that for a same circuit one can 
define multiple analysis setup.
Edit F and define linear step sweep from 0.1Ghz to 
3Ghz by step of 0.05Ghz, click ok.

You can notice that for a same circuit one can 
define multiple analysis setup.
Edit F and define linear step sweep from 0.1Ghz to 
3Ghz by step of 0.05Ghz, click ok.

Click Add, Click the arrow close to 
variable field, all the defined variable can 
be selected.

Click Add, Click the arrow close to 
variable field, all the defined variable can 
be selected.

Select Cvalue and define a linear step 
from 2pf to 12pf by step of 2pf.
Click ok and finish.

Select Cvalue and define a linear step 
from 2pf to 12pf by step of 2pf.
Click ok and finish.

4 3

1 2

Hit CTRL+S to save the projectHit CTRL+S to save the project



Click right on Csweep and select Analysis Csweep.
You can notice that if you click right on Analysis and 
select Start Analysis you will run successively NWA1 
and Csweep analysis.

Click right on Csweep and select Analysis Csweep.
You can notice that if you click right on Analysis and 
select Start Analysis you will run successively NWA1 
and Csweep analysis.



Click right on Results folder select create report.
Click the arrow of field solution and select 
Cvalsweep, hit the sweep Tab.

Click right on Results folder select create report.
Click the arrow of field solution and select 
Cvalsweep, hit the sweep Tab.

Clicking on one of the sweep variable shows the 
swept values, you can select all the value, one value 
or several value.
Use the shift and CTRL key to select multiple value.

Clicking on one of the sweep variable shows the 
swept values, you can select all the value, one value 
or several value.
Use the shift and CTRL key to select multiple value.

Clicking on the name of the variable you can 
change the sweep order.
Hit Tab Y and add S21 in DB, Click Done

Clicking on the name of the variable you can 
change the sweep order.
Hit Tab Y and add S21 in DB, Click Done



Each curve corresponds to a value of Cvalue.
Each curve is indexed with the value of the variable
Click on the curve/Value to highlight the curve/value

Each curve corresponds to a value of Cvalue.
Each curve is indexed with the value of the variable
Click on the curve/Value to highlight the curve/value



It is possible to create 3D plot to simultaneously view two 
parameters sweep.
Click right on results, select 3D Rectangular plot, hit Tab Z add 
S21 in DB. Click done.

It is possible to create 3D plot to simultaneously view two 
parameters sweep.
Click right on results, select 3D Rectangular plot, hit Tab Z add 
S21 in DB. Click done.



Tuning provides an interactive means 
of changing a design’s variables or 
component values and viewing the 
results immediately.  
Any variable or parameter can be 
swept.
In this example, we will define 
variable Cvalue and parameter L of 
the inductor to be tunable.
You can select any of the variables to 
include in tuning.  Select the 
checkbox for Cvalue.
The minimum and maximum values 
are automatically set to be ½ and 1 ½ 
times the nominal value. You can 
change them, if desired.
Next select Circuit > Tune and you’ll 
see the tuning dialog 
or click right on Optimetrics and select 
tuning

Tuning provides an interactive means 
of changing a design’s variables or 
component values and viewing the 
results immediately.  
Any variable or parameter can be 
swept.
In this example, we will define 
variable Cvalue and parameter L of 
the inductor to be tunable.
You can select any of the variables to 
include in tuning.  Select the 
checkbox for Cvalue.
The minimum and maximum values 
are automatically set to be ½ and 1 ½ 
times the nominal value. You can 
change them, if desired.
Next select Circuit > Tune and you’ll 
see the tuning dialog 
or click right on Optimetrics and select 
tuning



The main part of the dialog consists of the tune 
variable sliders where you can simply move the slider 
to a new value and analysis is continually performed 
as you move it. Delete a tune variable from the dialog 
by clicking on the X for that variable.
The Real Time checkbox indicates that the program 
will do an analysis and update the graphs each time a 
slider is moved.  Un-checking Real Time allows you to 
position the slider without performing an analysis until 
the Tune button is clicked.
If your design had more than one simulation setup, a 
list would be present and you could select which 
setups to include in the tuning analysis.

The main part of the dialog consists of the tune 
variable sliders where you can simply move the slider 
to a new value and analysis is continually performed 
as you move it. Delete a tune variable from the dialog 
by clicking on the X for that variable.
The Real Time checkbox indicates that the program 
will do an analysis and update the graphs each time a 
slider is moved.  Un-checking Real Time allows you to 
position the slider without performing an analysis until 
the Tune button is clicked.
If your design had more than one simulation setup, a 
list would be present and you could select which 
setups to include in the tuning analysis.

Briefly, other buttons include:
Tune – perform an analysis
Abort – stop the analysis
Save – remember the current state 
(values) of the tune variables and 
name this state.  Also, optionally 
apply the values back to the design.
Revert – recall a saved state
Reset – revert to the original tune 
variable values
Close – close the dialog.  You will be 
asked if you want to apply the tuned 
values if you have not already done 
so.

Briefly, other buttons include:
Tune – perform an analysis
Abort – stop the analysis
Save – remember the current state 
(values) of the tune variables and 
name this state.  Also, optionally 
apply the values back to the design.
Revert – recall a saved state
Reset – revert to the original tune 
variable values
Close – close the dialog.  You will be 
asked if you want to apply the tuned 
values if you have not already done 
so.



Move the sliders around and watch the graph change.  
You can still edit the design, change the design 
properties, or change the analysis setup while the tune 
dialog is active.  So, for example, you may want to 
reduce the number of analysis points in the analysis 
setup for faster updates.

Move the sliders around and watch the graph change.  
You can still edit the design, change the design 
properties, or change the analysis setup while the tune 
dialog is active.  So, for example, you may want to 
reduce the number of analysis points in the analysis 
setup for faster updates.



You can also setup a sweep of a tune variable by 
clicking on the Sweep checkbox.
You can also setup a sweep of a tune variable by 
clicking on the Sweep checkbox.



You can either select a 
value from the tune or 
none.
For none Click Don’t 
Apply

You can either select a 
value from the tune or 
none.
For none Click Don’t 
Apply

Delete Cvalue tune variable from the dialog by clicking 
on the X for that variable. 
Select  NWA1 and Csweep to tune multiple sweep.
Move the sliders around and watch the graphs change.
Close the Tune window.

Delete Cvalue tune variable from the dialog by clicking 
on the X for that variable. 
Select  NWA1 and Csweep to tune multiple sweep.
Move the sliders around and watch the graphs change.
Close the Tune window.

Hit CTRL+S to save the projectHit CTRL+S to save the project



Optimization: Define optimizable parameters

Double click on the Inductor symbol,
then select the Optimization view 
and click the Include button to ensure 
that L is used in the optimization.
Set Min to 2nh and Max to 18nh 

To run optimization we have to define the variable,
parameters to be optimizable and to define goals.
We will select the capacitors and inductor to be
optimizable.

As capacitors value are variable click right on LPF 
design and select Design Properties.
Then select the Optimization view and click the Include
button to ensure that Cvalue is used in theoptimization.
Set Min to 2pf and Max to 18pf. 



The next step is to set up a goal for the Optimization. 
Right click on Optimetrics in the Project Manager and then select 
Add > Optimization
This will bring up the
Setup Optimization Analysis dialog.



Optimizer allows to select from the 4th
different algorithms.
Select Random
Select Max. No of iterations     100

Clicking on Solution gives the user 
a dropdown dialog of all applicable 
Analyses.
Click Add and Select NWA1



Calculation allows to define the measurements
to be optimized. 
It could be measurements, equations or complete 
S, Y, Z matrix

Click in the field and enter db(s21)

Ansoft Designer lets the user 
create custom expressions for 
plotting and optimizing.

Ansoft Designer lets the user 
create custom expressions for 
plotting and optimizing.



Optimization: Define Calculation Range
Calc. Range can be single value
or band width. Default is the 
frequency range of Analysis setup

Select single Value,
Value = 1GHz
Click Update and Ok



Select     =

Clicking on Condition gives the a 
dropdown dialog of all equalities
Condition can be 
Equal : =
Less Than or Equal: <=
Greater than or Equal >=



The Goal can be defined as :
Single numerical value,
Expression (equation, sub-circuit name , S parameter file),
Variable Dependent (for parametric sweep)
Weight allows to increase the contribution of a specific 
goal to the whole error function when multiple goals are 
defined

The Goal can be defined as :
Single numerical value,
Expression (equation, sub-circuit name , S parameter file),
Variable Dependent (for parametric sweep)
Weight allows to increase the contribution of a specific 
goal to the whole error function when multiple goals are 
defined

Enter -3 as the Goal and 10 as the weight
Enter an additional goal to be
NWA1 db(s11)  F (from 100MHz to 850MHz)  <=  -15   (1)
In this case the contribution of the s21 goal on the 
whole error is multiply by 10 due to weight setting.

Enter -3 as the Goal and 10 as the weight
Enter an additional goal to be
NWA1 db(s11)  F (from 100MHz to 850MHz)  <=  -15   (1)
In this case the contribution of the s21 goal on the 
whole error is multiply by 10 due to weight setting.



Optimization Setup: 
Tab Variable and General

Hit the Variable tab.
This allows to change the minimum and 
maximum values or to exclude one or more 
parameters from the optimization

Hit the Variable tab.
This allows to change the minimum and 
maximum values or to exclude one or more 
parameters from the optimization

Hit the General tab 
This is used to define the 
strategy of updating the 
design parameters during 
and after optimization

Hit the General tab 
This is used to define the 
strategy of updating the 
design parameters during 
and after optimization



Click right on Optimetricsetup1 and select 
Analysis.
The progress window appears showing the 
optimization progress.

Click right on Optimetricsetup1 and select 
Analysis.
The progress window appears showing the 
optimization progress.



Click right on 
optimization and select 
View Analysis Result

Click right on 
optimization and select 
View Analysis Result

A window is displayed with the 
value of the cost function and 
the corresponding values of 
optimizable parameters

A window is displayed with the 
value of the cost function and 
the corresponding values of 
optimizable parameters



View Optimization Result on Graph

You can see on graph the result of 
optimization.
As we selected the option, the value 
of optimizable parameters were 
automatically updated.

You can see on graph the result of 
optimization.
As we selected the option, the value 
of optimizable parameters were 
automatically updated.



Set the parameters for Inductor

The results of optimization set L value of inductor to 8.72nh. 
Click on Choose model and select the normalized value closest 
To this value. Select 8.2nh 10% and click ok.

The results of optimization set L value of inductor to 8.72nh. 
Click on Choose model and select the normalized value closest 
To this value. Select 8.2nh 10% and click ok.

Select tolerance to 10% automatically defines tolerance for statistical 
analysis to 10%.
All vendor library components using tolerance in their definition are 
automatically included in the statistics.
You can verify it checking statistic window.

Select tolerance to 10% automatically defines tolerance for statistical 
analysis to 10%.
All vendor library components using tolerance in their definition are 
automatically included in the statistics.
You can verify it checking statistic window.



Set the parameters for Capacitor

Cvalue found by optimization=3.97. Select the two capacitors and click
Choose Model . You will change in one action both capacitor C parameter
Cvalue found by optimization=3.97. Select the two capacitors and click
Choose Model . You will change in one action both capacitor C parameter

Select 3.9pf tolerance 0.25pfSelect 3.9pf tolerance 0.25pf Once C parameter is set you can double click on one of the 
capacitor and check the statistic window.
If needed you can choice between Uniform and Gaussian 
distribution. Click on tolerance button to change the tolerance

Once C parameter is set you can double click on one of the 
capacitor and check the statistic window.
If needed you can choice between Uniform and Gaussian 
distribution. Click on tolerance button to change the tolerance



1
Enter iteration number 50.
Click Add and select NWA1 
for Solution

Enter iteration number 50.
Click Add and select NWA1 
for Solution

Enter db(s21) in Calculation 
field
Enter db(s21) in Calculation 
field 2

Hit Edit Calc. Range and 
select 1GHz
Hit Edit Calc. Range and 
select 1GHz 3

The Variables tab allows to 
change parameter settings or 
exclude parameter

The Variables tab allows to 
change parameter settings or 
exclude parameter 4



Enter statistical goals as shown aboveEnter statistical goals as shown above



Right-click on Statisticalsetup1 icon 
and choose analyze to run analysis 

The Statistical Analysis is running and the plot 
automatically updated.
When Statistical Analysis is finished you can look at 
the distribution of the results.

The Statistical Analysis is running and the plot 
automatically updated.
When Statistical Analysis is finished you can look at 
the distribution of the results.



Right-click on Statisticalsetup1 icon 
and choose View Results to see a data 
table or histogram plot



Select the 
number of 
bins

Select which 
result to view

Select Plot to see histogram







Click on the layout Icon 
to see the layout view

Alternatively, you can 
right-click on the circuit 
icon and choose layout

Replace ground 
elements by MS Via Pad



If you don’t get the layout aligned, 
hit Ctrl-M 
Or click on Align MW Ports icon
Or Select Menu Draw and click on
Align MW Ports
When none element is selected 
the whole layout is align.



The connection points are visible.
To make it non visible:
Select Menu Layout
Select Settings
Uncheck Draw Connection Points

When you select a footprint 
and move it, if this footprint is 
connecting  the connection is 
drawn as a wire on layer rats.



Click on the Align Microwave Port 
to icon to align the Footprint
(Hotkey Ctl-m)

Select first the element that will be 
the reference of the alignment.
The selected component appears 
in red.

Select first the element that will be 
the reference of the alignment.
The selected component appears 
in red.

Using Ctrl + Left Mouse button 
Select the second element to 
aligned. This second element 
appears in low red.

Using Ctrl + Left Mouse button 
Select the second element to 
aligned. This second element 
appears in low red.

You can apply any positioning modification to 
footprint move, rotate, mirror and then use the 
Align Microwave Port function to align  them. Any 
positioning modification are save in the footprint 
properties.

You can apply any positioning modification to 
footprint move, rotate, mirror and then use the 
Align Microwave Port function to align  them. Any 
positioning modification are save in the footprint 
properties.



Click on Current Footprint value to 
open the footprint library window.
Then select the new footprint you 
want to use.

Click on Current Footprint value to 
open the footprint library window.
Then select the new footprint you 
want to use.

Edit layer mapping allows to 
change the default mapping 
between Footprint layers and 
circuit layers

Edit layer mapping allows to 
change the default mapping 
between Footprint layers and 
circuit layers

Location = x,y coordinate of the footprint on layout.
You can use it to move the footprint from a specific 
value. It is allowed to use +/-.
Example: -7.6mm+1mm,13.8 will move the footprint 
of 1mm on the x axis
Angle changing this value will rotate the footprint
Flipped when checked indicates that the fotprint
was flipped.
Scaling multiply all dimension by scaling value

Location = x,y coordinate of the footprint on layout.
You can use it to move the footprint from a specific 
value. It is allowed to use +/-.
Example: -7.6mm+1mm,13.8 will move the footprint 
of 1mm on the x axis
Angle changing this value will rotate the footprint
Flipped when checked indicates that the fotprint
was flipped.
Scaling multiply all dimension by scaling value



In Edit Layers Definition window you can change layers 
attributes: Visibility, Selectability, Color, Pattern
Double click on the color to open color selection window
Double click on the pattern  to open pattern selection window 



It is possible to draw shape in the layout these shape don’t have simulation properties.
Here we drawn a path around the layout design.
It is possible to draw shape in the layout these shape don’t have simulation properties.
Here we drawn a path around the layout design.

To draw shape several drawing primitives are available : 
Draw circle, Draw Rectangle, Draw Line, Draw Polygon
To draw shape several drawing primitives are available : 
Draw circle, Draw Rectangle, Draw Line, Draw PolygonEach object created using the 

drawing primitives get some 
drawing properties like height, 
width, coordinates. These 
properties can be set by 
numeric value as well as  
variables, equations or 
parameters.

Each object created using the 
drawing primitives get some 
drawing properties like height, 
width, coordinates. These 
properties can be set by 
numeric value as well as  
variables, equations or 
parameters.



Draw Rectangle
The properties of the rectangle are 
layer, Center, Width, Height, Angle

Draw Rectangle
The properties of the rectangle are 
layer, Center, Width, Height, Angle Draw Line

The properties of the Line are 
layer, LineWidth, (x,y) coordinate of vertex, Angle, 
Bend Type, Cap Type

Draw Line
The properties of the Line are 
layer, LineWidth, (x,y) coordinate of vertex, Angle, 
Bend Type, Cap Type

Draw Polygon
The properties of the Polygon are 
layer, (x,y) coordinate of vertex, Angle

Draw Polygon
The properties of the Polygon are 
layer, (x,y) coordinate of vertex, Angle

Draw Circle
The properties of the Circle are 
layer, Center, Radius 

Draw Circle
The properties of the Circle are 
layer, Center, Radius 



Select the Line Select the Line 
hit the vertex selection icon 
Press Alt and click where 
you want to add vertex

hit the vertex selection icon 
Press Alt and click where 
you want to add vertex New Vertex New Vertex 

Select the Line Select the Line 

Move the cursor to a vertex 
Press Ctrl key, click left mouse button 
and drag to convert line in arc.

Move the cursor to a vertex 
Press Ctrl key, click left mouse button 
and drag to convert line in arc.

Drag and move Edge to stretch geometryDrag and move Edge to stretch geometry



Snap to grid: snap the shape on the gridSnap to grid: snap the shape on the grid
Graphical snap:
snap vertex to vertex, vertex to center 
when you move or draw shape

Graphical snap:
snap vertex to vertex, vertex to center 
when you move or draw shape

SnapSnap

SnapSnap



Boolean operation allows union, 
intersection and subtract.
Boolean operation allows union, 
intersection and subtract.

unionunion
Subtract
Substract is order 
selected dependant

Subtract
Substract is order 
selected dependant



You can also import existing GDSII or DXF file.
Using map file allow you to map the layer names in Ansoft Designer with the GDSII layer number
You can also import existing GDSII or DXF file.
Using map file allow you to map the layer names in Ansoft Designer with the GDSII layer number



Select Edit Definitions Add a new footprint or use 
An existing one

Select the Technology 
File (use existing stackup)



Parameter of the drawing 
shape are set by numerical 
value



Parameterized layout cell
The parameter of the drawing primitive 
are set using the parameters defined for 
the footprint, directly or by the way of 
equation.

Parameters defined for the layout cell 
are automatically linked to parameters, 
with the same name, of the component 
to which the layout cell is associated.



Scripted parameterized layout cell.
the footprint is generated using a script which 
Can be written in JavaScript or VBScript.
Using a script allows to create complex 
Parameterized layout cells like transistor, 
rectangular spiral inductor. 
Moreover a script allows to check 
minimum and maximum dimensions provided
design rules checking at the component level. 
The edit script window allow the user to 
create, modify the script and see the effect of
the modification on the layout cell just by 
clicking apply no need to compile or reload 
after modification.



� Create a footprint
� Set grid
� Define parameters
� Draw and parameterize shape 
� Add ports
� Save to library

� User Exercise
� Create new circuit and insert into previously created 
circuit

� Edit symbol



Select Edit Definitions

Click Add Footprint

Select the Technology 
As shown and 
Click open

1

2

Enter SimpleTRL and 
Click OK 3

4

Click Edit Footprint
5



Click on icon Grid Snap Setting

Set the Grid setup as shown 



Click properties

Select Definition Parameters 
Tab and click Add

Add another parameter 
P with Value 6mm

1

2

Enter : Name W
Value 2mm

Select Variable
Click OK 3

4



Select Trace as the 
drawing layer 1 Click on Draw line 1

Click on Left 3 Drag the mouse 4 Click on Left 
escape

5



Use the Definition Parameters 
To set the properties. 
lineWidth = w
Pt0 = 0,0
Pt1 = p,0

2

Changing the value 
Of w and p will 
Change the shape.

3

Set BenType to Corner
Set CapType to Flat 1



Insert connection Ports 
To the left edge of the 
footprint

Insert connection Ports 
To the right edge of the 
footprint1 3

Set the Port Angle to 180 2 Set the location 
To p,0 4



Click the cross to 
Close the Footprint 
Editor Window. 1

Save the Footprint
2



Select Edit Definition
Select SimpleTRL1 2

Click Export Footprint Library 2

You can select PersonalLib or 
Userlib as the location where to 
Save the file

Enter the name of the file and
Click Save



From Project window expand folder 
Definitions/Components.
Double click on MSTRL to open 
The edit Component window

Click select above footprint view 
To select a new footprint.

The Edit Component window allows
to select Symbol and Footprint to 
associte to the component

You can select from footprint libraries 
the footprint you want to use

1

2

3

Click Cancel to 
avoid modification



� Using Subcircuits and Symbols
� Inserting Subcircuits
� Changing Symbols



Open LPFProject previously created.
Click right on LPFProject and select Insert Circuit Design.
Select MS-FR4(4.4) .060in as the Technology File.

Rename the inserted circuit HPF.
Define Definition Parameters as shown:
Wline=0.8mm, Lline=1mm

Add Analysis Setup Linear Sweep from 
0.1GHz to 5GHz by step of 
0.01GHz.

Analyze the circuit.

Create a report with S21 and S11 in DB,
rename it DBS21&S11.
Change the Xscale to 0.1GHz-2GHz.
Save the project

Build the schematic as shown above.
Tee       w1=w2=w3=wline
Trl w=wline, p=lline
Cap       Philips_smc_0603, 6.8nh, Tol 0.25pf
Ind Tokoll1608f, 18nh, Tol 10%

1

2

3

4

5



Each time a Planar EM, Circuit or System Design is created, a symbol, with the 
same name as the design, is created. To edit this symbol expand the Definitions 

folders, then the Symbol Folder and double click on the symbol, here HPF. 

Click the cross to close 
the Symbol editor widow

Modify the symbol as shown using arc.
Close and save the symbol.
Save the project.

You can draw arc, circle, line, polygon, rectangle and add text.



Copy and Paste the Circuit Design
Click right on HPF 
And select Copy 1

Click right on LPF 
And select Paste 2

You can choice to use the same
stackup as Parent circuit or to 
insert The sub-circuit as black box

3

When Incorporate is selected 
The  Merge layers window is 
displayed allowing to merge 
sub-circuit and parent circuit 
layers 4

Symbol of the pasted sub-circuit 
appears in the schematic 5



You can change the values 
of the sub-circuit parameters

Sub-circuit folder appears in the circuit Design tree.
If needed you can simulate it stand-alone from this location.







Insert a circuit and choice  Technology File MS – FR4 (Er=4.4) 0.060 inch, 0.5 oz copper.



Insert Vendors Elements/SParamData/NPN/NEC NPN 2 Port



Double click on the symbol transistor to edit properties,
Click on the Choose Model button and select ne68133i.s2p



Add port and ground as shown on the schematic



Add Linear Network Analysis Setup.
Sweep the frequency to 0.5GHz to 2GHz with a step of 0.01GHz



Run the analysis and produce a Smith Chart plot. 
Plot of S11 as shown.



Click on Report2D menu and select Smith Tool



The utility contains several areas:
The Grids area lets you draw constant R, X, G, B, Q, VSWR, and Rho 
circles on the plot.
The Circles area lets you draw Gain, Noise, and Stability circles.
The Mapping area lets you transform the responses from the source plane
to the load plane and vice-versa.
At the top of the dialog, there are tabs to switch between this Display
portion of the dialog and the Matching portion.  We will exercise both 
areas as this example proceeds.
At the bottom of the dialog is information that is calculated from the device
S Parameters, like Maximum Stable Gain, minimum NF, and stability 
factor, K.



SmithTool - Maximizing Performance

Point P

14dB constant 
Gain circle

1.5dB constant 
Noise circle

In the Circles area, select Avail. Gain Ga (S-Plane).  Enter 14 in the Start box and click 
on Apply.  An 14dB gain circle appears.  
Now, select Noise and enter 1.5dB.  Click Apply and a 1.5dB noise circle appears. 
In the Start box of section Grids enter 2 and click on VSWR.

In the lower right area, 
select a frequency of 0.9GHz.
Now, note that the Maximum Stable 
Gain is 14.99dB, the minimum Noise 
Figure (NF) is 1.04dB, and the 
stability factor, K, is 0.86, indicating 
that our amplifier is potentially 
unstable.



Stability Circle K=1 
(Source Plane) Stability Circle K=1 

Load Plane)

In the Circles area, select Stability K (S Plane) in the drop down list and click Apply. 
The source plane circle for K=1 appears, with small lines, or spokes, indicating which
side of the circle is stable.
In the Circles area, select Stability K (L Plane) in the drop down list and click Apply. 
The load plane circle for K=1 appears, with small lines, or spokes, indicating which 
side of the circle is stable.



In the Grids area, click on G.  The cursor jumps to the plot.  Click on point P to draw a constant G
circle through it.  This circle should be approximately G = 1.60.  
In the Grids area, click on R.  The cursor jumps to the plot.  Click on point P to draw a constant R
circle through it.  This circle should be approximately G = 0.52.



Click on the Matching tab on the SmithTool dialog.  The dialog changes as shown above.
For the input matching circuit, we will move on the Smith chart from 50 Ohms at the center of the chart 
to our point P.  
Click on the New Match button. 
When you do this, the cursor will immediately jump to the center of the Smith chart.  Without moving 
the mouse, click again to place the “crosshair” at 50 Ohms.
After you do this, the ten element buttons in the dialog (shown above in gray) will activate.  These are 
the available elements for use in the matching circuit, representing both lumped and distributed 
components.



SmithTool - Input Matching Circuit

Click on the shunt L button in the dialog. 
When you do so, a small “tail” will appear on the R = 1 circle. 
Grab this tail and drag it to the constant R circle that we added 
earlier (approximately R = 0.52).  
Then, click on the series C button in the dialog.  Again, a tail will 
appear from our last point.  Drag this tail to the point P to 
complete the match.
The approximate values for the matching elements should be:
L = 9.19nH, C = 12,79pF
Click on the Export button to write the subcircuit for the input 
match.
Click OK



SmithTool - Source/Load Mapping
Sub-Circuit Circuit1 is added 
To the Circuit Design Tree

Point Q

Our next task is to take the point used for our input match and 
transform it into the load plane.  SmithTool provides the 
capability to do this effortlessly.
In the Mapping section of the dialog, make sure that Available 
Gain Ga S->L is selected.  In the Gain (dB) box, enter 14, which 
is the same gain value that we used to determine point P.  Click
on Apply.
When you do this, a second circle will appear that represents 
the source plane gain circle mapped into the load plane.  Click 
on the source plane circle at point P.  Now, a new point appears
on the load plane circle representing the same point, but in the
load plane, as shown above.  We will call this point Q.



SmithTool - Complex Conjugation

Point Q*In order to complete the output match, we must take point Q in 
the load plane and conjugate it.  We will use the conjugated 
point, Q*,  to begin our output match.
Click Conjugate and click point Q.
This will create a point Q* with the same real part and opposite
imaginary part.



SmithTool - Output Matching Circuit

Click on the New Match button.  The cursor will jump to the 
Smith chart.  Click on the point Q* to start the match.
Click on the shunt L button.  Drag its tail up to the R = 1 circle.
Click on the series C button.  Drag its tail down to the center of 
the chart.
The approximate values are: L = 10.7nH,  C = 2.01pF
Click on the Export button to write the subcircuit for the output
match
Click OK
Hit Display Tab, Click Clear and OK



Rename Sub-Circuit Circuit1 
to InputMatch .
Rename Sub-Circuit2 Circuit 
to OutputMatch



Run the analysis.  When it completes, 
produce a rectangular graph with the 
following traces:
dB(S11), dB(S22), dB(S21), dB(NF)

Right click on the graph and select Data Marker.  Add a marker on each trace at 0.9GHz.  
As you can see, our design goals of 14dB gain and 1.5dB NF have been met.
Note that the input is -6DB.  Also, note that the output is resonated, providing an excellent match at 
the output. Save the current project.

Save the Project





Exercise:
LNA Design

Non-Linear Analysis



Non linear model replace 
S parameters file

Capacitor and Inductor use 
Normalized value

Resistor were added for bias

You can either load the circuit or created from the previous project.
If you want to create the circuit: Open the project LNAMatch and save it as LnaNLRF1TONE
To use the existing circuit click File Open and select LnaNLStart.
This circuit use a non linear model for the transistor (Vendor lib/nonlinear/npn/nec/ne68133)
instead of the S parameters data file.
Values of Capacitors and Inductors were replace by normalized values, resistors are added for bias.



Insert Voltage Source

Click on Components Tab.
Expand Source Folder then Independent Sources folder and 
insert Voltage source as shown above.
Set the source to 2.5V.



Click Right on LNA circuit and select View DC Bias.
This will display on the schematic the DC current and Voltage.
We can check the bias of the transistor 2.5V 3mA which was the 
one of the S parameter use for matching.

Save the Project



Even if we use a non linear model it is possible to run linear analysis, non linear model is linearised at the 
bias condition and the simulation will use the corresponding S parameters. This allow to check that the 
results with the non linear model are close to the one get with S parameter data file.

Add Linear Network 
Analysis setup, 
define a linear sweep 
from 0.5GHz to 2GHz 
by step of 0.01GHz.
Run the analysis.
Create a report : 
Rectangular Plot with 
dBS21, dBS11, dBS21, 
NF in dB.
Check the results.



Double click on the input port 1

Click Add in the Sources 
section 2

Double click on the input port symbol to open the Port Definition window.
In the source section click Add to open the Source Selection window.
Select power and enter Pin as the value of parameter P.
Click ok in the Source Selection window
Click ok the Port Definition window.
In the Project Manager window expand the Excitations folder to check 
that source named Sinussoidal1 is added.

Select Power.
Enter Pin for 
value of P 3

Define Pin as local 
variable with value 
of -10dbm 4



Add Analysis Setup select :
Analysis Type     Harmonic Balance
Analysis Name    HB1Tone1
Category 1-Tone
Click Next 1

Highlight F1 and click Edit, 
add single value of 0.9GHz, 
Click OK. 2

Click Add in the Harmonic Balance Analysis, 1-Tone window,
In the Variable field select Pin,
Add a Linear step from -40dBm to 0dBm by step of 1dB,
Click ok

3

Save the Project



Click right on Analysis Setup HBTone1 and select Analyze HB1Tone1.
The Progress Bar appears click right in the progress bar and select details to Circuit Analysis Details.



Select Transducer Gain, TG21<F1,F1>, dB to plot the gain between
fundamental at port1 and fundamental at port2. Click done

Click right on Results and create 
report – Rectangular Plot

Select HB1Tone1 in field Solution
Select Sweep in  field Domain
Select Power, PO2<F1>, dBm to plot the 
output power at port 2 for the fundamental.

1

2

3



Select HB1Tone1 
Check DCIV Curves 
Check AC Load Line Uncheck All Values 

Using CTRL key select 
-40, -30, -20, -10dBM
Click Add Trace

Click right on Results and 
create report 
Device IV Characteristics.

Here, we see two types of traces:
1. Device DC-IV characteristics, taken from the nonlinear model
2. Instantaneous operating point, or dynamic load line over an 
RF cycle

1

2
3



Click right on Results and 
create report 
Rectangular Plot.

Select Power, PO2, dBm
Click Add Trace, Click done

Select HB1Tone1 in field Solution
Select Spectral in  field Domain
Hit sweep Tab
Select Pin = -10dbm for the Pin value.

1

2

3



Click right on Results and 
create report 
Rectangular Plot.

Select Voltage, V2, none
Click Add Trace, Click done

Select HB1Tone1 in field Solution
Select Time in  field Domain
Select Pin = -40, -30, -20, -10 dbm 
for the Pin values

1

2

3 Save the Project



Optional Exercises:
(Intermod)

Digital Modulation



Add a Second RF Source to Port 1

Double click on the input port
1

Click Add in the Sources 
section 2

Select Power.
Set Fnum to f2 and Enter 
Pin for value of P
Click OK

3



Add Intermodulation Analysis Setup
Analysis Type Harmonic Balance
Analysis Name HB2ToneInter1
Category 2 Tones Intermodulation Spectrum
Click Next

1

Highlight F2, Uncheck Offset option and click Edit, 
add single value of 0.901GHz, Click OK.
Click Add

Add a Linear step from -40dBm to 0dBm by step of 
2dBm for variable Pin
Click ok

32



Select HB2ToneInter1 in field Solution, Select Sweep in  field Domain
Select Power, PO2<F1>, dBm to plot the output power at port 2 for the fundamental.
Select Power, PO2<-f1+2*f2> to plot the output power at port2 for the IM3.
Click done

Click right on Results and create report 
Rectangular Plot.

Here, we can see the difference in slopes between the
fundamental and third order products.  As expected, 
the third order term has a slope that is 3 times unity.



Enter in field expression :
dBm(PO2<F1>)+(dBm(PO2<F1>)-dBm(PO2<2F1-F2>))/2.
Enter in field Name IP3, Click Add, Click done

Select HB2ToneInter1 in field Solution
Select Sweep in  field Domain
Click on Output Variables button to open the output Variables window.

Click right on Results and 
create report – Data Table.1

2

3

Select Output Variable in Category, IP3 in Quantity 
None as function, Click Add Trace and Done 4



Create Results: Intermodulation Spectrum
Click right on Results and 
create report – Rectangular Plot
Select HB2ToneInter1 in field Solution
Select Spectral in  field Domain

1

Select Pin, uncheck All Values,
Select  -5dbm 2

Select Power, PO2, dBm
Click Add Trace, Click Done 3

1MHz

zoom



Digital Modulation

Open example QPSK.adsn



Digital Modulation: Modulation Source (1)

Click to Edit the Modulation 
Source window

Edit source Sinussoidal1
You can select from the type of the 
Modulation Source CDMA2000, GSM, 
GSM Edge, GMSK, …, User Defined.

Parameters Tab 
Bit Rate, Delay, I/Q Imbalance

Filter Tab
select the filter Butterworth, Gaussian, 

Root-Raised, Cosine, Raised 
Cosine

Channel Meas
specify channel bandwidth



Channel Meas Tab
set BW2=BW3=590KHz and
FS2=1.99KHz,FS3=3,24KHz

3

Parameter Tab 
set Type to PSK, Br=1.2288MHz, m=4, Dly=0, Iasc=Qasc=1

set Type to PSK

Digital Modulation: Modulation Source (1)
2

1

Filter Tab 
set Type Butterworth, LPFC=665KHz, LPFN=3

Click OK



Set F1 to 2GHz 
define a power sweep on Pavs from 0dbm to 23dbm by step of 1db
Set the number of Harmonic to 8,

Click right on analysis and select add Analysis setup.
Select type Analysis Type Modulation Envelope, Category 1-Tone
Click Next

Modulation

2

1

The Modulation Source is 
added to the Data Folder.

You can select Modulation Envelope from the Analysis Type field.
Category allows you to select 
1-Tone, 
2-Tone/3-Tone, Intermododulation Spectrum
2-Tone/3-Tone, Mixer Intermododulation Spectrum

Set Length of Analysis to 104.2us
(=1/(br*8)*1024, with 1024=nb of sample)
Set Time step to 0.1us (= 1/(br*8) 
this means we oversample the bit rate by 8)

3

Click Finish 4



Tab Eye Diagram select 
Modulation 
Response, 
Quantity= 
IchEye2<F1>.

Click Done

Tab Sweeps uncheck All 
for Pavs and select 0dBm.

Click right on Results and select Create
Select Report Type=Eye Diagram, 

Display Type=Rectangular Plot, 
Click OK.

Digital Modulation: Eye Diagram
1

2

3
Number of Cycle

Available plot for Modulation Envelope are:
Eye Diagram, Constellation, IQ Spectrum, ACPR

Create an other plot with same
setting execpt Pavs=23dBm.

4



Modulation

1

2

3

Click right on Results and select Create.
Select Report Type=Standard, Display Type=Rectangular Plot, Click OK. 
Tab Sweeps uncheck All for Pavs,  select 0dBm and 20dBm using the 

CTRL key.
Tab Y select Category=Modulation Responses, Quantity=IQ2<F1>, 
Function dB.
Click Done.

You can compare on the graph the spectrum regrowth
produced for Pin=0dBm and Pin=20dBm. 

1
2
3



Digital Modulation: Constellation Plot
1

2

3

Click right on Results and select Create
Select Report Type=Constellation, Display Type=Rectangular Plot, Click OK. 
Tab Sweeps uncheck All for Pavs and select 0dBm.
Tab Constellation select Modulation Response, Quantity= Constlltn2<F1>.
Click Done

1
2
3





There are 7 essential Steps to perform load-pull 
analysis and review response

1. Define nonlinear circuit
2. Specify nonlinear source
3. Specify load/source pull tuner port
4. Specify nonlinear analysis
5. Specify loadpull analysis details based on 

selected nonlinear analysis
6. Analyze
7. Plot contours

Viewed in previous slides





2. Add source1. Edit port to be 
driven by RF source by
Double clicking on
symbol in schematic or 
icon in project tree

1

1
2



1. Edit desired tuner port
2. Create new tuner 

Definition – settings 
shown in next slide

2. Specify Reference node 
(ground default)

3. Tuner automatically added to 
data definitions folder in 
project tree

1

2



Loadpull tuner definition specifies tuner type (ideal, double stub) and 
default complex impedance at all specified harmonic frequencies 
(50ohm default). To modify edit from port dialog or double click on 
tuner icon in project tree.
Note: multiple tuners may be definedmovie



1. Add analysis setup
3. Specify swept parameters such as 
operating Frequencies and swept parameters 
such as  Bias, tuning or power level  (using 
the Add… Button)

2. Select nonlinear analysis 
such as Harmonic Balance 
or HB Oscillation

1

2

3



1. Add analysis setup

2. Specify swept parameters such as 
operating Frequencies and swept parameters 
such as  Bias, tuning or power level  (using 
the Add… Button)

1

2



2. Select HB analysis to apply
(multiple analyses may be 
defined for  a given design)

3. Specify Harmonic 
frequency index, 
For example 1=fundamental
2=second harmonic (2*f)

1. Select loadpull tuners 
from pull down list (if 
multiple tuners are defined)

movie

1

2

3



Set tuner range
a. ZRho controls the 
magnitude of the reflection 
coefficient
b. ZAng controls the angle 
of the reflection coefficient

Hint: low impedance 
matching networks that 
are common to high power 
amplifiers are simulated 
more quickly by using a 
directed loadpull sweep of 
low impedances 

ZRho

ZAng



1. Right mouse click on the 
defined loadpull analysis 
setup in the Analysis folder 
of the project tree

movie

1 2

2. Right mouse click on the 
progress bar to bring up 
abort/details menu, select 
details to view HB 
convergence

Analysis status window 
(Details)



1. Right mouse click on the 
Results folder to create new 
report

1
2

2. Select report type as Load-pull 
(only available after successful 
load-pull simulation)

3

3. Select display type as smith 
chart (optional rectangular or 
polar plots also allowed)



movie



Power
Added
Efficiency

Transducer
Gain Multiple plots

Drain current
Output power



1. Right mouse click in the 
report field to bring up 
menu, select “Contour 
Values”

1
2

2. Set new min, max 
and step values





Multiple analyses 
(ex. HB, Transient, 
Phase noise)
from single
Circuit design

Analysis set-up allows user 
to define multiple sweep 
parameters and oscillation 
search range



The oscillator design aid sweeps a 
user specified frequency range and 
plots complex currents through 
device. Negative resistance 
corresponds to potential oscillation 
frequency.

Oscillation 
frequency



Harmonic Balance Oscillator analysis
provides nonlinear circuit performance

Spectral plots

Output power 
(shown for f1 and f2),
Output frequency (f1)

Steady state 
output voltage

Search range and harmonics

Additional sweeps



Phase noise: 
Fundamental tone

Phase noise: 
Harmonic tone (2F)

Noise Spectrum analysis
provides nonlinear circuit 
noise spectrum data such as 
phase noise and amplitude 
noise



Set optimization, tuning and statistical
Analysis parameters/ranges through 
component properties

Set optimization, tuning and statistical
Analysis parameters/ranges through 
component properties





Non steady state
Base voltage

Transient analysis allows the 
Circuit designer to investigate 
non steady state behavior

Oscillator output voltage 
at startup







Insert Planar EM Design
Click Right on Project and 
select Insert Planar EM Design

Select MS-FR4 (Er=4.4) 0.060inch, 0.5 oz copper



Add Definitions Parameters
Click Right on Planar EM Design 
and select Design Properties.

Add following Definition Parameters:
Wline=2mm, Lline=10mm, Xstub=5mm, Wstub=2mm,Lstub=20mm



Draw A Simple Open Stub
Select Add Line and 
Draw two lines as 
shown

Use Defintions Parameters 
Xstub, Wstub, Lstub to set 
stub properties

Use Definitions Parameters 
Wline, Lline to set line 
properties



Add Ports

Edge Port Definition 
allows to select Port 
options.

Use select Edge to 
select edge line Draw Port

The inserted 
Port are added to 
Excitations folder

Click on Select Edge icon and select the left edge of 
the horizontal line, then click on draw Port icon.

Click on Select Edge icon and select the right edge of 
the horizontal line, then click on draw Port icon.



Add setup

Meshing Parameters Tab
to set meshing options ;Fixed Mesh, Edge Mesh, Adaptative Mesh, Initial Mesh Frequency.
Mesh Refinemennt tab
More Meshing option

Click right on Analysis folder 
and select Add Solution Setup.

Select Fixed Mesh with 
frequency = 5GHz.



Edge Meshing
Using Edge Meshing
When you define a non-adaptive solution setup, you can instruct Ansoft 
Designer to add narrow rectangles along the edges of the model. These 
rectangles efficiently capture electromagnetic effects close to the model 
edges, resulting in faster solution times and/or higher accuracy. 
When Ansoft Designer refines the fixed mesh, it determines the length of 
the rectangles (the longer edges, which lie parallel to the model edge) by 
making them smaller than a fraction of the guided wavelength at the 
frequency you specified. You determine the width of the rectangles by 
either specifying the ratio of the rectangles’ length to the width, or the edge
mesh length ratio, or by specifying the absolute width of the rectangles, or
the absolute edge length. 
To use edge meshing:
1. In the setup dialog box, click the Meshing Parameters tab.
2. Select Fixed Mesh, and then specify a frequency at which to generate
the fixed mesh in the Frequency text box.
3. Select Use Edge Mesh.
4. Specify how the edge mesh is created by selecting one of the following:
• Edge mesh length ratio
• Absolute edge length
5. If you selected Edge mesh length ratio, type the ratio of the length to
the width of the rectangles. 
After refinement, the width of the rectangles will be nominally equal to ratio
x length. The ratio value should be between 0.02 and 0.2 to prevent
extremely narrow rectangles and extremely wide triangles.
6. If you selected Absolute edge length, type the absolute width of the 
rectangles, including the model units.



No edge mesh

Edge mesh length ratio=0.1

Edge mesh length ratio=0.04



Setting Lambda Refinement
Lambda refinement is the process of refining the initial mesh based on the 
material-dependent wavelength. It is recommended and selected by default.
To specify the size of wavelength by which Ansoft Designer will refine the 
mesh:
1. Under the Mesh Refinement tab in the solution setup dialog box, select 
Lambda Refinement.
2. Type a value in the Edge Length Factor text box. The ratio of the guided
wavelength and the length of the longest triangle edge will be greater than 
or equal to the Edge Length Factor. 
Refining for Quality
When Refine for Quality is selected in the setup dialog box, Ansoft 
Designer will produce a mesh with triangles that have approximately the 
same size angles. The mesh is refined until all triangle angles in the mesh
are at least the Minimum Angle value.
To refine for quality:
1. Under the Mesh Refinement tab in the solution setup dialog box, 
select Refine for Quality.
2. Type a value in the Minimum Angle text box in degrees. 
Refining for Uniformity
When Refine for Uniformity is selected in the setup dialog box, Ansoft 
Designer will produce a mesh with triangles that are approximately the same
size. The ratio of the maximum length of any triangle edge to the average 
length of the triangle edges in the mesh will not be greater than Max/Mean 
Edge Length Ratio value, resulting in greater uniformity of the mesh.
To refine for uniformity:
1. Under the Mesh Refinement tab in the solution setup dialog box, select
Refine for Uniformity.
2. Type a value in the Max/Mean Edge Length Ratio text box.



Fixed Mesh Frequency= 5GHz
Edge Length factor = 12

Fixed Mesh Frequency= 5GHz
Edge Length factor = 16

Fixed Mesh Frequency= 7.5GHz
Edge Length factor = 12

Lambda Refinement

Fixed Mesh Frequency= 5GHz
No

Fixed Mesh Frequency= 5GHz
Minimum Angle =15deg

Fixed Mesh Frequency= 5GHz
Refine for Quality Minimum Angle =15deg
No

Fixed Mesh Frequency= 5GHz
Refine for Quality Minimum Angle =15deg
Max/Min Edge Length Ratio= 1

Refine for Uniformity

Refine for Quality



You can select multiple type sweep or single value, 
Discrete sweep or Interpolating Fast Sweep.

Click Right on the Setup just created 
and select Add Frequency Sweep..

Select Interpolating Fast
Remove the existing sweep.
Select Linear Step and enter 
Start 0.1GHz  Stop 5GHz Step 0.01GHz  

click Add.
Click on View Sweep Point List to see 

all frequency points.
Click OK



View Mesh

Before starting an analysis it’s 
recommended to look at the mesh 
to check if mesh setting are correct.

Click right on Setup folder and select
Mesh overlay to see 2D mesh or 3D
Mesh overlay to see the mesh by 
the way of 3D viewer.



Run Analysis
Click on icon start analysis

Click on icon view profile
to open this window



Create results: DB S11&S21 





You can draw arc, circle, line, polygon, 
Rectangle and add text.

Click the cross to close the 
Symbol editor widow

Save the symbol



Copy and Paste the Circuit Design

Click right on 
OpenStub and 
select Copy 1

Click right on 
LPF and select 
Paste

2

You can choice to use 
the same stackup as 
Parent circuit or to insert 
The sub-circuit as black 

box

3

Incorporate selected the Merge 
layers window allows to merge 
sub-circuit and parent circuit 
layers 4

Symbol of the pasted sub-circuit 
appears in the schematic 5



You can change the values 
of the sub-circuit parameters 

Sub-circuit folder appears 
in the circuit Design tree 



Ansoft Designer parse the Netlist 
and identify a Field Solver EM  
An EM simulation is automatically 
running













� Creating an Planar EM circuit will open layout.
� Click on ‘None’ in ‘Choose Layout Stationery’
� The grid and snaps for layout need to be configured.

� Layout -> Grid & Snap
� Set:

Major = 1
Minor = 0.1

Grid = 0.1mm
Graphical = 0.5mm

� OK



� Open the Stackup Editor in one of three ways:
� Layout -> Layers. Select Stackup tab.
� Click            icon.  Select Stackup tab.
� Click            icon.

� Insert an infinite ground layer
� Add Layer -> Name = “top” -> Type = “signal”

� Insert a dielectric layer
� Add Layer -> Name = “d1” -> Type = “dielectric”

� Insert a trace layer
� Add Layer -> Name = “bottom” -> Type = “signal”

� Change the “d1” thickness to 4 mm
� Layers can be moved by dragging and dropping the entire row..
� Material attributes can be defined by selecting the material button



� Change the active layer to “bottom”
� Select the layer pull-down menu and highlight “bottom”

� Begin drawing a rectangle object in one of two ways:
� Draw -> Primitive -> Rectangle
� Select the        icon.

� Enter the lower left-hand coordinates for the rectangle.
� In the Status Bar, enter X=0.0, Y=0.0.  Use the TAB key to move between 

entries and press ENTER when finished.

� Finish drawing the rectangle
� In the Status Bar enter Delta X = 40, Delta Y = 46.8.
� OR, drag the upper righthand corner until Delta X:40, Delta Y:46.8

� Fit the drawing by pressing “CTRL-D”, or View -> Fit Drawing



� We will now define a shortcut to the PIFA in order to reduce the physical
dimension to a quarter of the resonant wavelength.
� Select the        icon
� Enter the lower left-hand coordinates for the line.

� In the Status Bar, enter X=5, Y=46.8
� deltaX = 30 , deltaY = 0

� Use the TAB key to move between entries and press ENTER when finished.
� Verify the following properties 



� Select the line and Copy it (CTRL+C command)

� In the layer, choose Top

� Paste the line (CTRL-V)

� Select the 2 lines by maintaining the CTRL button when you select them. 

� In the menu on the left, click on Cross-Layer and Add Cross-Layer Plate



� Change the active layer to “Top”
� Select the layer pull-down menu and highlight “Top”
� Double Click on the line and adjust the properties 



� Begin drawing a rectangle object in one of two ways:
� Draw -> Primitive -> Rectangle
� Select the        icon.

� Enter the lower left-hand coordinates for the rectangle.
� In the Status Bar, enter X = 5, Y = 46.8.  Use the TAB key to move 

between entries and press ENTER when finished.

� Finish drawing the rectangle
� In the Status Bar enter Delta X = 30, Delta Y = -36.8.
� OR, drag the upper righthand corner until Delta X : 30, Delta Y : -36.8

� Fit the drawing by pressing “CTRL-D”, or View -> Fit Drawing



� Insert a hole
� Double Click on the hole and change the properties

� Enter the lower left-hand coordinates for the rectangle.
� In the Status Bar, enter X = 20, Y = 41.8.  
� Use the TAB key to move between entries and press ENTER when finished.

� Click on via1 and choose Properties



� Open a 3D view
� Select Planar EM -> 3D Viewer   OR
� Right-click on PlanarEM1 in the Project Manager and select “3D Viewer”

� Explore 3D view functionality 
� Right-click in the 3D view window
� Many options are available here….

� Change the 3D lighting
� View -> modify attributes -> lighting

� Change the background color
� View -> modify attributes -> background color



� Right click on the Analysis entry in the project tree and select 
add solution setup

� Use a fixed mesh frequency of 2GHz.  You can also change the 
mesh display color.



� Modify Mesh refinement

� Visualize the mesh



� Visualize 3D mesh



� Add a sweep to the analysis in one of two ways
� Planar EM -> Add Frequency Sweep   OR
� Right-click on the “Sweep 1” branch in the 

Project Manager and select “Add Frequency Sweep” 

� Fill in the Sweep dialogue as seen below.  Enter “Update Frequencies” 
to add the points to the sweep table. 
� Interpolating Fast Sweep

� Fstart = 1.5GHz

� Fstop = 2GHz
� Number of points = 51



� Right click on Sweep1 and select Start Analysis.  

� Click on 3D Editor.  



� By Right Clicking on the progress bar during 
simulation, the process can be aborted, paused, or 
have the priority level changed.

� The simulation engines have been turned into 
COM/DCOM objects.  This allows a simulation to 
be run on a remote machine, given permissions 
and an IP address.



� View tabular S-parameters
� Right-click on “Sweep1” 

� Select Results -> Matrix Data

� Plot Return Loss
� Right-click on “Sweep1”

� Select Results -> Plot Templates -> Return Loss




