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Redes Coloridas

1. Explorar as simetrias com o objetivo de reduzir o tamanho da rede.

Falha: o grafo é reduzido mas a informacao para para as inscricoes a
complexidade da representacao nao se altera significativamente

2. Ter uma representacao abstrata para a rede classica.
Falha: verdade em principio, mas ter que reduzir a representacao para
rede classica cada vez que deseja fazer analise de propriedades

pode nao ser exatamente uma vantagem.

3. Aumentar o poder de expressao da representacao baseada em
redes.

Falha: simplesmente nao é verdade.
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Historico das redes
CPN

As redes coloridas surgiram nos anos 80 conjugando a representacao grafica
das redes de Petri com o Standard ML, que representa tipos e cores.

No final dos anos 80 e principio dos anos 90 surgiu o ambiente Dsign CPN
proposto pelo mesmo grupo de Ahus, Dinamarca (Kurt Jensen).

A idéia é simplesmente ter um formalismo mais abstrato
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Definicao informal das
CPNs

Kurt Jensen

Coloured Petri Nets (CP-nets or CPNs) is a graphical
language for constructing models of concurrent systems
and analyzing their properties. CP-nets is a discrete-event
modeling language combining Petri Nets and the
functional programming language CPN ML which is based
on Standard ML.
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Aplicacoes

AplicacOes Tipicas Novas Aplica¢coes

Protocolo de Comunicagao Sistemas de workflow

Redes de Dados Sitemas de manufatura

Algoritmos Distribuidos Sistemas multi-agente

Sistemas Embarcados Processos de negocio

Analise de Requisitos
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Uso pratico das redes
CPN

Como no caso das redes classicas o uso pratico das redes CPN esta
associado a Simulacao do modelo, e portanto ao estudo de cenarios
especificos e ao processo de evolucao das marcas.

Temos portanto o mesmo problema de desenvolver métodos
alternativos de analise baseados nas propriedades da rede e fugir do
problema da atingibilidade.

Novos métodos Verificacao e Model checking
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Caracteristicas das redes
CPN

e As marcas sao divididas em conjuntos e separadas por tipo

e A area de declaracao do sistema contém a identidade de
cada variavel assim como em declaragoes em ML

e Os arcos possuem inscrigoes e filtros que selecionam o tipo
de marca que pode fluir por este arco.

e O comportamento dinamico € dado pelo conjunto : grafo,
inscricoes e declaracao.
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Contexto formal

Redes de Petri

Convencionais Linguagens Formais

Definicao de Tipos
Manipulacao
Sintaxe

Sincronizacao de
processos
concorrentes

Kurt Jensen, An Introduction to the Practical Use of Coloured Petri
Nets, Lect. Notes in Comp. Science 1492, 1998.
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Processos
especiais
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acoplamento com
recursos

O sistema S2PR pode ainda
ser acoplado de modo que
OS processos sequenciais
interferem um no outro
podendo causar atrasos e ate
deadlocks devido a falta de
recursos no momento
devido.

- 3 rd ) . .
Li, Z.W. and Zhou, M.C., “Deadlock resolution in Fig. 1(a) S'PR &3 -order system ;

automated manufacturing systems: A novel Petri net
approach,” Springer, London, 2009
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Introducgao informal: O problema da alocacao
de recursos

Na indUstria automotiva moderna é
comum se ter varios processos ou linhas
de montagem e nestes um ou mais tipos
de automoével sendo montados em
pipeline. Isso traz um problema, que é
ter o tipo certo de insumo ou recurso no
tempo correto, para a matriz correta.

Um problema similar e igualmente
importante é ter processos homogéneos

mas compartilhando o mesmo centro de
recursos.

Escola Politécnica da USP 2 S 2 PMR5237

Tuesday, April 16, 13



Estruturacao do
problema

Three g-processes

p-processes
take Two p-processes
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Modelagem
classica

Seja o seguinte sistema de alocacao de recursos, caracterizado
por dois processos concorrentes,

P process

\g process

\
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Modelagem
classica

Seja o seguinte sistema de alocacao de recursos, caracterizado
por dois processos concorrentes,

P process

\g process

\
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Modelagem
classica

Seja o seguinte sistema de alocacao de recursos, caracterizado
por dois processos concorrentes,

P process

\g process

\
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P process
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P process
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Para sintetizar uma rede uma rede colorida devemos
explorar a simetria entre os processos, isto €,
produzir um unico processo que representa tanto o
processo p como o processo g. Neste caso as

marcas passam a ser distinguiveis para representar os
dois processos.
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color U=with p | q;

color I = int;

color P = product U*I;

color E=with e;

varx : U;

var1: I; E

2 2e case x of

p=2'¢
q=1¢
=p then 1'e ’
else empty

3'(q.9)
P P
(x,i) (x,i) (x,1) (X,1)

A 3'(q,0) Q[2'(p,0)
[x=q]

If x=q
then 1°(q, 1+1)
else empty
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case x of
p=> 2 e
lg=>1%e
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Binding:

_ ‘ New Marking
<X=p, i=0>

case X of case x of

p=> 2'e p=>2e
lg=>1%e

@ 3'e
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Strong type

Binding:
<X=(, |=2>

case X of
p=>2e
lg=>1¢e

e

- @_}1 e
@3‘9
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Strong type

Binding:
<X=(, |=2>

case X of
p=>2e
lg=>1¢e

e

- CS\}/H e
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Strong type

Binding:
<X=(, |=2>

case x of
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Outro exemplo

case X of
p=>2e
| q =1e

@3‘9
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Uma vez respeitado o tipo qualquer possibilidade pode ocorrer.

Binding: ., (BT (P2+1'(P.4+1°(@3)  Binding:
<X=p, i=2> € <xX=(q, i=3>

case X of case x of
p=>2e p=>2e

o1 ' lg=>1"e "1
lg=>1e 1(@3)
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Concorréencia

Binding:
<X=P, I=2>

Binding: 1°(p,2)+1 (p,4)+1°(q,3)
<x=q, i=3> i ®

i) [ 1 (P2+1 @3

case X of
F) = 22‘63

Iq=>1‘e

iy [ T P2+ @3)

f)
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case X of
p=>2e
lg=>1e
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Gerenciando
conflito

R TTIE—————

A situacao de conflito é similar, s6 que agora levando em conta os tipos

Binding: b (3 (3) 1 (p.2)+1°(p,4)+1°(@.3)  Binding: o (5 (3) 1" (p.2)+1 (p.4)+1°(q.3)
<X=p, I=2> ” <X=P, I=4> 1
1(p.4)

(X,i) 1(p,2)

p=>2e p=>2e
) | q=> 1e

case x of case x of
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CPN Elements

Declarations:

o Types, functions, operations and variables.

Each place has the following inscriptions:

e Name (for 1dentification).

o Colour set (specifying the type of tokens which
may reside on the place).

o Initial marking (multi-set of token colours).
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Each transition has the following inscriptions:

 Name (for 1dentification).

* Guard (boolean expression containing some of
the variables).

Each arc has the following inscriptions:

» Arc expression (containing some of the variables).
When the arc expression 1s evaluated 1t yields a
multi-set of token colours.
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Enabling Condition

A binding assigns a colour (1.e., a value) to each
variable of a transition.

A binding element 1s a pair (t,b) where t1s a
transition while b 1s a binding for the variables
of t. Example: (T2,<x=p, 1=2>).
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A binding element 1s enabled if and only if:

e There are enough tokens (of the correct colours on
each mput-place).

e The guard evaluates to true.

When a binding element 1s enabled 1t may occur:

e A multi-set of tokens 1s removed from each
mput-place.

e A multi-set of tokens 1s added to each
output-place.

A binding element may occur concurrently to other
binding elements — iff there are so many tokens
that each binding element can get its "own share".

PMR5237
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CPN Tools Homepage

CPN Tools P '
"“\4 | » | |@® http://cpntools.org/start v |c| (28~ Google Q) (A&
Most Visited v ’ Getting Started |5 Latest Headlines v U Apple D Yahoo! -(“ Google Maps D YouTube \Y/ Wikipedia n Bookmarks v

(cpntools.org) e oo mmm s o wems -

CPN Tools

* Documentation

* FAQ Home Download Getting Started Documentation Support Contact

* Getting Started

* Licensing
Contact
Download
Publications
Support

| Search I X

¥ HierarchicaProtocol con
Step: 0

CPN Tools is a tool for editing, simulating, and Lo
analyzing Colored Petri nets. oy

¥Dedarations
: . * coliat DATA
The tool features incremental syntax checking » colset INTXDATA s
i i i Svwnknin vy
and code generation, which take place while a Z:.:..".:L' T

net is being constructed. A fast simulator » colset Tano manT

» colset Tanl

efficiently handles untimed and timed nets. Full s — PR
and partial state spaces can be generated and A i

analyzed, and a standard state space report
contains information, such as boundedness

properties and liveness properties.

New Features in Version 3.0

e Support for 64-bit Windows
e Support for running under virtualization

software such as VMWare and Parallels (use

safe mode if you get errors under Parallels)
® New simulator which is up to twice as fast Michael's Blog on CPN Tools

for both automatic simulation and state

space generation e In All Fairness... (2011/04/20 16:58)
® Support for prioritized transitions e Graphical User Interface (2011/03/24
e Support for real time 14:31)
e The Access/CPN Source Released

The latest version is version 3.0.4 from April (2011/02/08 10:51)
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Download << CPN Tools Homepage
J @ Download << CPN Tools Home... l ¥/) Curso: Modelagem e Design de ... u + [ b4

(‘x( ﬁ [@ http: //cpntools.org/download 2 v C'} |h;'v Google Q:;. ?

Most Visited » P Getting Started Latest Headlines v ["] Apple || Yahoo! +*J Google Maps [ | YouTube \X/ Wikipedia » [EJ Bookmarks ~

GME&API’S v | cpn tools download v| vo v vEELogin » 9y

CPN Tools
* Documentation
* FAQ Home Download = Getting Started = Documentation @~ Support = Contact

* Getting Started
* Licensing

sl Download

Publications
Support

[Google™ custom | Search | %

CPN Tools is free software; see here for licensing information.

It should be straight-forward to install CPN Tools; otherwise, read the help pages.

—Windows

Download: [3.04 3

Mailing list:

¥ Announce (highly recommended, very low traffic)

0 Support (recommended, support questions go here, medium traffic and digest
option available)

E-mail address:

Linux/Mac OS X

We recommend you to download the latest Windows version of CPN Tools and run it
using a virtual machine. Linux users can also download an older version of CPN Tools,
but these versions are not maintained any longer.

Download Linux Version 2.3.5

Download Linux Version 2.2.0
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary :
Create ifx=q
Hierarchy then 17 (q,i+1)
Monitoring alse ampty
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave
» Simulation Report e ) then 1° (p,i+1)
» Simulator Process “e(R _ else empty
¥ ResourceAllocation.cpn
Step: 0
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
»colset P
»colset E
»var x
= vari
» Monitors case X o

Top p=>2e
|lg=>1"¢e

Resource Allocation Example
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#* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary
Create
Hierarchy
Maonitoring
Net
Simulation
State space
Style
View
» Help
¥ Options
Commands between autosave
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 1
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
» colset P
»colset E
»varx
e vari
» Monitors

Top

Escola Politécnica da USP
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if x=q
then 17 (q,i+1)
else empty

if %=p ‘
then 17 (p,i+1)
else empty

Resource Allocation Example

PMR5237




¥Tool box
Auxiliary :
Create ifx=q
Hierarchy g;f: elmfn?:§'|+1)
Monitoring
Net
Simulation
State space
Style
View
» Help
¥ Options
Commands between autosave :
» Simulation Report i then 1° (p,i+1)
» Simulataor Process ' . _ slse empty
¥ ResourceAllocation.cpn
Step: 2
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
» colset P
»colset E
»var x
e vari
» Monitors

Top

Resource Allocation Example
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¥Tool box
Auxiliary

Create ifhx=q o
Hierarchy then 17 (q,i+1)

Monitoring else empty

Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave :
» Simulation Report ey ) then 1° (p,i+1)
» Simulator Process ! : _ else empty
¥ ResourceAllocation.cpn
Step: 3
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
» colset P
»colset E
= var x
e vari
» Monitors case X 0

To p=>2'e
Top 19=21"6

Resource Allocation Example
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®* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary .
Create fx=q
Hierarchy tet?se: elmg%(,""l)
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave
» Simulation Report e ) then 1° (p,i+1)
» Simulator Process ’ X else empt;l
¥ ResourceAllocation.cpn
Step: 4
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
»colset P
»colset E
»var X
e vari
» Monitors

Top

Resource Allocation Example
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary =
Create ifx=q
Hierarchy gl‘:: elmg?:;l”l)
Maonitoring
Net
Simulation
State space
Style
View
»Help
¥ Options & <.
Commands between autosave : : T
» Simulation Report [ then 1° (p,i+1)
» Simulator Process : ‘ _ slse empty
¥ ResourceAllocation.cpn
Step: S
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
»colset E
»varx
»yar i
» Monitors
Top

Resource Allocation Example
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®* CPN Tools (Version 3.0.4,

¥Tool box
Auxiliary ‘
Create |fhx=q o
Hierarchy then 17 (q,i+1)
itari else empty
Monitoring
Net )

Simulation 1.1 (q,0)|
State space
Style i
View
» Help
¥ Options & <.
Commands between autosave : +1 (3,0) ™
» Simulation Report [ then 1° (p,i+1)
» Simulator Process : _ else empty
¥ ResourceAllocation.cpn
Step: 5
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
»colset E
»var x
»yari
» Monitors
Top

Resource Allocation Example
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¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space
Style
View

> Help

¥ Options

Commands between autosave

» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 6
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
»colset P
»colset E
= var X
= vari
» Monitors

Top
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if x=q
then 17 (q,i+1)
else empty

~

s 17(q,0)++

(ki) TX=P
Z then 17 (p,i+1)
else empty

Resource Allocation Example
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Modelagem classica para o
problema dos filosofos

O exemplo dos filésofos
fi
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®+* CPN Tools (Version 3.0.4, April 2011) EJ@I@
¥Tool box

Auxiliary

Create

Hierarchy

Monitoring

Net

Simulation

State space PH.all()

sle @ ) 17 ph(1)++
1 ph(2)++
» Help 1 ph(3)++
¥ Options 1" ph(4)++
Commands between autosave : 50 1" ph(S)
» Simulation Report
» Simulator Process Take )
¥ DiningPhilosophers.cpn Chopsticks Chopsticks(p)
Step: 4
Time: 0
» Options
» History . Unused
v[:eclfratlons Chopsticks
val n
» colset PH
» colset CS
»varp
»fun Chopsticks
» Monitors

Page

Put Down Chopsticks(p)
Chopsticks

))

Prof. José Reinaldo Si Iva
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elagem com
CPNs

* Diferente abordagem, mais abstracao

* Classificar elementos do projeto segundo tipos bem definidos
* A observancia dos bindings (strong type) é fundamental

* Explorando as simetrias (pode ndao aparecer desta forma)

* Maior facilidade para reutilizacao
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Alguns problemas...

 Diferente abordagem, mais abstracao
Depende do background do designer, mas a questao base € escolher entre fazer a

o modelagem ja direto em rede colorida ou comegarJ)ela. rede classica
* Classificar elementos do projeto segundo tipos bem definidos

Consequencia do item anterior e novamente € uma questao de diciplina.

* A observancia dos bindings (strong type) é fundamental ,
Comum nos processos estruturados, choca-se com a excessiva carga funcional que os

engenheiros costumar dar aos projetos.
* Explorando as simetrias (pode nao aparecer desta forma)

De fato deve ser feito também no caso classico, o tipo de simetria a ser explorada é que é

; B . = dif te.
* Maior facilidade para reutilizacdo ilsPoie:

Sera amplicado no tanto no caso classico com no das redes de alto nivel com a introducao da
hierarquia, mas continua mais forte no caso das redes de alto nivel, embora a escolha da
componente reutilizavel seja mais complexa.
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Sobre o formalismo

Portanto, a Unica maneira de minorar os problema é voltar ao
formalismo para explorar melhor a analise de propriedades,
especialmente os invariantes.

O formalismo também abre a possibilidade de se ter outras interfaces
mais amigaveis e adaptadas aos ambientes de trabalho, tendo o CPN
Tools (por exemplo) por tras. Nesse caso a aderéncia ao formalismo
das CPNs é importante e fundamental para a credibilidade da
ferramenta.
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CPN : definicao formal

Definition: A Coloured Petr1 Net 1s a tuple CPN = (2, P, T, A, N,
C, G, E,]I) satisfying the following requirements:
(1) X 1s a finite set of non-empty types, called colour sets.
(1) P 1s a finite set of places.
(1) T 1s a finite set of transitions.
(1v) A 1s a finite set of ares such that:
* PAT=PnA=TnA=0.
(v) N 1s a node function. It 1s defined from A mto PxT u T xP.

(vi) C 1s a colour function. It 1s defined from P into X.
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G 1s a guard function. It 1s defined from T into expressions
such that:

e VteT: [Type(G(t)) = Bool A Type(Var(G(t))) c X].

E 1s an arc expression function. It 1s defined from A into
expressions such that:

* VacA: [Type(E(a)) = C(p(a)wms » Type(Var(E(a))) c 2]

where p(a) 1s the place of N(a).

I 1s an initialization function. It 1s defined from P into
closed expressions such that:

* VpeP: [TypeI(p)) = C(p)wms].
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