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PROCEDIMENTOS BÁSICOS PARA CRIAÇÃO DE UMA APLICAÇÃO 
PARA O PANELVIEW PLUS COMPACT 

 

1) Criando uma aplicação com o FTview ME 

a) Abra o FactoryTalk View Studio  
(Start->Rockwell Software->FactoryTalk View->FactoryTalk View Studio ) 

b) Selecione o Tipo de Aplicação como Machine Edition e pressione Continue 
 

 

c) Na aba New de um nome a sua aplicação em Application name selecione o campo Compact 
Machine Edition application e pressione Create 
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d) O programa deverá criar uma estrutura básica da sua aplicação conforme mostrado a 
seguir 

 

Sua aplicação está criada. Os próximos itens descreverão os passos necessários para o 
desenvolvimento de sua Aplicação. 

2) Configurando a Comunicação da IHM com o CLP. 
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a) Abra o FactoryTalk View Studio  

(Start->Rockwell Software->FactoryTalk View->FactoryTalk View Studio ); 

b) Selecione o Tipo de Aplicação como Machine Edition e pressione Continue; 

c) Na aba Existing selecione sua aplicação e pressione Open; 

d) Abra o Communication Setup de sua aplicação;  

 

 

e) O Wizard de configuração deve aparecer;  

f) Selecione Create a new configuration e pressione Finish; 

g) Uma nova tela de configuração deverá aparecer. Nessa tela você deverá criar um 
“caminho” para seu CLP. Para isso siga os seguintes passos:  

i) Pressione Add no canto superior esquerdo (Device Shortcuts) da tela e dê um nome ao 
seu atalho (definiu-se como padrão o nome PEA2509); 

ii) Selecione o atalho recém-criado e na aba Design (Local) navegue na árvore até achar 
a CPU do CLP de sua bancada; 

iii) Sua tela deverá estar como mostrado na figura abaixo (verificar o IP do CLP de sua 
bancada); 

 

 

 

iv) Caso sua tela esteja como a mostrada acima pressione Apply. Em seguida confirme as 
mudanças pressionando Yes na janela que aparecerá; 

v) Para finalizar pressione Copy from Design to runtime (canto superior direito), a fim de 
replicar a configuração feita para a área de configuração da IHM; 

vi) Confirme tudo pressionando OK no canto inferior direito.  
 

Neste ponto, a aplicação já deverá estar “enxergando” o CLP e sua base de dados. 

 

3) Configurando dados de execução da sua aplicação. 
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Para a correta operação de seu sistema é necessário verificar se algumas configurações 
condizem com o PanelView que estamos trabalhando. Para tanto siga os seguintes passos: 

a) Abra o Project Settings (System -> Project Settings) 

• Verifique se o Project window size está configurado como PVPlus Compact 1000 
(640x480); 

b) Abra o Startup (System -> Startup); 

• Verifique se os campos Alarms e Informations messages estão sem a seleção. 
• Verifique se o campo Initial graphic está habilitado e se o nome da tela que é 

mostrado condiz com a tela que você deseja como tela de abertura. 

c) Abra o Runtime Security (System -> Runtime Security); 

É nessa tela de configuração que podemos adicionar Usuários e definir seus privilégios na 
aplicação. 

A ideia usada para o PanelView da Rockwell é de atribuir códigos de segurança para 
cada usuário de modo que tais códigos sejam usados na configuração e animação de 
objetos de maneira que se evite que usuários não autorizados realizem operações 
ilegítimas.  

Ou seja, para a configuração abaixo temos dois Usuários o usuário Default (Padrão do 
sistema, é esse usuário que está ativo quando nenhum usuário está “logado”) e o Admin 
(Administrador do sistema). Para o Usuário Default só está atribuído o código de segurança 
D, ou seja, ele só terá acesso a telas e objetos que não apresentarem restrição de acesso 
ou apresentarem restrição D. Para o Usuário Admin estão atribuídos todos os códigos de 
segurança, ou seja, ele terá acesso a todo o sistema. 

 

 

 

Sua aplicação já está pré-configurada para darmos início ao desenvolvimento das telas 
propriamente. 
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4) Criando uma Tela no FactoryTalk View Studio – Machine Edition 

a)  Abra o FactoryTalk View Studio  
(Start->Rockwell Software->FactoryTalk View->FactoryTalk View Studio ); 

b) Selecione o Tipo de Aplicação como Machine Edition e pressione Continue; 

c) Na aba Existing selecione sua aplicação e pressione Open; 

d) Pressione com o botão direito do mouse o item Displays em seguida selecione NEW; 
 

 

 

e) Pressione com o botão direito do mouse qualquer lugar da tela e em seguida selecione 
Display Setting..... Deve-se obter a seguinte tela: 

 

 

f) Altere a cor de fundo (Background Color) para a cor cinza (RGB: 192;192;192) e 
pressione OK para confirma e fechar a aba de configuração 

g) Selecione File-> Save (ou pelo ícone ) e dê um nome a sua tela. Exemplo (Tela 1) 
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h) Verifique que a tela foi adicionada a árvore do seu projeto. Para editá-la basta 
pressionar com o botão direito do mouse e em seguida em Open (ou apenas dê um duplo-
clique sobre a mesma). 
 

 

5) Criando e Configurando Objetos no FactoryTalk View Studio – Machine Edition  

Para o desenvolvimento das telas é necessário explorar as ferramentas de desenho e entender 
as funcionalidades de alguns objetos. A seguir são apresentadas algumas das barras de 
ferramentas disponíveis no FactoryTalk View.  

1. Barra de ferramenta Gráfica (Graphics) 

Esta barra de ferramenta apresenta as funcionalidades auxiliares no desenvolvimento da 
tela. Tais funcionalidades são apresentadas a seguir. 

 

 

 

• Test Display ( ) e Edit Display ( ): 
Permite a simulação da tela que está sendo desenvolvida. Pressione  para iniciar o teste 
e  para voltar ao modo de edição. 

• Recortar ( ), Copiar ( ), Colar ( ) e Duplicar ( ) 

• Espaçamento Uniforme Vertical ( ) e Horizontal ( ).  
(Necessário selecionar ao menos 3 objetos) 

• Espelhamento Vertical ( ) e Horizontal ( ) 

• Agrupar ( ) e Desagrupar ( ) 

• Zoom ( ). 

• Desfazer ( ) e refazer ( ) última alteração. 

• Exibir/Esconder Property Panel ( ). 
Property Panel – Janela que apresenta as propriedade do objeto selecionado. 
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• Exibir/Esconder Object Explorer ( ). 

Object Explorer – Janela que apresenta a lista de objetos presentes na tela e permite 
explorar os grupos de objetos criados. 

2. Barra de ferramenta de Alinhamento (Alignment) 

Esta barra de ferramenta apresenta as funcionalidades auxiliares de alinhamento de 
objetos. 

 

• Alinhar à esquerda ( ), à direita ( ),à cima ( ) e à baixo ( ). 

• Alinhar ao centro deslocando os objetos horizontalmente ( ) e verticalmente ( ). 

• Centralizar ( ). 

• Alinhar a grade ( ). 

Permite que se posicionem os objetos segundo uma grade (grid) para melhor distribuir os 
mesmos.  

3. Barra de ferramenta de Objetos (Objects) 
 

Esta barra de ferramentas apresenta os principais objetos presentes no FactoryTalk View 
Machine Edition. 

 

 

• Ferramenta de Seleção ( ). 

• Rotacionar o objeto selecionado ( ). 

• Adicionar Texto ( ) e Imagem ( ). 

• Adicionar formas simples e desenhos: Painel ( ), Arco ( ), Elipse ( ), Traçado Livre (

), Reta ( ), Polígono ( ), Poli-linhas ( ), Retângulo ( ), Retângulo de Cantos 

Arredondados ( ), Cunha ( ). 

• Adicionar Botões: Ação Instantânea ( ), Ação Retentiva ( ), Ação Retentiva com reset 

externo ( ), Multiestado ( ), Intertravado ( ), Incremental ( ). 
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• Objetos referentes a variáveis numéricas e variáveis de texto: Mostrador Numérico ( ) e 

de Texto ( ); Entrada Numérica ( ) e de texto ( ); Entrada/Mostrador Numérico (
). 

• Botões de Navegação: Ir para ( ), Voltar ( ), Fechar ( ) e Lista de Telas para 

Navegação ( ). 

• Indicador Multiestado ( ). 

É possível navegar entre as opções de objetos também pelo menu Objects. Caso não visualize 
as barras de ferramenta a cima citadas verifique se em View->Toolbars as respectivas barras de 
ferramentas estão habilitadas. 

Localizados os objetos e ferramentas, é necessário, agora, entender como devem ser 
configurados os objetos para que representem corretamente o estado atual da planta e permitam 
a intervenção apropriada do operador na mesma. A seguir são descritos alguns objetos, suas 
configurações e comportamentos. 

4. Objetos do FTView ME 

Em geral, para desenhar um objeto na tela basta selecionar o tipo de objeto desejado na 
barra de ferramenta e em seguida definir o inicio do mesmo com um clique na tela, mantendo o 
botão do mouse pressionado arraste o mesmo até obter o tamanho desejado do botão. Note que 
um contorno se forma durante essa operação dando uma prévia do tamanho do seu objeto em 
tela. Soltando o botão do mouse o objeto é criado com suas configurações padrão. 

A janela de propriedade da maioria dos objetos é semelhante, sendo sempre subdividida em 
abas sendo: Uma aba General que apresenta detalhes de aparência e funcionamento do objeto, 
uma aba Common que permite definir o tamanho e a posição do objeto, uma aba Connections em 
que são definidos os links de comunicação para o objeto em questão, sendo essa última apenas 
presente para objetos com links externos. Dependendo do objeto há outras abas específicas que 
permitem definir algumas características próprias do mesmo. 

A seguir descreveremos alguns objetos mais comumente utilizados.  

1. Botões: 

A configuração dos botões se dá na 
janela de propriedade dos mesmos. Para 
acessar tal janela basta pressionar duas 
vezes o objeto ou clicar com o botão 
direito e em seguida Properties. 

Há, nessa janela, 4 ou 5 abas 
dependendo do tipo do botão. A seguir 
são mostradas as configurações comuns 
para os botões:  
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Na aba General são apresentadas características de aparência do botão como o estilo da borda, 
largura da mesma. Pode-se configurar se o fundo será solido ou transparente além do formato do 
botão. Para cada tipo de botão existem configurações específicas presentes nessa aba. 

 

Na aba States é possível configurar 
aparências específicas para cada valor 
(Value) da variável de retorno 
configurada no Indicator da aba 
Connections. A menos do botão 
multiestado, todos os demais apresentam 
dois estados válidos e um estado Error. 
Para cada estado é possível definir um 
texto a ser apresentado (Caption), cores 
do texto (Caption color) e do Botão 
(Back Color) e os detalhes de fonte. Por 
exemplo, é possível definir um único 
botão para ligar e desligar um 
determinado equipamento. Se definirmos 
para o estado 0 (State 0) o texto 
apresentado como Ligar, a cor de fundo 
como verde com letras brancas, e para o 
estado 1 (State 1) o texto como Desligar 
a cor de fundo como vermelha também 
com letras brancas, e utilizarmos o 
estado (Ligado/Desligado) do 
equipamento como o Indicator, temos 
que para o equipamento ligado o botão 
aparece como um botão de desligar e 

para o equipamento desligado o mesmo aparece como um botão de ligar.  

A aba Common apresenta dados de 
dimensão e posicionamento e permite 
que se altere o mesmo de maneira a se 
obter valores mais precisos. É possível, 
também, renomear o objeto para 
facilitar a organização de projetos com 
grande quantidade de objetos, um 
nome que caracterize bem o objeto 
facilita sua localização no object 

explorer e permite uma rápida edição 
do mesmo. 
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A aba Connections é onde se define 
as ligações com os tags do CLP. 
Para cada tipo de botão existem 
diferentes conexões. No exemplo ao 
lado há somente as ligações de 
valor (Value) e de indicação 
(Indicator). 

 

Abaixo veremos as características específicas dos principais tipos de botões utilizados. 

1. Ação Instantânea ( ) – Momentary Push Button  

O botão de ação instantânea se comporta como uma botoeira não retentiva.  

Na aba General das Propriedades desse botão temos o Button Settings, em que é possível 
escolher seu comportamento (Button Action). As configurações existentes são Normally open 
(Normal Aberto), Normally closed (Normal fechada) e Value (Valor). A opção Value permite 
definir o valor que será escrito na variável de saída quando o botão está ou não pressionado. 
Para tanto, basta definir o campo Value (Aba States) do Estado 0 para o botão não 
pressionado e Estado 1 para o botão pressionado. O tempo mínimo de atuação do botão é 
definido pelo Hold time, esse valor é importante para permitir que o “pulso” gerado pelo botão 
seja percebido pelo CLP independentemente do tempo que o operador segurar o botão 
apertado. 

 

 

2. Ação Retentiva ( ) 

O botão de ação retentiva se comporta como uma botoeira biestável, ou seja, apresenta 
alternância de estado para cada atuação sobre ela.  

3. Ação Retentiva com reset externo ( ) 

4. Mostrador Numérico (Numeric Display) 

Assim como para os botões existem também para o Mostrador Numérico as abas General, 
Common e Connections. Para configurar o Mostrador Numérico basta atribuir na aba Connections 
a variável a ser monitorada ao item Value da mesma. 
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5. Indicador Multiestado 

O indicador de Multiestado apresenta as abas General, States, Common e Connections. Para 
esse objeto destaca-se a aba States em que para cada valor da variável atribuída ao indicador 
(Indicator na Aba Connections) é possível atribuir uma aparência ao objeto como cor e texto. 
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6. Animações 

Além dos objetos existentes para visualização e operação do sistema, é possível ainda atribuir 
comportamentos a objetos estáticos. Por exemplo, é possível vincular cores a estados diferentes 
em um mesmo equipamento, fazer com que objetos se movam de acordo com o valor de alguma 
variável, fazer com que apareçam e desapareçam dependendo dos sinais atrelados a ele, entre 
outros. Para isso devemos definir as opções de Animation de acordo com o comportamento que 
desejamos para a representação dos equipamentos.  

Para atribuir uma animação a um objeto pressione o mesmo com o botão direito e em seguida 
seleciona a opção Animation e o tipo de animação desejada.  

 

 

As animações que já estiverem atribuídas ao objeto selecionado ficam marcadas com um check. 
No exemplo da figura a cima tem-se uma animação de cor (Color) definida. 

 Quando selecionamos uma animação para ser atribuída a algum objeto a tela de 
configuração dessa animação é mostrada. As configurações das animações, basicamente, são 
compostas por uma expressão (Expression) a ser verificada e uma ação a ser tomada.  

Abaixo temos um exemplo de configuração de uma animação de cor (Color), em que no campo 
Expression foi atribuído uma variável({[PEA2509]Fim_de_Curso_1}) e para cada Valor (Value) 
que essa variável assumir foi atribuída uma cor de preenchimento (Fill) e uma cor de linha (Line). 

 

 



Tutorial: Programação da IHM PanelView 
 

PEA/EPUSP PEA 2509 – Laboratório de Sistemas Elétricos 
Luiz Antônio Aielo – Hiroaki Okawa Página 13 
 

 

APLICAÇÃO:  ESTEIRA TRANSPORTADORA 

 

A aplicação exemplo desse tutorial se refere a um sistema de operação e supervisão de uma 
esteira transportadora. Os sinais de estado de equipamentos e comando são apresentados na 
tabela abaixo. 

Tag do CLP Sinal Valores Válidos 

Cmd_IHM_Desliga Comando Desliga 
1 (Comando ativo); 
0 (Comando Inativo) 

Cmd_IHM_Liga Comando Liga 
1 (Comando ativo); 
0 (Comando Inativo) 

cmd_IHM_refA 
Define a Referência A como referência 
de velocidade 

1 (Comando ativo); 
0 (Comando Inativo) 

cmd_IHM_refB 
Define a Referência B como referência 
de velocidade 

1 (Comando ativo); 
0 (Comando Inativo) 

Fim_de_Curso_1 Sinal de sensor de fim de curso 1 
1 (Sensor atuado); 
0 (Sensor não atuado) 

Fim_de_Curso_2 Sinal de sensor de fim de curso 2 
1 (Sensor atuado); 
0 (Sensor não atuado) 

Inversor.Ligado Sinal de retorno de esteira ligada 
1 (Esteira Energizada); 
0 (Esteira não Energizada) 

Inversor.frequencia Velocidade atual da esteira 0 ~ 120 Hz 

Inversor.Sentido Sinal de retorno do sentido de rotação 1 (Sentido Negativo); 
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da esteira 0 (Sentido Positivo) 
Obs.: Verificar referência 
definida no start-up do 
inversor 

Inversor.Falha Sinal de falha do inversor 
0 (Motor OK) 
1 (Motor em Falha) 

 

Instruções: 

• Configurar os comandos das referências de velocidade da esteira (baixa e alta) através de 
botões de ação retentiva; 

• Configurar os comandos de liga e desliga da esteira através de botões de ação não retentiva. 
(Discutir o porquê do uso de dois botões não retentivos para o acionamento do inversor); 

• Mostrar os valores dos estados do inversor em verde (Motor OK) ou amarelo (Motor em falha) 
utilizando um indicador multiestado; 

• Mostrar em um display o valor da velocidade e o seu sentido; 

• Fazer as animações das chaves de fim de curso; 

• Verificar a animação da esteira; 
 

6) Verificar a animação da esteira;Criando um backup de suas aplicações 

As aplicações do FactoryTalk View ME utilizam uma grande variedade de arquivos os quais 

estão armazenados na pasta do projeto de sua aplicação. A fim de facilitar a manipulação desses 

arquivos existe, no conjunto de ferramentas do FactoryTalk View,  a ferramenta Application 

Manager. Para abri-la basta selecionar Tools -> Application Manager... no menu superior do FT 

View ou pelo atalho na área de trabalho.  

Para fazer o backup de sua aplicação abra o Application Manager e siga os passos a seguir: 

a) Selecione o tipo de aplicação como Machine Edition e pressione Next. 
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b)  Selecione Backup application e pressione Next. 

 

c) Selecione a aplicação que você quer fazer backup e pressione Next. 
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d) No primeiro campo entre com o nome desejado para o arquivo de backup(.apa) da 

aplicação. No segundo campo, selecione onde a aplicação será salva. 

 

 

e) Restaurando a aplicação de um arquivo de backup (.apa) 

 

Para restaurar sua aplicação basta pressionar duas vezes o arquivo de backup que o 

Application Manager abrirá. A Tela a seguir deverá aparecer.  
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Verifique se o caminho mostrado aponta para seu arquivo de backup e se a opção “Restore 

the FactoryTalk Machine Edition Aplication” está selecionada. Pressione Next. Na próxima tela 

entre com um nome para sua aplicação e pressione Finish. 

 

 

O Application Manager fará a restauração de sua Aplicação e fechará. Sua Aplicação, então, 

estará disponivel no FactoryTalk View. 

Obs.: Caso já exista alguma aplicação com o mesmo nome o Application Manager não 

permitirá que o backup seja restaurado, ou seja, deverá ser escolhido um novo nome para sua 

aplicação. 

7) Download de uma Aplicação no PanelView Plus 

Para transferir as telas criadas para um terminal PanelView Plus é necessário criar uma 

arquivo do tipo .MER. Para tanto siga os seguintes passos.  

a) Selecione Application -> Create Runtime Application 
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b) Indique onde o seu projeto será salvo e dê um nome à sua aplicação. 

Após a geração do arquivo tipo .MER, basta fazer o download para o PanelView Plus. Para 

tanto, siga os seguintes passos: 

a) Selecione Tools -> Transfer Utility (ou pelo ícone ) 

b) Na tela a seguir, em Source File indique onde a sua aplicação está salva e em Select 

destination terminal selecione o seu PanelView Plus. Clique em Download. 
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Obs.: Selecione a opção Run application at start-up, para que a aplicação comece a funcionar 
automaticamente na IHM após o download. 


