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A. OBJETIVOS 

 
Esta sessão de lab visa familiarizar o estudante com o uso do ambiente de 

gerenciamento de projeto IC Station, da Mentor Graphics Corporation. O 
ambiente consiste de uma série de ferramentas como, por exemplo: 

• IC Graph- editor de polígonos coloridos, em que cada conjunto <cor - textura - 
espessura de borda> representa uma máscara da tecnologia CMOS 
considerada; 

• Calibre- programa de extração do esquema de um circuito a partir do seu 
leiaute, 

• DRC- iniciais de design rule checker, programa de verificação das regras de 
projeto impostas pela empresa onde o circuito será fabricado (em uma Silicon 
Foudry).  

As tarefas a serem realizadas neste laboratório são: 

1. Familiarização com a ferramenta IC Graph. 

2. Desenhar o leiaute de um transistor MOS usando o programa ICGraph. 

3. Verificar se a regras de projeto (também denominadas de regras de leiaute) 
da biblioteca de células ADK, usando-se a ferramenta DRC, estão sendo 
respeitadas; 

4. Gerar arquivos contendo a descrição de leiaute no formato (arquivo) GDSII, 
que representa a geometria dos polígonos correspondentes às máscaras do 
processo CMOS e que serve como interface entre a fase de projeto e a de 
fabricação de um CI. 

B. PARTE TEÓRICA 

 
1) O IC STATION 

 O IC Station é um programa que permite editar um leiaute, verificar 
(interativamente) se as regras de projeto estão sendo respeitadas e extrair o 
esquema elétrico a partir do leiaute.  

 Uma grade baseada em unidades λ pode ser sobreposta a este desenho para 
servir como guia. Isto facilita a tarefa de posicionamento das diversas figuras 
geométricas sobre o plano, bem como a de verificação das mensagens de erro que 
eventualmente ocorram (quando regras de projeto são desobedecidas). A unidade λ 
é parametrizável de acordo com a tecnologia de fabricação utilizada, 
correspondendo à metade da menor dimensão geométrica encontrada nesta; na 
prática, é o comprimento do canal. Por exemplo, 

tecnologia de 90nm�  λ= 45 nm . 

Devido ao fato de a edição ser feita baseada em uma unidade genérica λ, um 
mesmo leiaute resultante é escalável, podendo, em princípio, ser transferido para 
diversas tecnologias de fabricação. Para as nossas experiências, adotamos algumas 
tecnologias que são parte da distribuição das ferramentas da Mentor Graphics no 
seu Programa Universitário, particularmente da TSMC e AMI (atualmente 



PSI3452 – 2017 
 

3 

pertencente à ON Semiconductor). 

 O IC Station contém um design rule checker, DRC, programa que verifica se o 
arquivo sendo editado está de acordo com as regras de projeto. Regras de projeto 
existem para garantir margens de segurança ao se desenhar as máscaras do 
leiaute; exemplos são dimensões mínimas de linhas de metal ou silício-poli, 
tamanhos mínimos para aberturas de contatos, distâncias entre máscaras de região 
ativa e seleção n+ (ou p+) para garantir a construção correta de regiões de dreno ou 
fonte, etc. Evita-se assim que desvios naturais que ocorrem nos processos de 
fabricação levem a CIs inoperantes ou com falhas.  Cada tecnologia (TSMC ou AMI, 
por exemplo) tem o seu conjunto de regras, dadas em µm.  
 

Regras de projeto podem ser dadas também em distâncias λ, mas ao final, 
quando se converte as máscaras projetadas em λ para os correspondentes em µm,  
estas devem atender as regras de projeto dadas pela fábrica. Estas regras estão 
descritas em um arquivo de tecnologia (veja algumas regras em λ, do conjunto 
sCMOS/SUBM, dadas em  no apêndice 1).  

 
O DRC pode ser chamado a qualquer momento da edição do leiaute, sendo, 

então, qualquer violação das regras de projeto acusada imediatamente. A 
identificação dos erros pode ser feita por meio de botões da interface do programa 
com o usuário. 
 

2) MÁSCARAS E REGRAS DE PROJETO SCMOS 

 Um leiaute é um desenho composto de polígonos coloridos que 
correspondem a máscaras de processo (planos das máscaras). Como explicado 
anteriormente, cada conjunto <cor - textura - espessura de borda> representa uma 
máscara no IC Graph. É importante fazer a ressalva que, em muitos aplicativos, os 
polígonos e planos podem corresponder a um conjunto/composição de máscaras; 
isto como forma de diminuir a quantidade de objetos (elementos de computação) e, 
portanto, a sua complexidade. Uma importante consequência disto é que durante a 
fase de edição de um leiaute o usuário deve tomar cuidado com a interpretação de 
certas operações. Por exemplo, ao se acrescentar uma camada sobre outra já 
existente, a intersecção entre ambas pode ser automaticamente armazenada como 
uma camada composta na estrutura de dados, se houver correlação entre elas. Isto 
pode fazer com que não seja possível mais apagar apenas uma destas camadas. 

O programa IC Graph em si é independente de tecnologia. Arquivos de 
tecnologia são incorporados ao programa e uma tecnologia específica deve estar 
carregada em um projeto em andamento. Os arquivos contêm as informações 
tecnológicas como nomes das diferentes máscaras, camadas, código de cores, 
regras de projeto (vide apêndice 1), parâmetros elétricos, etc.  

Os arquivos das tecnologias da TSMC e AMI utilizadas nas nossas 
experiências seguem regras de projeto SCMOS em unidade λ do MOSIS 
(www.mosis.com)1. São dois arquivos para cada tecnologia, para os seguintes casos 
de regras de projeto:   

- SCMOS – adequado a transistores de dimensões grandes; 

- SCMOS SUBM – transistores de dimensões submicrônicas 

                                                 
1 Lembrar que as máscaras finas são em µm, após a conversão. 
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- SCMOS DEEP – transistores de dimensões submicrônicas profundas 
(deep submicron) 

Adotamos o SCMOS/SUBM para esta experiência por ser mais compatível 
com a tecnologia TSMC de 0,35 µm utilizada2. Os arquivos de tecnologia 
correspondentes estão nas pastas: 

• layers_nome_da_tecnologia  

• nome_da_tecnologia.rules 

 O ADK consiste de uma biblioteca de células disponíveis em 5 tecnologias: 
AMI_0,5; AMI_1,2; TSMC_0,18; TSMC_0,25 e TSMC_0,35. Nesta biblioteca, além 
do conjunto de células, há descrições dos processos utilizados e as correspondentes 
regras de projeto.  

 A dimensão mencionada nos nomes da tecnologia representa um parâmetro 
importante que é o da dimensão mínima (em µm) do canal dos transistores a serem 
fabricados; quanto menor for esta dimensão, mais rápido será o circuito e menor 
será a sua área, porém o custo de fabricação será maior.  

 

3) COMANDOS DO IC GRAPH 

 O IC Graph é um ambiente de projeto que permite realizar as tarefas 
necessárias de edição de um leiaute a partir de diferentes interfaces com o usuário. 
Ao se iniciar o programa, aparece uma tela sobre a qual um desenho pode ser 
criado, ampliado ou modificado (de uma sessão anteriormente salva).  Os comandos 
de edição podem ser fornecidos de três maneiras diferentes: 

1.  Através das opções na barra de menu (parte superior da janela). 

2.  Através de botões das barras de ferramentas (palhetas).  

3.  Através de comandos longos (muitas vezes, apenas comandos curtos já são 
suficientes).  

A lista exaustiva dos comandos poderá ser encontrada no manual do aplicativo. 

 

                                                 
2 Para satisfazer as regras da fábrica em µm, a conversão para a tecnologia TSMC 0,35 µm deve ser  

λ= 0,20 µm (observe que não é λ= 0,175 µm) 
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C. PARTE EXPERIMENTAL 

ATENÇÃO: Observe que, ao longo desta apostila, existem várias informações e 
discussões, que deverão aparecer na sua folha de respostas. Recomenda-se que o 
aluno grave todas as informações relevantes para, depois, poder anexá-los e/ou 
usar para estudo para as provas. 

ATENÇÃO: Ao ligar o computador na sala c1-10, o aluno deverá selecionar o 
sistema operacional Scientific Linux – Mentor Graphics/Cadence. 
 

 1) ALGUNS PASSOS COM O LINUX 

Para os labs da disciplina PSI-3452, os alunos usarão ferramentas que rodam 
sobre o sistema operacional LINUX, incluídos o software IC Station, os softwares de 
simulação e os de visualização. O aluno não necessitará de conhecimentos de UNIX 
para realizar as experiências uma vez que trabalhará, praticamente, apenas com o 
sistema de janelas (desktop). Ocasionalmente, alguns comandos UNIX serão 
introduzidos objetivando tornar as sessões de trabalho mais rápidas e eficientes. 

ATENÇÃO: em LINUX, há diferenciação entre letras maiúsculas e minúsculas; 
não se pode trocar umas pelas outras. 

Na caixa de diálogo para a inserção de seu nome de usuário e senha, clique 
sobre o botão ao centro para, então, selecionar o KDE, um dos ambientes de 
desktop do LINUX. Sempre que uma sessão de trabalho for aberta, o aluno será 
direcionado automaticamente à pasta:  

 /home/grad/nome_do_usuário  

(informalmente conhecida como sua pasta particular ou, em inglês, home diretory).  

 O aluno tem permissão de controlar e gerenciar (escrever, editar, copiar, criar 
e remover subpastas, etc.) a sua pasta home e todas suas subpastas descendentes. 
Da mesma forma, qualquer usuário pode bloquear (ou permitir) o acesso de outros 
usuários às suas pastas e subpastas. 

ATENÇÃO: para as diferentes distribuições, versões e instalações, podem 
ocorrer diferenças entre os menus do KDE; portanto, as informações abaixo 
podem apresentar diferenças em relação ao encontrado na tela de seu 
computador.  

 1.1. ATIVANDO E TROCANDO DESKTOPS 

Para não congestionar a tela com a abertura simultânea de muitas janelas, o 
aluno poderá organizar o seu trabalho em quatro desktops diferentes.  

• Clique sobre os retângulos cinzas, que aparecem na barra inferior da tela a 
fim de ativar cada uma das áreas de trabalho (desktops). Em cada área de 
trabalho, o aluno poderá abrir janelas e ativar diferentes programas. 

• Retorne à área de trabalho inicial onde será feita a experiência. Para os 
alunos que querem ir anotando os resultados da experiência e editando 
diretamente o relatório (que, de outra forma pode ser feito depois da aula), 
recomenda-se que usem outra área de trabalho (por exemplo, o desktop 4) 
para editar o seu arquivo. 



6 
 

 

 1.2. ATIVANDO JANELAS E PROGRAMAS 

Para disparar programas como, por exemplo, o ambiente de projeto IC 
Station, é necessário criar uma JANELA DE TERMINAL (ou JANELA DE 
COMANDOS) ASCII. Para isto: 

• Clique no Menu K de Aplicações (no canto inferior ou superior esquerdo). 

• Selecione    Acessórios > Terminal  

OBSERVAÇÃO: O mesmo efeito pode ser obtido ao se clicar com o botão direito do 
mouse sobre a tela e, no menu que aparece, selecionar Konsole (Terminal). 

 Com esta operação, aparecerá uma janela em que uma sessão estará aberta, 
posicionada na sua pasta home, que está pronta para receber comandos de linha. 
Verifique o nome de sua pasta home digitando o comando pwd (mnemônico do 
inglês present working directory) e observe o caminho que aparece.  

OBSERVAÇÃO: É permitido abrir diversas janelas de terminal, cada uma realizando 
diferentes tarefas. 

 

 1.3. GERENCIAMENTO DE ARQUIVOS E PASTAS (E NAVEGAÇÃO NA 
INTERNET) 

Primeiramente, construa o seu sistema de arquivos com o gerenciador de 
arquivos (o programa Konqueror). Para acessá-lo: 

• Clique no Menu K   
• Selecione  Aplicações > Internet > Konqueror (obs. é também 
navegador de Internet) 

 Alternativamente, você pode acessar o  Konqueror digitando o comando 
konqueror na sua janela de terminal, já aberta. Você verificará que existe o desenho 
de uma casa no menu superior. Ao clicar neste ícone o gerenciador posiciona-se na 
sua pasta home. 

 /home/grad/nome_do_usuário  

 Teste o gerenciador (que é muito semelhante ao Windows Explorer) utilizando 
a sua barra de ferramentas e menus3. Em seguida use o gerenciador para criar as 
pastas necessárias para esta e  demais experiências. 

• Dentro da sua pasta home crie uma pasta chamada  psi3452          

ATENÇÃO: psi  EM LETRAS MINÚSCULAS. 

• Dentro da pasta psi3452 crie uma pasta chamada lab1. 

• Dentro da pasta lab1 crie uma pasta chamada celulas. 

 Na janela de terminal, você poderá também acessar a pasta criada.  

• Tecle cd lab1. 
• Tecle cd celulas. 

 

                                                 
3 Observe que, por tratar-se de um ambiente de uso público, existem diversas áreas às quais usuários comuns 

não têm acesso. Existe um super-usuário (administrador) conhecido como root, que tem direitos sobre todo o 

sistema. A subpasta root equivale à pasta chamada /  (chamada de root) , de nível de hierarquia mais alta. 
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OBSERVAÇÃO: em LINUX/UNIX, “cd” é o código mnemônico para change diretory. 
Use "man cd", caso deseje mais detalhes sobre o comando "cd". 

 Apenas para confirmar, usando o comando pwd, verifique se o caminho 
completo desta pasta é: 

 ~/psi3452/lab1/celulas 

OBSERVAÇÃO: em LINUX/UNIX, o símbolo ~ equivale  à  sua pasta home  (então 
“cd /home/grad/nome_do_usuário” é o mesmo que “cd ~”).  

 Todas as tarefas da experiência 1 (descritas a seguir) deverão ser realizadas 
a partir da pasta ~/psi3452/lab1/celulas.  Esta pasta corresponderá ao working 
directory (ou pasta de trabalho) de seu projeto e será frequentemente designada 
pelas iniciais WD. 

 

 1.4. EDITANDO ARQUIVOS 

Para edição de seus relatórios, o aluno poderá lançar mão do programa 
KWrite. Para acessá-lo digite kwrite no seu terminal. 

Obs.: para fazer o relatório, você pode usar a ferramenta de edição de texto, 
OpenOffice, se você preparar o relatório no LINUX; o aluno poderá gravar em 
formato *.doc, caso vá utilizá-lo com o Word no WINDOWS, depois. Tome cuidado 
com fórmulas ou símbolos, pois a conversão pode não ser a esperada, sendo 
necessárias algumas edições adicionais. 

 

 1.5.  AJUSTANDO VARIÁVEIS DE AMBIENTE 

Considerando que a árvore de pastas e arquivos muda de instituição para 
instituição, de acordo com a técnica, tradição e gosto do gerente de sistemas, os 
programas aplicativos devem, então adaptar-se rapidamente a ele (o sistema). Isto 
cria um problema na elaboração dos códigos destes aplicativos, pois muitas vezes, 
os scripts do programa (sequência de comandos do sistema operacional) precisam 
dizer onde, dentro da árvore de pastas, estão os componentes do programa. Para 
facilitar esta tarefa, usam-se variáveis de ambiente que são definições locais dadas 
a algumas "palavras-chave" que são, por sua vez, utilizadas nos scripts.  

Um exemplo de variável de ambiente é a variável HOME, gerada 
automaticamente no login do usuário, que deve corresponder ao caminho de sua 
pasta home/grad/nome_do_usuário. Desta forma, os aplicativos podem 
simplesmente apontar a pasta de denominação genérica $HOME e, para cada 
usuário o significado será específico. Para ver HOME na janela de terminal já criada, 
tecle: 

env 
 
Observe que este comando lista todas as variáveis de ambiente já criadas e os 

seus valores (significados). Para exercitar este conceito, encontre e confirme o valor 
da sua variável HOME. 

Em relação aos programas que utilizaremos na nossa disciplina existem algumas 
variáveis de ambiente pré fixadas para que o aluno possa acessar os programas da 
empresa Mentor Graphics, o gerenciador de licenças, para algumas bibliotecas a 
serem utilizadas.  
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 1.6. ATIVANDO AS VARIÁVEIS DE AMBIENTE 

Na janela de terminal (de onde será mais adiante disparado o programa) tecle: 

  source     /home/disc/psi3452/perfil_mgc1 
 

O comando source executa scripts. Neste caso, o script executado está contido no 
arquivo perfil_mgc1. Os comandos executados servem para definir alguns 
caminhos de busca e algumas variáveis de ambiente necessárias aos programas da 
Mentor.  

ATENÇÃO: A execução deste comando é obrigatória todas as vezes que você abrir 
uma nova janela de terminal para rodar comandos linha referentes aos programas 
da Mentor. 

2) ASPECTOS DA TECNOLOGIA USADA 

 2.1. MANUAIS DE TECNOLOGIA E REGRAS DE PROJETO 

 As aulas práticas no laboratório adotarão uma tecnologia de 0,35 µm tanto da 
TSMC, como da AMI. Esta é uma tecnologia com a qual é possível fabricar circuitos 
que podem funcionar em frequências na faixa de gigaHertz (podendo chegar a 3 ou 
4 GHZ). A especificação desta tecnologia encontra-se em /home/disc/psi3452/ . 

As regras de projeto estão no manual: 

ENG-183_rev6.pdf (revisão 6)  

enquanto os parâmetros elétricos no manual:  

ENG-182_rev5.pdf (revisão 5) 

 Como forma de se familiarizar com o manual, o aluno deverá fazer algumas 
anotações e comentá-las. 

� Completar informações na folha de respostas (item 2.1) 

 
 2.2. EXEMPLO COM REGRAS DE PROJETO 

 O sistema ADK-ICstation (o programa IC Station dirigido à biblioteca ADK), 
que usaremos em nossas aulas, substitui estas regras de projeto por “regras de 
projeto escalável”, ou seja baseado em regras λ. Adotamos as regras MOSIS-SUBM 
em λ, sendo que algumas estão no Apêndice 1 deste texto. Todas as regras são 
calculadas usando critérios de pior caso. O valor de λ no nosso caso é de 0,2 μm 
(para não usar 0,175 μm, por segurança, arredonda-se para cima).  

O leiaute gerado pelo ADK é convertido para o formato GDSII que está no 
sistema métrico e este que será enviado para fabricação. Note que o leiaute, quando 
convertido em microns, deverá ter todas as dimensões maiores que os valores 
mínimos das regras da tecnologia TSMC 035 estão no manual ENG-183_rev6.pdf. 

 Como forma de verificar a questão da margem de segurança nas dimensões, 
o aluno deverá fazer uma comparação entre os dois casos de conversão de λ: 0,175 
e 0,2 μm.  

� Completar informações na folha de respostas (item 2.2) 
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 2.3. MANUAIS DA IC STATION E OUTRAS FERRAMENTAS 

 A Mentor Graphics disponibiliza os manuais de seus softwares, incluído a IC 
Station, através de documentos *.html ou *.pdf.  Estes manuais se encontram nas 
pastas: 

• /tools/mgc_tree/ic_station_2014_v9/v9.0h_linux_x86_64/icstation_hom
e/docs/pdfdocs/icstn_user.pdf 

• /tools/mgc_tree/ic_station_2014_v9/v9.0h_linux_x86_64/icstation_hom
e/docs/htmldocs/icstn_user/wwhelp/wwhimpl/js/html/wwhelp.htm 

 
OBSERVAÇÃO: Você pode acessar os manuais depois de disparar a ferramenta 
IC Station. clicando em:  

• Help → Open Users manual  

e para acessar o Manual de Usuário do IC Station no Acrobat Reader escolha: 

• IC Station-> Getting Started with IC Station.  

 Usando o gerenciador de arquivos, acesse a pasta onde se encontra o 
manual no formato .pdf. Observe que nas pastas indicadas existem diversos outros 
manuais de outros programas que compõem o pacote da Mentor Graphics. 

 Para que o aluno familiarize-se com estes manuais, o aluno deverá acessar 
alguns deles. 

3) EXEMPLO GUIADO COM IC STATION 

 3.1. DISPARANDO O PROGRAMA IC Station 

Primeiro você precisa posicionar o seu terminal na sua pasta de trabalho, 
working directory. Para isto, ative um terminal na sua tela (ou usar algum terminal 
que já esteja aberto). Na janela tecle o comando : 

•  cd  ~    (para se certificar que esteja ou retornar para o seu home diretory) 

•  cd  psi3452/lab1/celulas   (para mudar para sua pasta de trabalho 
working directory) 

 ATENÇÃO: lembre-se de, ao abrir uma nova janela de terminal, sempre usar o 
comando  

• source /home/disc/psi3452/perfil_mgc1 

Dispare o IC Station, teclando: 

• adk_ic & 

  e aguarde alguns instantes até a janela do IC Station aparecer. 

OBSERVAÇÃO: O comando adk_ic é na verdade um script que serve para 
configurar as variáveis de ambiente, os caminhos (paths) e a licença de uso do 
programa IC Station adaptado para a biblioteca de tecnologia ADK. 

OBSERVAÇÃO: O símbolo & do LINUX indica que após acessar o IC Station, o 
program estará rodando em background e a janela de terminal estará liberada para a 
entrada de demais comandos. 
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Primeiramente, defina o diretório de trabalho no IC Station. Clique na barra 
superior 

• MGC -> Location Map → Set Working Directory 

e selecione ~/psi3452/lab/celulas se o WD não estiver já selecionado. 

Observe que aparece à direita da tela do IC Station uma palheta de trabalho (IC 
Palettes). Caso a palheta de trabalho não esteja na tela, clique na barra superior, 
para ela aparecer: 

• Setup -> Windows -> Palette Area 

OBSERVAÇÃO: A palheta pode ser eliminada da tela para ampliar a área de 
trabalho clicando na parte superior da própria palheta sobre o símbolo de um pino (à 
esquerda do X). Para reativar a palheta basta posicionar o mouse sobre a palavra 
Session (que aparece no canto direito da janela) e em seguida clicar novamente 
sobre o pino. 

 

 3.2.CRIANDO UMA NOVA CÉLULA 

Na palheta de trabalho (IC Palletes), clique: 

• New (aparecerá a caixa de diálogo New Layout) 

• Cell name:  cel_1  

• Process: navegue até o arquivo de biblioteca navegue até a pasta 
/tools/mgc_tree/adk3_1/technology/ic/process e selecione a tecnologia 
CMOS 0,35um (indicado com a letra P). Clicar OK. 

• Rules: navegue até a mesma pasta, selecione o arquivo de regras de 
leiaute (“algum_nome.rules”). Clicar OK. 

• Confirme as seleções clicando OK. 

Uma janela de projeto (vazia) aparecerá, cuja parte superior conterá o nome da 
célula (cel_1). Nela aparece uma grade composta de pontos, alguns menos e outros 
mais brilhantes. Na parte inferior há uma aba denominada Message Area, onde  
você pode acompanhar todos os seus comandos correspondentes às suas ações.  

ATENÇÃO: A mensagem que deve aparecer é "$MGC_WD/cel_1 reserved for 
edit”. O $MGC_WD indica que você está, de fato, trabalhando na sua pasta de 
trabalho,  cel_1 é o nome dado para a sua célula e reserved for edit significa que a 
célula pode ser editada.  

 
 3.3. EDITANDO UMA CÉLULA 

Uma janela do editor de leiaute do IC Station pode apresentar uma célula COM ou 
SEM permissão para ser editada. A opção COM permissão (reserved for edit) é a 
normal. A opção SEM permissão é usada quando, por precaução, não se deseja 
permitir mudanças (nem mesmo acidentais) num leiaute satisfatório. Você pode 
mudar de uma situação para outra clicando em: 

• Context -> Layout -> Set Edit Mode On/Off 

OBSERVAÇÃO: após você gravar o resultado de um leiaute (o que, por segurança, 
deve ser feito sempre que você obtiver um resultado parcial satisfatório), ao reiniciar 
o projeto (usando a opção OPEN cell na palheta de trabalho) a célula será sempre 
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reaberta no modo SEM permissão. Logo, não esqueça de tornar a célula editável 
caso queira prosseguir realizando alterações no projeto. 

 

 3.4. ENTENDENDO O SISTEMA DE COORDENADAS 

 No canto superior direito da janela do IC Station aparece um indicador 
Cursor, com dois números. Estes números correspondem à atual posição do cursor 
do projeto em coordenadas λ. O ponto (0,0) (origem) está indicado na figura através 

de um +. Ao mover o mouse sobre a grade, o cursor indica as suas coordenadas, ou 
seja a distância dada em λ. Os valores indicados são relativos à origem que é fixa.  

• Posicione o cursor no centro da janela e observe que aparecem as 
coordenadas (0,0). 

• Mova o mouse e observe que os valores (em λ)λ)λ)λ)    em mudam. 

 

 3.5. CONTROLANDO A GRADE 

A grade serve para duas finalidades: 

1-  Definir as dimensões dos retângulos (ou outros tipos de polígonos) que 
irão constituir o leiaute;  

2-  Definir a posição de cada retângulo (polígono) no leiaute.  

No menu superior: 

• Selecione View→→→→Zoom→→→→To Grid. 

e observe o que ocorre.  

 Observe também usando o indicador Cursor  qual é o espaçamento entre os 
pontos menores e maiores. Observe que o ponteiro do mouse pode, pelo menos, 
neste primeiro momento, parar fora das posições da grade. Pelo menu: 

• Selecione a opção Setup →→→→Preferences 

• Na janela que surge, selecione  Display->Rulers/Grid 

• Na caixa de diálogo, observe que a opção Use Snap Grid esteja ativada. 
Observe os valores de Snap grid coordinates X e Y, Snap grid offsets X 
e Y e Grid points at Major e Minor.  

OBSERVAÇÃO: Você pode usar a opção View→→→→Zoom→→→→IN ou OUT para 
ampliar/reduzir o seu desenho. 

� Completar informações na folha de respostas (item 3.5) 

• Mova o cursor e veja a relação entre os pontos de parada e os valores de 
Snap grid coordinates X e Y 

• Veja qual a relação entre o valor de Grid points at Minor e os valores de 
Snap grid coordinates X e Y  

• Veja qual a relação entre o valor de Grid points at Minor e o valor de Grid 
points at Major 
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 3.6. MODIFICANDO OS VALORES DA GRADE 

Modifique a grade para que você tenha certeza que entendeu o significado dos 
parâmetros dados. Repeta as operações:  

• Selecione a opção Setup →→→→Preferences 

• Na janela que surge, selecione  Display->Rulers/Grid 

• Modifique o valor de  um parâmetro (veja logo abaixo) 

• Clique em Apply → OK 

• Selecione View → Zoom → To Grid 

e movendo o cursor sobre a nova grade observe o que ocorre pela marcação da 
posição do cursor no canto superior direito de sua tela.  

 Mude os seguintes parâmetros (um de cada vez): 

 Grid points at Major = 10 

  Grid points at Minor = 1 

  Snap grid coordinates X = 2 

  Snap grid coordinates Y = 1 

� Completar informações na folha de respostas (item 3.6.A) 

• Mova o cursor e veja a relação entre os pontos de parada e os valores de 
Snap grid coordinates X e Y 

• Veja qual a relação entre o valor de Grid points at Minor e os valores de 
Snap grid coordinates X e Y  

• Veja qual a relação entre o valor de Grid points at Minor e o valor de Grid 
points at Major  

� Completar informações na folha de respostas (item 3.6.B) 

 Faça mais mudanças e experimentos por sua conta: 

 Para as tarefas seguintes, retorne aos valores da grade inicial, ou seja: 

 Grid points at Major = 5 

  Grid points at Minor = 2 

  Snap grid coordinates X = 0.5 

  Snap grid coordinates Y = 0.5 

 

 3.7. DESENHANDO UM RETÂNGULO (POLY) 

Os desenhos serão personalizados com o número USP da seguinte forma: 

 W (em λ) é o penúltimo algarismo do seu número USP. Se for < 5, some o valor 
5 a ele. 

 L (em λ) é formado com o último algarismo do seu número USP. Considere o 
algarismo como n, então a dimensão é (n mod 4). Caso for < 2, some o valor 2  a 
ele. 

 Exemplo 1: #USP 3164124  leva a W =7λ (ou seja, 2+5 )  e  L=2λ. 
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 Exemplo 2: #USP 3164167  leva a W =6λ e  L=3λ. 

� Completar informações na folha de respostas (item 3.7) 

Para desenhar polígonos (retângulos) coloridos, cada cor representando uma 
camada do processo CMOS, clique sobre a palheta de trabalho em: 

• Easy Edit -> Shape 

Antes de desenhar o polígono é preciso escolher a que camada do processo 
CMOS corresponde (cor do polígono). Caso a palheta de camadas (ATENÇÃO: não 
confundir com a palheta de trabalho) não estiver presente na tela, faça-a aparecer 
clicando em: 

• Setup/Windows/Layer Pallete  

OBSERVAÇÃO: caso apareça uma caixa de diálogo Object Editor, você pode 
minimizar o seu tamanho, pois ela não será usada nesta experiência. 

OBSERVAÇÃO: A palheta Layer contém TODAS AS CAMADAS DO PROCESSO 
TSMC_035. Nós somente usaremos algumas destas camadas. Localize a camada 
N-WELL. As camadas que serão usadas nas aulas de laboratório são as que estão 
listadas logo após a NWELL. 

Prosseguindo, 

• Na palheta Layer, clique sobre o botão POLY. 

• Clique sobre a palheta de trabalho em: Easy Edit -> Shape 

• O seu retângulo deverá ter tamanho (altura= W+4λ; largura=L) 

• Posicione o mouse sobre a grade no ponto onde você irá desenhar um dos 
vértices do retângulo, arraste o mouse (sem soltar o botão do mouse) até a 
posição onde se encontra o vértice na outra diagonal do retângulo e 
finalmente solte o botão. O retângulo na camada Poly (cor vermelha) 
aparece na área de trabalho, como abaixo. 

 

 

 

Caso apenas a borda esteja em vermelho, coloque o cursor dentro do retângulo e 
tecle F2 (esta função será explicada com detalhes mais adiante).  

 

 3.8. MEDINDO O TAMANHO DO RETÂNGULO 

 Existem diferentes formas de se medir o tamanho. 

 a) PELA GRADE 

 Calcule o tamanho do retângulo em função do tamanho de sua grade. Veja no 
item d) acima de que forma você definiu a distância entre os pontos da grade. 

 b) PELA RÉGUA (RULER) NA PALHETA DE TRABALHO 
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• Clique em Ruler (a opção line na janela que se abre deve estar ativada) 

• Clique com o mouse posicionado sobre uma das extremidades do 
retângulo e clique novamente na outra extremidade. 

 c) PELA MEDIDA DE DISTÂNCIA (VIEW MEASURE DIST) 

• Clique em View → Measure Dist  

• Clique com o mouse posicionado sobre uma das extremidades do 
retângulo e clique novamente na outra extremidade. 

Naturalmente as 3 formas devem conduzir aos mesmos valores. 

 

 3.9. GRAVANDO O SEU PROJETO 

Para gravar o seu projeto (neste momento um retângulo na camada POLY. 
vermelha). 

• Clique em File→Save→Layout 

 

 3.10. FECHANDO E REABRINDO A IC STATION E REATIVANDO A SUA 
CÉLULA 

 Saia do programa clicando: 

• MGC -> Exit 

• Reative o programa (adk_ic &) e reabra a sua célula: 

• Na palheta de trabalho clique em Open 

• Na janela clique sobre o nome da sua célula e confirme com OK. 

ATENÇÃO: lembre-se que a sua célula foi reaberta SEM PERMISSÃO PARA 
EDIÇÃO. Para mudar tecle: 

• Context -> Layout -> Set Edit Mode On 

 

 3.11. DESENHANDO UM SEGUNDO RETÂNGULO (ACTIVE) 

Desenhe um segundo retângulo na camada Active (região ativa) como indicado 
na figura abaixo. Ele deverá ter as dimensões (altura= W; largura=L+11λλλλ). 

 

     

 

 

 

Clique sobre a palheta de trabalho em: 

• Easy Edit -> Shape 

• Na palheta de camadas escolha a camada ACTIVE.  

Lembre-se que caso a palheta de camadas não esteja presente na tela, faça-a 
aparecer com clicando em: 
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• Setup/Windows/Layer Pallete  

• Posicione o mouse sobre a grade no ponto onde você irá desenhar um dos 
vértices do retângulo, arraste o mouse (sem soltar o botão do mouse) até a 
posição onde se encontra o vértice na outra diagonal do retângulo e 
finalmente solte o botão. Tente manter a simetria do desenho como na 
figura. O retângulo na camada ACTIVE (cor verde) aparece na área de 
trabalho. 

Caso apenas a borda esteja colorida, coloque o cursor dentro do retângulo e tecle 
F2 . Foi preciso de-selecioná-lo para observar seu preenchimento de cor verde (veja 
o próximo item). 

OBSERVAÇÃO: Ao acrescentar um novo objeto (retângulo) este está 
automaticamente selecionado.  

OBSERVAÇÃO++: Note que, apesar de neste momento existirem apenas 2 
retângulos, das camadas vermelho (Poly) e verde (Região Ativa), na tela aparece 
uma terceira cor, na região onde os 2 retângulos se cruzam. Esta cor NÃO 
representa nenhuma camada útil do processo CMOS. Trata-se apenas de um 
feedback da ferramenta para indicar a superposição de duas ou mais camadas. 
Neste caso, esta cor indica o que será a região de canal do transistor. 

 

 3.12. IMPRIMINDO E GRAVANDO LEIAUTES 

 Para gravar o desenho do leiaute (a ser incluído no seu relatório), acione 
File→Print, e na janela que aparece, escolha 'Use formatter' e 'Export to file'. 
Tecle no retângulo 'Formatter Options' e lá escolha o 'Output format' como TIFF 
(poderia ser outro formato), escolha um nome 'Output file' por exemplo "cel_1.tiff". 
Selecione 'Omit page numbers', acione o 'color output' (ou sairá em preto e 
branco), finalmente tecle OK nesta janela. Tecle OK na primeira janela aberta. No 
seu diretório de trabalho deve aparecer um arquivo 'cel_1.tiff'.  

� Completar informações na folha de respostas (item 3.12) 

 3.13. REGISTRO DAS MÁSCARAS 

Um formato bem comum para guardar as informações geométricas das máscaras 
de um leiaute é o GDSII. Este é o formato usado para transmitir o ASIC para ser 
fabricado na Foundry. Trata-se de um formato de arquivo binário, compacto, 
adequado para transferências eletrônicas. Outro formato equivalente é o XML. Para 
gerar estas descrições, acione File→Export→GDSII (e, também, →XML). Na janela 
que aparece, use as opções default, selecione a célula topo de seu leiaute e escolha 
um nome para o ‘Output GDS File’, por exemplo: cel_1.gds2 (e, também, para o 
‘Output XML File’, com NMOS.xml). Clique em OK.  

Abra os dois arquivos com o aplicativo Kate e veja os seus conteúdos. Em, 
particular, para o arquivo XML, use adicionalmente a opção do IC Station, 
Report→Design Layers, com o mapeamento das máscaras, para auxiliar no 
entendimento do arquivo. 

� Completar informações na folha de respostas (item 3.13) 
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 3.14. SELECIONANDO E DESSELECIONANDO POLÍGONOS 

Para efetuar modificações e correções em um desenho em andamento, é 
necessário selecionar e/ou desselecionar polígonos já desenhados que precisam ser 
modificados ou corrigidos. 

Existem diversas formas para fazer a seleção/desseleção de figuras.  

a) USANDO O MENU DO BOTÃO DIREITO 

• Clicar COM O BOTÃO DIREITO DO MOUSE POSICIONADO SOBRE A 
JANELA DE TRABALHO. Aparecerá um cardápio de opções onde, entre 
outros comandos, encontram-se Select e Unselect. Cada um deles 
apresenta diversas opções.  

Para selecionar: 

• Clicar em Select -> Área 

• Arrastando o mouse, desenhe um retângulo qualquer que cubra TODA a 
área do retângulo desenhado. Desta forma ele estará selecionado.  

Para desselecionar: 

• Clicar em Unselect  -> Área  

• Arrastando o mouse, desenhe um retângulo qualquer que cubra a área do 
retângulo desenhado. Desta forma ele estará desselecionado. 

OBSERVAÇÃO: Você também pode selecionar e desselecionar usando outras 
alternativas indicadas no menu. 

OBSERVAÇÃO: Quando o retângulo está desselecionado, toda sua superfície está 
em vermelho (cor que representa silício poli). Mas, quando está selecionado aparece 
apenas a sua periferia, indicando que modificações de tamanho ou qualquer outra 
podem ser feitas. 

b) USANDO AS TECLAS F1 E F2 

A tecla F1 corresponde a selecionar e a F2 desselecionar. Para testar os seus 
funcionamentos execute as seguintes operações:  

• Com o cursor sobre a área de trabalho (onde existe grade), mas 
posicionado fora dos 2 retângulos, tecle uma vez em  <F2>  e depois tecle 
<F1> duas vezes seguidas.  

• Repita, mas agora mantenha o cursor sobre um dos retângulos. 

• Repita, mas agora mantenha o cursor sobre o outro retângulo. 

• Repita mais uma vez mas posicione o cursor sobre a palheta de camadas. 

OBSERVAÇÃO: Use o  item do menu View->Zoom-> In (ou Out) para uma melhor 
visualização.  

OBSERVAÇÃO: Uma forma rápida de centralizar a visualização é teclar <Shift F8> 
no teclado (veja as informações sobre as teclas de funções na barra abaixo da tela 
de projeto). Este atalho é equivalente a clicar na barra superior com View->All. 
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 3.15. FAZENDO CÓPIA DE UM OBJETO 

Selecione um polígono e depois, para fazer uma cópia, clique com o botão direito 
do mouse sobre a área de trabalho. No menu do botão direito clique: 

• Edit->Copy->Selected (ou, equivalentemente, na palheta de trabalho 
selecionar Copy) 

Observe que grudado ao cursor aparece a geometria que está sendo copiada 

• Posicione o novo polígono na posição desejada. 

• Clique com o botão esquerdo do mouse para fixar a cópia nesta posição. 

 

 3.16. MOVENDO O POLÍGONO USANDO A OPÇÃO REL MOVE 

Com o polígono selecionado: 

• No menu do botão direito clique: Edit -> Move -> Relative (ou, 
equivalentemente, na palheta de trabalho, clique: Rel Move - mover 
relativamente). Na caixa de diálogo informe: X Offset = 2; Y Offset = 0. 

• Clique em OK (o retângulo se deslocará de 2λ positivamente pois o offset 
de Y é indiferente neste caso).  

 

 3.17. MODIFICANDO AS DIMENSÕES USANDO A OPÇÃO STRETCH  

Com o polígono de-selecionado: 

• No menu do botão direito, clique Select-> Area e selecione o retângulo 
cuja dimensão será modificada. 

• Clique sobre a opção Stretch na palheta de trabalho.  

• Note que a opção Polygon está ativada na janela que se abre. 

• Clicando com o botão esquerdo do mouse (sem soltar) desenhe uma janela 
retangular envolvendo os dois vértices do lado do retângulo que será 
deslocado (a fim de mudar a dimensão). Mas, somente estes 2 vértices 
devem ser cobertos pela janela. 

Observe que, feito isto a opção Line será automaticamente ativada na janela 
inferior 

• Desenhe sobre a grade, em qualquer posição da área de trabalho (não 
precisa clicar exatamente sobre o lado do retângulo) uma linha com o 
tamanho do deslocamento (a direção do deslocamento, para a esquerda ou 
para a direita, para cima ou para baixo é importante). Você observará o 
deslocamento do lado selecionado no valor definido. 

• Clique em OK e cancele a janela inferior.  

• Por precaução de-selecione tudo (F2). 

 3.18. APAGANDO UM DOS POLÍGONOS 

 a) USANDO O TECLADO 

• Selecione somente um dos retângulos e em seguida tecle delete (no 
teclado).  
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b) USANDO O MENU GRÁFICO DO CANTO ESQUERDO 

 Observe que no canto esquerdo da área de trabalho existe outro menu com 
símbolos gráficos. Teste cada um deles para saber os seus significados. 

• Clicar sobre o X (vermelho)  

 

 3.19. CORRIGINDO ERROS DE EDIÇÃO  

É comum ocorrer erros, particularmente quando se está aprendendo a usar a 
ferramenta de edição (erros de dimensão, de camadas, etc.). Uma forma muito 
eficiente e eficaz de corrigir tais erros consiste em usar o comando UNDO.  

Para desfazer a operação de apagar, no menu do lado direito, clique em: 

• UNDO 

 

 3.20. VISUALIZANDO UMA MÁSCARA DE CADA VEZ 

Ao desenhar um leiaute, o desenho apresenta diversos polígonos em diversas 
cores. Muitas vezes é útil visualizar uma, ou um conjunto de camadas de cada vez 
(as outras são eliminadas da tela, sem serem apagadas). Na palheta de camadas, 
observe que existem 5 colunas que contêm: os nomes das camadas, as cores e três 
com as letras. São elas: S (select), V (visibility) e F (fill). Normalmente todas estão 
ativadas (símbolo √). Ao clicar sobre o símbolo repetidamente, você pode 
desativar/ativar cada coluna independentemente. A fim de observar somente o 
retângulo na camada Active, na palheta de camadas:   

• Desative as 3 colunas. 

• Duplo clique sobre o ícone azul (logo ao lado dos símbolos S V F) que 
corresponde  ao comando save layer settings. 

• Clique sobre os campos V e F da camada Active. 

• Duplo clique sobre o ícone azul. 

Na tela ficará somente o retângulo na camada Active. Você pode editá-lo 
modificando sua forma, tamanho, posição, etc, sem alterar o resto do seu desenho. 

Para visualizar todo o seu desenho novamente basta voltar a selecionar todas as 
colunas novamente e dar o duplo clique sobre o ícone azul. 

 

 3.21. ATIVANDO O VERIFICADOR DE ERROS DE PROJETO (DRC) 

A fim de se testar o programa DRC, modifique (use a operação Stretch) a 
dimensão de um dos retângulos cruzados de forma que uma das bordas de cada 
retângulo coincida como indicado na figura abaixo.  

 

 

Rode o programa de verificação DRC para entender o seu funcionamento. Na 
palheta Easy Edit: 
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• Clique em Back (no topo da palheta de trabalho).  

Na palheta IC Palettes: 

• Clique em ICrules.  

Na palheta ICrules que deve aparecer: 

• Clique em Check.   

• Clique OK na caixinha de diálogo.  

Em seguida clique em: 

• First.  

O(s) erro(s) cometido(s) aparecerá(ão) através de uma realimentação gráfica 
sobre o seu leiaute. Na área de mensagens (na parte inferior da janela) aparecerá a 
explicação sobre o(s) erro(s).  

Em seguida clique sucessivamente em: 

• Next  

A cada novo clique aparecerão mais erros cometidos, tanto na tela como na área 
de mensagens. 

� Completar informações na folha de respostas (item 3.21) 

 3.22. LOCALIZANDO OS ERROS NO ARQUIVO DE TECHNOLOGIA 

Vá para o desktop 2. Usando o programa File Browser vá até a pasta 
/home/disc/psi3452/ e abra o  abra o documento contendo as regras de leiaute: 

 

ENG-183_rev6.pdf (revisão 6)  

 

Localize as regras que foram violadas e observe os valores mínimos neste 
documento. 

 

� Completar informações na folha de respostas (item 3.22) 
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Apêndice 1: Algumas regras da tecnologia SCMOS-SUBM TSMC-AMI  0.35 µµµµm                                                                                                            
 
Regras λ (obs ilha é mesmo que poço) 
 
DRC1_1:  ilha N - largura mínima 12 
DRC1_2:  ilha N - espaçamento mínimo 18 
DRC2_1:  região ativa - largura mínima 3 
DRC2_2:  região ativa - espaçamento mínimo 3 
DRC2_3:  região ativa - espaçamento mínimo de fonte/dreno para borda da ilha 6 
DRC2_4:  região ativa - espaçamento mínimo de contato de substrato para borda da ilha 3 
DRC3_1:  POLY - largura mínima 2 
DRC3_2:  POLY - espaçamento mínimo 3 
DRC3_3:  POLY - overlap porta/reg.ativa 2 
DRC3_4:  POLY - overlap reg.ativa/porta 3 
DRC3_5:  POLY - espaçamento POLY.campo/reg.ativa 1 
DRC4_2:  seleção N ou P espaçamento (ou overlap) sobre reg.ativa 2 
DRC5_1:  contato POLY - dimensão 2x2 
DRC5_2:  contato POLY - overlap POLY/contato 1,5 
DRC5_3:  contato POLY - espaçamento 3 
DRC5_4:  contato POLY - distância para a porta 2 
DRC6_1:  contato ativa - dimensão 2x2 
DRC6_2:  contato ativa - overlap ativa/contato 1,5 
DRC6_3:  contato ativa - espaçamento 3 
DRC6_4:  contato ativa - distância para a porta 2 
DRC7_1:  metal1 - largura mínima 3 
DRC7_2:  metal1 - espaçamento mínimo 3 
DRC7_3:  metal1 - overlap para contato de POLY ou ativa 1 
DRC7_4:  metal1 - espaçamento quando (largura >10) 6 
DRC8_1:  via - dimensão 2x2 
DRC8_2:  via - separação 3 
DRC8_3:  overlap sobre metal1 1 
DRC9_1:  metal2 - largura mínima 3 
DRC9_2:  metal2 - espaçamento mínimo 3 
DRC9_3:  metal2 - overlap sobre contato de POLY ou ativa 1 
DRC9_4:  metal2 - espaçamento quando (largura >10) 6 

 

Apêndice 2: O aplicativo Gimp 

 

 O aplicativo Gimp é de grande utilidade no processamento de figuras com o 
objetivo de inseri-las em apresentações como o relatório, por exemplo. 

 Como grande parte das ferramentas desta disciplina não apresentam uma 
interface gráfica de alto poder, uma solução fácil é a captura de janelas em forma de 
bitmap que podem ser posteriormente gravadas em vários formatos como JPEG, por 
exemplo. O aplicativo Gimp permite selecionar janelas isoladamente ou a tela toda, 
para posterior edição. 

 A seqüência para a captura de uma janela (de leiaute de máscaras, pelo 
Ghostview) é a seguinte: 

  > gimp & 

No menu Arquivo, escolher a opção Capturar, depois Tela e na caixa de diálogo 
escolher  Janela Simples. Uma cruz aparecerá e bastará, então, clicar sobre a 
janela desejada. Experimente 
 

Para usar o Gimp:  



21 
 

• Capturar no Gimp usando o comando 'Arquivo→Criar→Captura de tela' 
• Escolher 'Capturar uma única janela' e Atraso de 5s. 
• Selecionar o leiaute do transistor usando o comando 
'Ferramentas→Ferramentas de seleção→Seleção retangular' 
• Redefinir o tamanho do desenho com o comando 'Imagem→Cortar Imagem' 
• Inverter as cores do desenho com o comando 'Camadas→Cores→inverter' 
• Escolher onde a imagem será guardada com o comando 'Arquivo→Salvar 
como'  
• Escolher um nome com extensão jpg (celula_1.jpg – mas, existem outros 
formatos, verifique) respondendo exportar e OK nas perguntas que aparecerão. 
fechar o Gimp. 
 


