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O problema (de
planejamento)

Problema ja esta modelado e com uma representacao ja definida para
especificacao de estados, e uma série de acdes que modificam estes estados. Estes

estados atuam sobre um conjunto de blocos individualizados (distinguiveis).
Portanto a modelagem deste tipo de problema é direta e deve ser feita com

vantagem usando a HLPN (comparado a fazer a rede classica primeiro).

A modelagem do problema fica assim bem simples.
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Voce conseguiria sintetizar a rede de alto nivel (ou colorida)
diretamente do enunciado do problema?

Tente fazer isso, mesmo ja tendo visto a solugao.
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Coloured Petri Nets

Definition 4.3.1. A coloured Petri net (CPN) is defined by a tuple
N = (P, T,Pre,Post,C, cd), where

e P is a finite set (the set of places of N'),

e T is a finite set (the set of transitions of N ), disjoint from P,

e C 1is the set of colour classes,

e cd: PUT — C is the colour domain mapping, and

e Pre, Post € BIPI*ITl are matrices (the backward and forward incidence
matrices of N') such that Pre[p,t] : ed(t) — Bag(ed(p)) and Post|p,t] :
cd(t) — Bag(ed(p)) are mappings for each pair (p,t) € P xT.

B can be taken as the set of mappings of the form f : ed(t) — Bag(ed(p)).
Again, C = Post — Pre is called the incidence matrix.
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Vamos considerar novamente o problema da largada de formula 1, agora seguido de um

checkpoint onde se verifica a posicao de cada carro.

t, P, t;

conf
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p 7
P, P
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macrotransicao
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E possivel dobrar esta rede? O que fazer como o dobramento?
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Historico das redes
CPN

As redes coloridas surgiram nos anos 80 conjugando a representacao grafica
das redes de Petri com o Standard ML, que representa tipos e cores.

No final dos anos 80 e principio dos anos 90 surgiu o ambiente Dsign CPN
proposto pelo mesmo grupo de Ahus, Dinamarca (Kurt Jensen).

A idéia é simplesmente ter um formalismo mais abstrato
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Definicao informal das
CPNs

Kurt Jensen

Coloured Petri Nets (CP-nets or CPNs) is a graphical
language for constructing models of concurrent systems
and analyzing their properties. CP-nets is a discrete-event
modeling language combining Petri Nets and the
functional programming language CPN ML which is based
on Standard ML.
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Aplicacoes

AplicagOes Tipicas

Protocolo de Comunicacao
Redes de Dados

Algoritmos Distribuidos

Sistemas Embarcados

Novas Aplicagcoes

Sistemas de workflow
Sitemas de manufatura
Sistemas multi-agente
Processos de negdcio

Analise de Requisitos
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At a time when it is increasingly
understood that programs must
withstand rigorous analysis,
particularly for systems where safety
is critical, a rigorous language
presentation is even important for
negotiators and contractors; for a
robust program written in an
insecure language is like

a house built upon sand.

Robin Milner

As redes coloridas demarcam uma fase onde se buscava
nao apenas enfrentar a “‘explosao combinatoria”, do espaco
de estados mas garantir o formalismo da modelagem.
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Portanto as redes coloridas (e de alto nivel) devem ser
vistas como um convite a aumentar o nivel de
abstragao dos processos de modelagem em
Engenharia.
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mitos)

As vantagens das redes coloridas seriam:

1. Explorar as simetrias com o objetivo de reduzir o tamanho da rede.

Falha: o grafo é reduzido mas a informacao para para as inscricoes a
complexidade da representacao nao se altera significativamente

2. Ter uma representacao abstrata para a rede classica.
Falha: verdade em principio, mas ter que reduzir a representacao para
rede classica cada vez que deseja fazer analise de propriedades

pode nao ser exatamente uma vantagem.

3. Aumentar o poder de expressao da representacao baseada em
redes.

Falha: simplesmente nao é verdade.
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Uso pratico das redes
CPN

Como no caso das redes classicas o uso pratico das redes CPN esta
associado a Simulacao do modelo, e portanto ao estudo de cenarios
especificos e ao processo de evolucao das marcas.

Temos portanto o mesmo problema de desenvolver métodos
alternativos de analise baseados nas propriedades da rede e fugir do
problema da atingibilidade.

Novos métodos > Verificacao e Model checking
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Processos
especiais

- \ Fig. 1(c) S°PR of N; and N>
Fig. 1(b) Two S°P.
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O problema do
acoplamento com
recursos

O sistema S2PR pode ainda
ser acoplado de modo que
OS processos sequenciais
interferem um no outro
podendo causar atrasos e ate
deadlocks devido a falta de
recursos no momento
devido.

Fig. 1(a) S’PR &3™-order system :

Li, Z.W. and Zhou, M.C., “Deadlock resolution in
a=b=c=1.

automated manufacturing systems: A novel Petri net
approach,” Springer, London, 2009
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Introducgao informal: O problema da alocacao

Escola Politécnica da USP

de recursos

Na indUstria automotiva moderna é
comum se ter varios processos ou linhas
de montagem e nestes um ou mais tipos
de automovel sendo montados em
pipeline. Isso traz um problema, que é
ter o tipo certo de insumo ou recurso no
tempo correto, para a matriz correta.

Um problema similar e igualmente
importante é ter processos homogéneos

mas compartilhando o mesmo centro de
recursos.
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Modelagem
classica

Seja o seguinte sistema de alocacao de recursos, caracterizado
por dois processos concorrentes,

P/T

P process

— ™ Z

\g pProcess
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P process

Prof. José Reinaldo Silva

Escola Politécnica da USP PMR5237

20



Para sintetizar uma rede uma rede colorida devemos
explorar a simetria entre os processos, isto €,
produzir um unico processo que representa tanto o
processo p como o processo g. Neste caso as
marcas passam a ser distinguiveis para representar os
dois processos.
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color U=with p | q;
color I = int;

color P = product U*I;
color E= with e;

varx : U;
vari: I;
E E 2 2'e
case x of
(D 1e 3'e ‘ p= 2‘3
c q=1¢
> =p then 1'¢ 2'¢
of else empty
p=2%¢ E
lqg=1"¢e
3°(q.0) 2'(p.0)
P
g . @
(x,1) (x,i) (x,1) (x,1) (X,1) (x i) (X,1) (x,1) (x,i)
3 3@ Q@0
[x=q]
If x=q
then 1°(q, 1+1)
else empty
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case x of
p=>2e
lg=>1%e

@3‘9
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Binding: (2)2(p.0) New Markin
<X=p, I=0> P @ ‘ ’

case X of case x of

p=>2e T p=>2e
lg=>1%e 17 lg=>1"e
/ i1 PO

2)2e E
265 p o
@3‘e
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Strong type

Binding:
<X=(, I=2>

case X of
p=> 2 e
lg=>1%e
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Outro exemplo

case X of
p=>2e€
| q =1e

@3‘9
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Uma vez respeitado o tipo qualquer possibilidade pode ocorrer.

Binding: O (3) 1'(p.2)+1" (p.4)+1°(9.3) Binding: (3) 17 (P.2)+1 (p,4)+1°(
<X=p, i=2> <X=q, i=3> '
' 1 3
case X of (X, ') 1 (P.2) case x of (x.1) (@:9)
) =>2e
I p=> 2‘e | z=> e o
g=>1e 17 1 (q,3)
/ (x,1) 1(p.2) < (X, |)
- 71
2 |12°e . £ @ p
@ e @ 3'e
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Concorréencia

Binding:
<X=P, I=2>

Binding:
<X=q, I=3>

case X of
p = 2‘9
lg=>1%e

- Csj '3'e
@3‘e

(3) 1" (p.2)+1°(p,4)+1°(q,3)
O
x,i) 1 P.2)+1(q.3)

12

i) [T P2+ (@3

P
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case X of
p=> 2 e
lg=>1¢e

(2)1'(p,2)+1°(q,3)
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........
.........

Gnciando
conflito

A situacao de conflito é similar, s6 que agora levando em conta os tipos

Binding: > (3) 1 (p.2)+1°(p,4)+1°(9.3)  Binding: o (3 (3) 1 (p.2)+1 (p.4)+1°(a.3)
<X=p, I=2> P Q <X=p, I=4> 9
o 17(p,2 N1 (p.4
case x of (i) ] T (P2) case x of i) 1 P4
p=>2e p=>2e
lqg=>1e b lg=>1e \ ‘
/ R / Y
292'e 2)2'e
E (sy P E (Sy P
(®)3e (3)3e
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CPN Elements

Declarations:

o Types, functions, operations and variables.

Each place has the following inscriptions:

e Name (for 1dentification).

o Colour set (specifying the type of tokens which
may reside on the place).

o Initial marking (multi-set of token colours).

Prof. José Reinaldo Silva
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Each transition has the following inscriptions:
 Name (for 1dentification).

* Guard (boolean expression containing some of
the variables).

Each arc has the following inscriptions:

» Arc expression (containing some of the variables).

When the arc expression 1s evaluated 1t yields a
multi-set of token colours.

Prof. José Reinaldo Silva
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Enabling Condition

A binding assigns a colour (1.e., a value) to each
variable of a transition.

A binding element 1s a pair (t,b) where t1s a
transition while b 1s a binding for the variables
of t. Example: (T2,<x=p, 1=2>).

Prof. José Reinaldo Silva
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A binding element 1s enabled if and only if:

e There are enough tokens (of the correct colours on
each mput-place).

e The guard evaluates to true.

When a binding element 1s enabled 1t may occur:

e A multi-set of tokens 1s removed from each
mput-place.

e A multi-set of tokens 1s added to each
output-place.

A binding element may occur concurrently to other
binding elements — iff there are so many tokens
that each binding element can get its "own share".

Prof. José Reinaldo Silva
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CPN Tools Homepage
L+l -
V‘C" 2§~ Google Q ‘i‘

Most Visited » P Getting Started Latest Headlines ~ U Apple D Yahoo! -“ Google Maps [:’ YouTube \X/ Wikipedia » [EJ Bookmarks ~

(cpntools.org PP ——————— B O E & DB 8 - =

CPN Tools o e

@) http://cpntools.org/start

CPN Tools M
* Documentation
* FAQ Home Download Getting Started Documentation Support Contact
* Getting Started
* Licensing
Contact DY ——— =)
. ¥ Tool box -~
Download » Aandiary Binder 0 - -
Publications :.c'::':;" Top Sender Network Recsiver(1) Recsiver(2)
» Monstonng
Support TOO]S o e
» State space 1 (3::8756 b )4+
Search X :\%I: INTXDATA i v Eé::&:c.g‘lg:j]))::
» , 19 T e
: E)E%fn;vai’wtow Lo i i g I'":‘“::':‘: )
CPN Tools is a tool for editing, simulating, and preeh INTXDATA
analyzing Colored Petri nets. o
¥Dedarations
. A ::::::m;x on
The tool features incremental syntax checking » colet INTIOATA :
and code generation, which take place while a it ""
net is being constructed. A fast simulator IZ:E%"E’..? INTAINT
efficiently handles untimed and timed nets. Full B 1022}
and partial state spaces can be generated and > imn —
» Morstors None )
analyzed, and a standard state space report oo :«.bo M k‘&im:
contains such as boundedness

information,
properties and liveness properties.

New Features in Version 3.0

e Support for 64-bit Windows

e Support for running under virtualization
software such as VMWare and Parallels (use
safe mode if you get errors under Parallels)

e New simulator which is up to twice as fast
for both automatic simulation and state
space generation

e Support for prioritized transitions

e Support for real time

The latest version is version 3.0.4 from April

Michael's Blog on CPN Tools

e In All Fairness... (2011/04/20 16:58)
e Graphical User Interface (2011/03/24

14:31)

e The Access/CPN Source Released

(2011/

02/08 10:51)
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Download << CPN Tools Homepage

J @) Download << CPN Tools Home... M‘YJ'J Curso: Modelagem e Design de ... ﬂ + [

a —

v

(€)> | @ http://cpntools.org/download v | (g~ Google Q

)| ?

Most Visited » P Getting Started Latest Headlines v U Apple D Yahoo! -.' Google Maps D YouTube \X/ Wikipedia

» [EJ Bookmarks ~

GAME & APPS

v | cpn tools download (Ml Web Search v o |@ @ | = @ = | Login @ @1 » Yy

CPN Tools
> FAQ

* Licensing
Contact
Download
Publications
Support

* Documentation

* Getting Started

Search | %

Home Download Getting Started Documentation Support Contact

Download

CPN Tools is free software; see here for licensing information.

It should be straight-forward to install CPN Tools; otherwise, read the help pages.

—Windows

Download: [3.04 3]

Mailing list:

¥ Announce (highly recommended, very low traffic)

[ Support (recommended, support questions go here, medium traffic and digest
option available)

E-mail address:

—Linux/Mac 0OS X

We recommend you to download the latest Windows version of CPN Tools and run it
using a virtual machine. Linux users can also download an older version of CPN Tools,
but these versions are not maintained any longer.

Download Linux Version 2.3.5

Download Linux Version 2.2.0
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®+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary :
Create ifx=q
Hierarchy gl‘seen elm é%;” 1)
Monitoring
Net o
Simulation 3.3 (q,0)
State space PLA 3“W7J
Style (x,1)
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report [ then 1° (p,i+1)
» Simulator Process “e(R ‘ _ else empty
¥ ResourceAllocation.cpn
Step: O
Time: 0
» Options
» History
¥ Declarations
» colset U
»colset I
» colset P
»colset E
= var x
= vari
» Monitors
Top

Resource Allocation Example
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#+* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 1
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
»colset E
»var x
e vari
» Monitors
Top

150

if x=p then &

else empty

Resource Allocation Example

Prof. José Reinaldo Silva
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then 17 (q,i+1)
else empty

2°
P 20 2 (’q,O)
| T1 |[x=q]

else empty

~

p,i+1)
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“* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: 2
Time: 0
» Options
» History
¥ Declarations
» colset U
» colset I
» colset P
» colset E
= var X
= vari
» Monitors
Top

Resource Allocation Example
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then 17 (q,i+1)
else empty

then 17 (p,i+1)
else empty
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#* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary _
Create ifx=q
Hierarchy teT:: elmgz;“)
Monitoring
Net
Simulation
State space
Style
View
> Help
¥ Options
Commands between autosave : 50
» Simulation Report [ then 1° (p,i+1)
» Simulator Process : i _ else empty
¥ ResourceAllocation.cpn
Step: 3
Time: 0
» Options
» History
¥ Declarations
»colset U
»colset I
» colset P
»colset E
= var x
e vari
» Monitors
Top

Resource Allocation Example
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“* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary

Create if x=q .
then 17 (q,i+1)

else empty

Hierarchy
Monitoring
Net
Simulation
State space
Style
View
» Help
¥ Options
Commands between autosave : 50
» Simulation Report ) then 1° (p,i+1)
» Simulator Process ’ ) _ else empt;'
¥ ResourceAllocation.cpn
Step: 4
Time: 0
» Options
» History .
¥ Declarations if x=
» colset U =
» colset I
» colset P
»colset E
= var x
= vari
» Monitors
Top

Resource Allocation Example
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®* CPN Tools (Version 3.0.4, April 2011)

¥Tool box
Auxiliary

Create if x=q .
then 17 (q,i+1)

else empty

Hierarchy
Maonitoring
Net
Simulation
State space
Style
View
> Help -
¥ Options 2. (p,0)++
Commands between autosave : 50 lnf(xq=L ™
» Simulation Report thenpl‘ (p,i+1)
» Simulator Process ’ . | else empt;I
¥ ResourceAllocation.cpn
Step: S
Time: 0
» Options
» History
¥Declarations
»colset U
»colset
» colset P
»colset E
B varx
> yari
» Monitors
Top

Resource Allocation Example
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¥Tool box
Auxiliary
Create
Hierarchy
Maonitoring
Net
Simulation
State space
Style
View

»Help

¥ Options

» Simulation Report
» Simulator Process
¥ ResourceAllocation.cpn
Step: S
Time: 0

» Options

» History

¥ Declarations
» colset U
» colset I
» colset P
»colset E
»var x
> yar

» Monitors
Top

®+* CPN Tools (Version 3.0.4, April 2011)

Commands between autosave

Resource Allocation Example
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if x=q
then 17 (q,i+1)
else empty

22 (p,0)++

1" (q,0)
=g )
then 17 (p,i+1)

else empty
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¥Tool box

Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space
Style
View
»Help
¥ Options
Commands between autosave : 50
» Simulation Report
» Simulator Process

¥ ResourceAllocation.cpn

Step: 6
Time: 0

» Options

» History

¥ Declarations
»colset U
»colset I
»colset P
»colset E
= var X
= vari

» Monitors
Top

if x=q
then 17 (qg,i+1)
else empty

~

if %=p ‘
then 17 (p,i+1)
else empty

Resource Allocation Example
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Modelagem classica para o
problema dos filosofos

O exemplo dos filésofos
fi

Prof. José Reinaldo Silva
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%+ CPN Tools (Version 3.0.4, April 2011) M=3

¥Tool box
Auxiliary
Create
Hierarchy
Monitoring
Net
Simulation
State space PH.all()
Style Think  S) 1" ph(1)++
L 1 ph(2)++
»Help PH 1'ph(3)++
¥ Options 1 ph(4)++
Commands between autosave : 50 1" ph(5)
» Simulation Report
» Simulator Process Take;
¥ DiningPhilosophers.cpn Chopsticks
Step: 4
Time: 0
» Options
» History
¥ Declarations
»valn
» colset PH
» colset CS
»varp
»fun Chopsticks
» Monitors
Page

Binder 0
Page

Chopsticks(p)

Put Down Chopsticks(p)
Chopsticks

)
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CPNs

* Diferente abordagem, mais abstracao

* Classificar elementos do projeto segundo tipos bem definidos
* A observancia dos bindings (strong type) é fundamental

* Explorando as simetrias (pode nao aparecer desta forma)

* Maior facilidade para reutilizacao

Prof. José Reinaldo Silva
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Alguns problemas...

 Diferente abordagem, mais abstracao
Depende do background do designer, mas a questao base é escolher entre fazer a

o modelagem ja direto em rede colorida ou comegarJelq rede classica
* Classificar elementos do projeto segundo tipos bem definidos

Consequencia do item anterior e novamente € uma questao de diciplina.

* A observancia dos bindings (strong type) é fundamental ,
Comum nos processos estruturados, choca-se com a excessiva carga funcional que os

engenheiros costumar dar aos projetos.
* Explorando as simetrias (pode nao aparecer desta forma)

De fato deve ser feito também no caso classico, o tipo de simetria a ser explorada é que é

* Maior facilidade para reutilizacio el
Sera amplicado no tanto no caso classico com no das redes de alto nivel com a introdugao da
hierarquia, mas continua mais forte no caso das redes de alto nivel, embora a escolha da
componente reutilizavel seja mais complexa.

Prof. José Reinaldo Silva

Escola Politécnica da USP PMR5237

49




Sobre o formalismo

Portanto, a Unica maneira de minorar os problema é voltar ao
formalismo para explorar melhor a analise de propriedades,
especialmente os invariantes.

O formalismo também abre a possibilidade de se ter outras interfaces
mais amigaveis e adaptadas aos ambientes de trabalho, tendo o CPN
Tools (por exemplo) por tras. Nesse caso a aderéncia ao formalismo
das CPNs é importante e fundamental para a credibilidade da
ferramenta.

Prof. José Reinaldo Silva
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CPN : definicao formal

Definition: A Coloured Petr1 Net 1s a tuple CPN = (2, P, T, A, N,
C, G, E,]I) satisfying the following requirements:
(1) X 1s a finite set of non-empty types, called colour sets.
(1) P 1s a finite set of places.
(1) T 1s a finite set of transitions.
(1v) A 1s a finite set of arcs such that:
* PAnT=PnA=TnA=0.
(v) N 1s a node function. It 1s defined from A mto PxT u T xP.

(vi) C 1s a colour function. It 1s defined from P into X.

Prof. José Reinaldo Silva
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(vit) G 1s a guard function. It 1s defined from T into expressions
such that:

o VteT: [Type(G(t)) =Bool A Type(Var(G(t))) c X].

(vin) E 1s an arc expression function. It 1s defined from A into
expressions such that:

* VaeA: [Type(E(a)) = C(p(a))ms » Type(Var(E(a))) c X]
where p(a) 1s the place of N(a).

(ix) I 1s an initialization function. It 1s defined from P into
closed expressions such that:

* VpeP: [Type(I(p)) = C(p)ms].
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