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Laboratório de ITS: SIG Dinâmico e Mapas Virtuais 

 Para esse laboratório, serão abordados temas como a utilização de um software de 

Sistema de Informação Geográfica (SIG), a elaboração de mapas de temperatura e a 

manipulação interativa de mapas virtuais em plataformas on-line. O procedimento a seguir 

caracteriza-se como uma sequência do primeiro Laboratório de ITS (Sistemas Inteligentes 

de Transporte) sobre banco de dados, já que os dados aqui utilizados são os resultados do 

tratamento dos dados feito no SQL Server, a partir da fonte de dados da SPTrans. Nesse 

sentido, o laboratório prossegue como um estudo de caso dos ônibus rastreados, partindo 

de um banco de dados, tratando-os e, posteriormente, analisando-os por ferramentas como 

softwares de SIG e plataformas virtuais para então utilizar softwares de microssimulação a 

fim de aplicar conceitos de ITS. 

 O laboratório está dividido em duas partes: 

 1ª parte: QGIS: Software colaborativo de Sistemas de Informação Geográfica 

 2ª parte: Funcionalidades de mapas virtuais 

 

 

1ª parte - Laboratório de ITS – QGIS: Software colaborativo de 

Sistemas de Informação Geográfica 

Utilizaremos o software de fonte aberta QGIS. Neste software, diferentes usuários 

adicionam complementos opcionais ao programa, tais como mapas, ferramentas de 

manipulação de vetores, entre outros. 

 

 Instalando os complementos necessários 

1) Abra o Software QGIS Desktop 2.2.0, pela área de trabalho ou função executar 

do Windows; 

2) Na barra de ferramentas localizada na parte superior da tela, vá em Plugins > 

Manage and install plugins; 

Nota: É possível que a sua máquina já possua os plug-ins instalados. Se for o 

caso, ignore os passos 3 e 4. 

3) O programa irá carregar o menu de complementos. Na busca, digite 

OpenLayers e selecione o OpenLayers Plugin.  Clique em Install plugin e 

aguarde a instalação; 

4) Busque MMQGIS e repita o procedimento para instalar o plugin e feche a janela 

de plugins; 
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 Carregando o banco de dados 

 Conforme vimos no último laboratório, o sistema de banco de dados nos fornecerá 

uma tabela em Excel com os dados referentes a movimentação dos ônibus na Avenida 

Consolação, no sentido bairro centro, no horário de pico da tarde.  Primeiramente, 

devemos converter esses dados para um formato que o QGIS consiga extrair as 

informações necessárias. 

5) No diretório E:/PTR2580/Lab 01 – Banco de Dados, procure por um arquivo do 

excel (.xlsx). Abra o arquivo; 

 Nota: Caso não encontre o arquivo nesta pasta, acesse o diretório 

E:\PTR2580\Lab02 - SIG dinâmico e mapas virtuais\Backup e abra o arquivo 

Dados_Consolação.xlsx 

6) Na barra de ferramentas, vá em Arquivo > Salvar Como; 

7) No campo Nome do arquivo, escolha Dados_Consolaçao. Escolha o diretório 

E:\PTR2580\Lab02 - SIG dinâmico e mapas virtuais. Em Salvar como tipo, 

escolha CSV(separado por vírgulas)(*.csv) e salve o arquivo; 

8) O excel apresentará duas mensagens. Aperte “sim” e “sim” e após salvar, feche o 

programa; 

9) Volte ao Software QGIS. Na barra de ferramentas, escolha Project > New; 

10)  Primeiramente, carregaremos os dados provenientes do arquivo que criamos. 

Na barra de ferramentas, vá em Layer > Add Delimited Text Layer; 

 Clique em Browse... e escolha o arquivo Dados_Consolacao.csv. 

 Em File Format, escolha Custom Delimiters e apenas Semicolon como 

separador (ponto e vírgula). 

 Em Field Options, marque a opção Decimal Separator is comma. 

 Em Geometry Definition, escolha as colunas Long como X field e Lat 

como Y field. 

 As demais configurações devem continuar padrões. 

Para que o programa reconheça adequadamente os campos que indicam a 
localização do ônibus segundo o sistema WGS-84, configure a janela conforme a 
figura a seguir:  
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(Os campos em vermelho indicam como devem estar os campos) 

 
11)  Clique em OK. Na próxima tela, escolha a projeção WGS84 com EPSG:4326 , que é o 

sistema utilizado pelos GPS dos ônibus da SPTRANS, com o qual trabalharemos; 
 

12)  Você notará que uma camada foi criada com milhares de pontos distribuídos 

numa determinada área. Agora, carregaremos o mapa sobre o qual 

trabalharemos como plano de fundo. Existem diversos mapas gratuitos 

disponíveis, advindos de sistemas como o Google Earth, Google Maps, Bing 

Maps, entre outros. Trabalharemos com o Open Street Maps pois é um mapa 

mais leve e cuja visualização é mais rápida; 

 No menu de ferramentas, vá em Plugins > OpenLayers plugin > Add 

Open StreetMap layer. 

13)  Porém, esta camada foi carregada acima da camada dos pontos. Assim, 

perdemos a visualização dos pontos. Na parte esquerda, no menu de Layers, 

arraste a camada Dados_Consolação para acima da Open Street Map, 

conforme a figura a seguir: 
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Dica: Na parte inferior da tela em Escala, deixe como 1:10.000 para uma melhor visualização 

do Open Street Maps e dos pontos. 

 

 Tratamento dos dados por meio de um buffer 

14)  Agora, devemos separar os dados dos ônibus que se referem exclusivamente 

ao trecho da Consolação o qual estudaremos. Para tanto, criaremos uma linha 

que acompanhe o trecho requisitado. 

 No menu de Layers, desmarque a camada Dados_Consolação para 

melhorar a visualização; 

 No menu de ferramentas, vá Layer > New > New Shapefile Layer ; 

 Em Type, escolha o tipo Line e escolha o diretório 

“E:\PTR2580\Lab02 - SIG dinâmico e mapas virtuais”. 

 Escolha o nome da nova camada como “traçado” e salve. 

 Para começar o desenho da sua linha, na barra de ferramentas, clique 

no ícone “Alternar Edição” , que liberará o menu de edição no QGIS. 

 Ainda no menu de ferramentas, clique no ícone “Add feature” , e 

faça o traçado na Rua da Consolação, iniciando após a paulista e 

terminando um pouco após a Rua Caio Prado. É uma ferramenta de multi-

pontos, então vá clicando para formar um traçado que acompanhe o 

traçado da rua segundo o Open Street Maps. Clique com o botão direito 

para encerrar o traçado e clique em OK para a janela que aparecer. 

 Após terminar o traçado, clique novamente no ícone “Alterar edição” 

 e salve as alterações feitas na camada. O resultado obtido deve ser 

semelhante ao da figura a seguir: 
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15)  Agora, com a linha formada, aplicaremos uma operação de Buffer. Utilizaremos 

para tal, o plugin MMQGIS. No menu de ferramentas, vá em MMQGIS > Create > 

Create Buffers. 

 Na janela de criação, a Source Layer será  a camada traçado. Como Radius Unit 

escolha Meters, com uma largura de 6 metros. 

  Em buffer shape, escolha Flat End. 

 Em Output Shapefile, clique em browse escolha o diretório E:\PTR2580\Lab02 

- SIG dinâmico e mapas virtuais, mas salve como buffer_consolacao. Sua 

configuração deve se assemelhar a da imagem a seguir: 
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16)  Ao final desse processo, devemos obter uma faixa de 12 metros de largura em torno 

do traçado executado. Agora, devemos fazer uma operação de intersecção para 

separar os pontos emitidos pelos ônibus que estejam contidos na região do Buffer. 

Para tal, acessaremos o menu de geoprocessamento do QGIS: 

 Na barra de ferramentas, vá em Vector > Geoprocessing Tools > Intersect. 

 Em Input vector layer, escolha Dados_Consolaçao, que contém todos os pontos. 

 Em Intersect Layer, escolha a camada buffer_consolacao”, que contém o buffer 

criado anteriormente. 

 Como Shapefile de saída, salve com o nome Dados_Trecho no diretório 

E:\PTR2580\Lab02 - SIG dinâmico e mapas virtuais. 

 Marque a opção "Add result to canvas". Sua janela de intersecção deve se 

assemelhar a seguinte: 
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 Clique em OK. Essa operação pode demorar um tempo. Ao finalizar a tarefa, o 

programa irá solicitar um sistema para georreferenciar a camada que está sendo 

criada. Escolha o WGS 84. 

 Ao fim desse processo, feche a janela de Intersecção. Você deve obter uma 

disposição de elementos e camadas conforme a seguinte: 

 

 Agora, para melhor visualização dos pontos, você já pode desmarcar as demais 

camadas auxiliares e deixar apenas as camadas dados_trecho e OpenStreetMap. 
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 Elaboração do mapa de calor (HEATMAP) 

 Com o objetivo de identificar os pontos de retardamento dos ônibus, ou seja, os 

pontos críticos do corredor que Campo Limpo – Rebouças, elaboraremos um Mapa de Calor. 

O QGIS já possui um plugin instalado chamado Heatmap. 

17) Para acessar o plugin, na barra de ferramentas, vá em Raster > Heatmap > Heatmap; 

 Em input point layer, escolha a camada dados_trecho. 

 Em Output Raster, salve no diretório sugerido pelo programa com o nome 

heatmap. 

 Em Radius, devido a grande concentração de pontos (+ de 7.000 pontos) 

escolheremos como 5e-05 em map units. 

 No menu Advanced, escolha 801 Linhas para obter uma melhor visualização. 

 Sua configuração deve se assemelhar à seguinte: 

 

Nota: devido à diferença no número de pontos realizados na intersecção do buffer,  podem 

haver variações no campo das colunas. Isso não causará problemas ao mapa de temperatura. 

 Clique em OK e o Mapa de Calor será gerado. 

18) Ao final dessa operação, é possível notar já um mapa de calor, onde as áreas brancas 

representam a maior concentração de pontos enquanto a parte preta representa pouca 

concentração. Porém, existem vários recursos que melhoram essa visualização; 
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19) Primeiramente, ajustaremos as cores que correspondem à melhor visualização do 

mapa de calor: 

 No menu Layers no canto direito, desmarque as outras camadas e deixe apenas o 

heatmap e o OpenStreetMap. Depois, clique com o botão direito na camada 

heatmap e vá em Properties. 

 Em render type, escolha Singleband pseudocolor. 

 No menu “load min/max values”, escolha Min/Max. 

 No menu Generate new color map, escolha a escala Blues e deixe as outras 

configurações como o padrão. Os seguintes itens devem ser alterados: 

 

 

 Então, Clique em Classify.O QGIS então gerará uma legenda com tons diferentes de 

azul. Cada cor representa uma classe de quantidade de sinais de ônibus emitidos. 

Então, clique em Apply para alterar o mapa no display do programa. 



 
11 

 

 

20) Agora, ajustaremos a transparência para que o mapa de calor não impeça a 

visualização do OpenStreetMap; 

 Ainda em Layer Properties, vá na Aba Transparency. 

 Em Global Transparency, ajuste para 30% e clique em Apply e depois 

Ok para observar o mapa de calor.  

 Ao final dos procedimentos, o seu mapa de calor deve se assemelhar ao 

seguinte: 
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 Carregamento dos pontos de ônibus e semáforos 

 O OpenStreetMaps já representa alguns semáforos embutidos no mapa, mas 

não os pontos de ônibus. Portanto carregaremos, assim como trouxemos os dados dos 

ônibus, a localização dos pontos de ônibus no trecho escolhido, para verificarmos a 

relação entre os locais de retenção de ônibus e os pontos de ônibus. 

21) Repetindo os passos 10 a 11, carregue o arquivo Pontos_Onibus, localizado no 

diretório E:\PTR2580\Lab02 - SIG Dinâmico e Mapas Virtuais 

 Análise do mapa de calor 

 Ao final dos procedimentos realizados, obtivemos um Mapa de Calor 

sobreposto a Rua da Consolação, com os pontos de ônibus do trecho indicados.  

Na barra de ferramentas, vá em Project > Save e salve como Lab 2 - Consolação no 

diretório E:\PTR2580\Lab02 - SIG Dinâmico e Mapas Virtuais.  

 

Exercício 

Descreve com suas palavras o que pode ser observado no HeatMap, já carregados os 

Pontos de Ônibus. 

Carregue no STOA o arquivo Lab 2 – Consolação. 
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2ª parte - Laboratório de ITS - Funcionalidades de mapas virtuais 

  

 Google Earth, Google Maps, Google My Maps, Nasa WorldWind são exemplos 

comuns de recursos, disponíveis na web, úteis para otimizar o georreferenciamento, 

permitindo a operação em mapas virtuais de fácil acesso e edição. Na ferramenta 

Google My Maps, podem ser exploradas as funcionalidades de alocação de pontos 

referenciados a partir de um banco de dados; de delineamento de rotas; do 

carregamento de referências para esses pontos georreferenciados, dentre outras 

utilidades. 

 Nessa perspectiva, a segunda parte desse Laboratório de ITS tem como 

objetivo possibilitar a análise e a representação simplificada dos dados 

georreferenciados em mapas interativos. Os dados utilizados nessa etapa foram antes 

tratados (Laboratório 1: Banco de dados) e depois filtrados por um buffer, em um 

Sistema de Informação Geográfica (SIG) (Laboratório 2 - 1ª parte: QGIS software 

colaborativo de Sistemas de Informação Geográfica).     

 Preparação de planilhas 

 Deve-se preparar uma planilha com as coordenadas referenciadas – 

latitude e longitude - dos pontos obtidos em um banco de dados, como de 

ônibus rastreados ou de qualquer outra origem. Nesse caso, será utilizada a 

planilha com os pontos do trecho delimitado pelo buffer, procedimento 

realizado na primeira etapa do Laboratório. Os pontos dessa planilha serão 

expostos no mapa virtual, na forma de pequenos balões, para delineamento de 

rotas. A planilha deve conter: 

 máximo de 1000 pontos. 

 três colunas:  HORÁRIO (utilizado como identificador do ponto) 

    LATITUDE 

    LONGITUDE 

Como a planilha obtida do QGIS (Quantum GIS), correspondente ao 

trecho demarcado pelo buffer, contém mais de 1000 pontos e apresenta outras 

informações, deve-se adequá-la à quantidade exigida e às informações 

necessárias (apenas horário, latitude e longitude). A planilha correta 

PLANILHA_ BUFFER, previamente ajustada às exigências, encontra-se no 

diretório: E:\PTR2580\Lab 02 - SIG dinâmico e mapas virtuais 

 

 Criação de um novo mapa 

 

Para criação do mapa virtual, o Google MyMaps pode ser acessado pelo link: 

https://www.google.com/maps/d/splash?hl=en_US&app=mp. É necessário 

ter uma conta Gmail e efetuar o login. 

https://www.google.com/maps/d/splash?hl=en_US&app=mp
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Na página inicial, seleciona-se a opção “Criar Novo Mapa”. 

 

 Carregamento da planilha 

Para carregar uma planilha, deve-se ter uma Camada, cuja indicação é dada em 

um quadro branco no canto superior esquerdo da tela. A nova camada já é 

existente e indicada por “Camada sem título”, mas pode ser inicializada 

também por “Adicionar Nova Camada”. Os passos seguintes são:  

 Renomear camada, clicando sobre o nome “Camada sem título”. 

Exemplo: “Ônibus SPTrans na Consolação”. 

 Abaixo do título da camada, selecionar a opção “Importar”.  

 O upload da planilha pode ser feito do próprio Google Drive ou de um 

diretório do Computador. 

 Pela opção “Selecionar um arquivo do computador”, abrir a planilha 

preparada. Aguarde o upload. Exemplo: PLANILHA_BUFFER. 

 No quadro “Escolher colunas para posicionar marcadores”, selecionar 

as referências geográficas, como endereços ou coordenadas. Escolher 

LATITUDE e LONGITUDE. [Imagem 1] 

     No quadro “Escolher uma coluna para identificar seus marcadores”, 

selecionar a coluna utilizada para identificação. Nesse caso, escolha 

HORÁRIO. [Imagem 2] 

 Selecione Concluir e aguarde o carregamento dos pontos. 

 

 Personalização dos pontos e do mapa 

 

A edição dos pontos é feita de acordo com suas finalidades. Pode-se 

estabelecer, entre outros objetivos, diferentes cores e formatos para cada 

período de uma frota de ônibus (Ex.: cor amarela – ônibus 17hrs às 18hrs), ou 

para cada trecho do mapa analisado (Ex.: cor verde – paralelas a Av. 

Consolação), ficando a escolha por conta do aluno. 

 

 Na indicação da camada, ao lado de “Todos os itens”, é possível clicar no 

botão  . Nessa opção, ocorre a personalização de todos os pontos, 

quanto à cor e ao formato do ícone indicador. Ao selecionar “Mais 

ícones”, existem ícones personalizados para indicar pontos de 

interesse, tipos de transporte ou qualquer outra possibilidade do 

diretório do aluno.  
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 Para a personalização individual dos pontos, deve-se selecionar “Estilo 

Uniforme” e mudar para “Estilos individuais”, abaixo da indicação da 

camada, ainda no quadro branco. Logo, para cada ponto aparecerá a 

opção  a fim de mudar a cor e o ícone, analogamente. Ainda na 

opção “Estilos individuais”, é possível mudar a identificação do 

marcador, para qual havíamos antes colocado HORÁRIO. 

 Na opção “Mapa Básico”, na extremidade inferior do quadro branco, é 

possível escolher outros planos de fundo para o mapa.  

 Ao selecionar um ponto no mapa, é possível editar o marcador e suas 

coordenadas, deletá-lo, traçar rotas até esse ponto e ainda carregar 

referências. O carregamento de geotags (informações, como fotos ou 

outros dados, carregadas para certa localização geográfica), pela opção 

 , pode ser feito com imagens e vídeos do diretório ou da própria 

Web.  

  

 Delineamento de rotas 

 

O delineamento de rotas pode ser feito manualmente pela opção “Desenhar 

linha”, indicada por , ou pela opção  chamada de “Adicionar rotas”, na 

qual são escolhidos dois pontos ou mais  e a rota é delineada automaticamente. 

Para cada trajeto manual ( )      ou           rota automática ( ) , aparecerá 

uma nova camada indicando-as. 

 Para a opção “Desenhar linha” ( ), o cursor será trocado por um 

ícone em cruz, a partir do qual criam-se e ligam-se pontos. Há a opção 

de escolher o tipo de trajeto (carro, bicicleta e pedestre), além da 

possibilidade de se desenhar formas diversas, utilizando os pontos 

como vértices. Ao selecionar as formas, é possível renomeá-las com 

algum propósito e também observar a área em hectares (ha) e o 

perímetro em metros (m). 

 Para a opção “Adicionar rotas” (  ), pode-se também escolher o 

usuário (carro, bicicleta e pedestre). Após essa escolha, no quadro 

branco, aparecerá uma nova camada com indicações de ponto A e de 

ponto B, os quais devem ser escolhidos do mapa. Aqui a rota será 

automática. Para adicionar mais pontos, basta selecionar, na camada, a 

opção “Adicionar destino”. 

 Para medir distâncias, basta selecionar  e escolher um ponto de 

origem e um ponto final. Essa opção também permite medir áreas, 

desenhando os pontos como vértices de um formato poligonal. 
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 Compartilhamento, edição simultânea e formatos de exportação 

No quadro branco, há a opção “Compartilhar”. Nessa opção, pode-se 

compartilhar o link e escolher o caráter do acesso, como público ou particular 

(para o próprio usuário ou também para usuários específicos). Também pode-

se habilitar a edição do mapa como simultânea para outros usuários, 

convidando-os, tendo estes que ter uma conta gmail.  

Ao lado da opção compartilhar, existe um menu com outras 

funcionalidades, do lado direito (indicada por três pontos). Dentre elas, a 

“Exportar para KML”, na qual possibilita-se o download do arquivo em 

formato KML, caracterizado como um arquivo GIS, isto é, um arquivo 

correspondente a um Sistema de Informação Geográfica. O formato KML é 

tipicamente utilizado nos programas de localização virtuais – como Google 

Maps e Google Earth -, além de outras plataformas de georreferenciamento, 

como o QGIS (Quantum GIS). 
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